Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

a different kind of output in the show int gi 2/0/38

Hi to all

Good morning

I am getting some weird information on the status of the port which I never see before

And also I did not find anything on internet that helped me to understand this.

Few days ago we bring a new Storage NetApp which is VM kind product.

I did some port channels configuration  and allow the LACP protocol on the ports connected to storage

And connect the ports with switches and storage unit

There are two switches 3750 and 2960

I make the ports in trunk mode and put them in respective channel groups

CONFIG and OUTPUT ON 3750

sw-3750 #sh run int gi 1/0/43

Building configuration...

Current configuration : 280 bytes

!

interface GigabitEthernet1/0/43

description "Connection to eoa port (c) for controller B of NetApp"

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 50

switchport mode trunk

spanning-tree portfast

channel-protocol lacp

channel-group 4 mode active

end

***************************************************************************************

sw-3750 #sh interfaces gi 1/0/38 status

Port      Name                              Status       Vlan       Duplex            Speed Type

Gi1/0/38  "Connection to eoa connected      trunk      a-full a-1000     10/100/1000BaseTX

***************************************************************************************

sw-3750 #sh int gi 1/0/38

GigabitEthernet1/0/38 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is fc99.47d3.0c26 (bia fc99.47d3.0c26)

  Description: "Connection to eoa port (port a) for controller A of NetApp"

  MTU 9000 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:23, output 00:00:02, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 75000 bits/sec, 36 packets/sec

  5 minute output rate 791000 bits/sec, 65 packets/sec

     9813218 packets input, 6939842236 bytes, 0 no buffer

     Received 3968 broadcasts (3952 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 3952 multicast, 0 pause input

     0 input packets with dribble condition detected

     10305920 packets output, 12446905848 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

but on 2960 I am getting totally different output

CONFIG AND OUTPUT ON 2960

sh run int gi 2/0/43

Building configuration...

Current configuration : 242 bytes

!

interface GigabitEthernet2/0/43

description "Connection to eoa port (c) for controller A of NetApp"

switchport trunk allowed vlan 50

switchport mode trunk

spanning-tree portfast

channel-protocol lacp

channel-group 3 mode active

end

***************************************************************************************

sw1#sh interfaces gi 2/0/43 status

Port      Name                              Status       Vlan       Duplex            Speed Type

Gi2/0/43  "Connection to eoa   notconnect   trunk      a-full a-1000   10/100/1000BaseTX

***************************************************************************************

sw1#sh interfaces gi 2/0/43

GigabitEthernet2/0/43 is up, line protocol is down (notconnect)

  Hardware is Gigabit Ethernet, address is f4ea.675e.8a2b (bia f4ea.675e.8a2b)

  Description: "Connection to eoa port (c) for controller A of NetApp"

  MTU 9000 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:28, output 00:00:06, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     3939 packets input, 504192 bytes, 0 no buffer

     Received 3939 broadcasts (3939 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 3939 multicast, 0 pause input

     0 input packets with dribble condition detected

     8181 packets output, 815357 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

The thing I did not understand is why I am getting not connect on 2960

And on 2960 every port that I put in channel group is giving me same information. While its different on 3750

2960 says not connected and 3750 says connected.

any help will be appreciated

thanks

11 REPLIES

a different kind of output in the show int gi 2/0/38

Line protocol down means that it doesn't see a physical connection to the port, like a bad cable or something is misconfigured somewhere. Does the netapp interface that connects to the 2960 have lacp configured? If you're not sure, have you tried taking the lacp configuration off of the 2960 port to see if the interface would come up? If it does, the netapp isn't configured for an etherchannel....

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

a different kind of output in the show int gi 2/0/38

Hello John

first of all thanks for your quick response and reply

yes the netapp is configured for lacp because the ports on 3750 are showing connected (connected) just the ports on 2960 is not showing connected (notconnected) .

About the cable, all the cables should not be bad since there are 4 ports connected to 2960 and 4 ports connected to 3750. and after work when people will leave the office then i will try to take off the LACP config and see how it goes and post the information here

thanks

Gaurav

New Member

a different kind of output in the show int gi 2/0/38

Hello john

i try to took away the channel-protocol lacp with the

no channel-protocol lacp

but it still says not connected in both the

sh interfcaes gi 2/0/38 and

sh interfaces gi 2/0/38 status

what do you think what could be the issue here???

thanks

a different kind of output in the show int gi 2/0/38

As my previous post, there are really only two options that I can think of: bad connection (bad cable, netapp port down) or something configured incorrectly in the netapp. We're doing this same exact thing now, and I was told that Netapp didn't require etherchannels, so we opted not to do them for one reason or another. The ports wouldn't come up, and the reason was that Netapp configured for lacp but I hadn't done that and the port was showing down.

Do you have vlan 50 created on the switch? You have that as the only allowed vlan on the switchport, but if it's not created that could be a reason as well I suppose...

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: a different kind of output in the show int gi 2/0/38

Thanks again for your reply John

yes the vlan 50 is being created on both switches (3750 and 2960)

My colleague who is working on NetApp told me few days ago that NetApp requires the interface group which is basically a channel group.atttached is the picture of that

thats why i create the port channels and add the port in port group.

regarding cables i know they work because those attached in different setup

this port channel configuration exists in both 3750 and 2960. just 2960 config does not work and ports shows not connected.

thanks

Gaurav

a different kind of output in the show int gi 2/0/38

Unfortunately, I can't help with the Netapp stuff. You could try to change your mode to passive on the channel group to see if that makes a difference, but you should be able to negotiate even if both sides were active-active.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: a different kind of output in the show int gi 2/0/38

thats ok John and thanks for your quick responses

appreciate that

thanks

gaurav

PS i will try to figure it out today and if something comes up i will post here

Re: a different kind of output in the show int gi 2/0/38

Please do...I'd be interested to hear what was causing the issue...

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Gold

a different kind of output in the show int gi 2/0/38

I don't think this is a Layer 1 issue because you have "up/down".  However, let's eliminate that bit.

Try this:

1.  Command:  test cable tdr interface G 2/0/43;

2.  Wait for approximately 5 to 7 seconds;

3.  Command:  sh cable tdr interface G 2/0/43; and

4.  Post the output to #3.

How many interfaces are connected to your NetApp server?  If there are 2 or more, are they all going to the 3750 and/or 2960S switch?

New Member

Re: a different kind of output in the show int gi 2/0/38

In your interface configuration you have switchport trunk allowed vlan 50 implying that you are only using a single VLAN. So there is no need for  switchport mode trunk. You could just as well change it to switchport mode access.

This is just an observation and not mandatory.

I had a similar situation with UP, NOT CONNECTED status back at my office.

The engineer working on the server insisted that the LACP is misconfigured on the production 3750 switch. I had to take a spare switch, connect it directly to each other in a port-channel with LACP in order to convince the server guy that the LACP is definitely working on the production 3750 switch. Once the NIC's were properly configured on the server for LACP, the interface status changed to UP, UP.

Ensure that the NetApp server has its NIC's configured for  teaming using LACP.

New Member

Re: a different kind of output in the show int gi 2/0/38

Thanke Kevin for your reponse

I will surely tlak with my colleague whose is working on the Netapp

adn see how it goes

Thanks

gaurav

663
Views
0
Helpful
11
Replies