Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

about bittorrent.pdlm,please help me

hi,everyone

i have a 3640 router with c3640-i-mz.12.2-12c.bin IOS and i donwloaded the new bittorent PDLM to block the bitcomet application . i loading the pdlm by examples and make a test on the Bitcomet application,but do not limiting the Bitcomet application.

please help me.ASAP...

show run:

ip subnet-zero

ip cef

!

ip nbar pdlm flash:bittorrent.pdlm

!

!

!

class-map match-all bittorrent

match protocol bittorrent

!

!

policy-map bittorrent-policy

class bittorrent

police 8000 1500 1500 conform-action transmit exceed-action drop violate-ac

tion drop

!

!

controller E1 0/0

!

controller E1 0/1

!

!

!

interface FastEthernet0/0

ip address 192.168.30.200 255.255.255.0

ip nat outside

ip nbar protocol-discovery

duplex auto

speed auto

service-policy input bittorrent-policy

service-policy output bittorrent-policy

!

interface FastEthernet2/0

ip address 10.0.0.1 255.255.255.0

ip nat inside

ip nbar protocol-discovery

duplex auto

speed auto

service-policy input bittorrent-policy

service-policy output bittorrent-policy

!

Router#sh flash

System flash directory:

File Length Name/status

1 6166828 c3640-i-mz.122-12c.bin

2 3100 bittorrent.pdlm

[6170056 bytes used, 10607160 available, 16777216 total]

16384K bytes of processor board System flash (Read/Write)

8 REPLIES
Community Member

Re: about bittorrent.pdlm,please help me

regards

xfei

Community Member

Re: about bittorrent.pdlm,please help me

hai there :)

just googling,

try this link

http://cetamac.blogspot.com/2006/01/alternative-managing-bittorrent.html

rgds,

hw

Re: about bittorrent.pdlm,please help me

Hi ,

Can u pls check wheter you are getting traffic in the class you have defined.

sh policy-map interface fa2/0 bittorrent-policy input

regards

vanesh k

Community Member

Re: about bittorrent.pdlm,please help me

this

Router#sh policy-map interface fa 2/0

FastEthernet2/0

Service-policy input: bittorrent-policy

Class-map: bittorrent (match-all)

1386 packets, 695870 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: protocol bittorrent

police:

8000 bps, 1500 limit, 1500 extended limit

conformed 1206 packets, 454815 bytes; action: transmit

exceeded 111 packets, 149892 bytes; action: drop

violated 69 packets, 91163 bytes; action: drop

conformed 0 bps, exceed 0 bps, violate 0 bps

Class-map: class-default (match-any)

1002783 packets, 807842225 bytes

5 minute offered rate 1057000 bps, drop rate 0 bps

Match: any

Service-policy output: bittorrent-policy

Class-map: bittorrent (match-all)

235 packets, 108644 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: protocol bittorrent

police:

8000 bps, 1500 limit, 1500 extended limit

conformed 218 packets, 83572 bytes; action: transmit

exceeded 11 packets, 16108 bytes; action: drop

violated 6 packets, 8964 bytes; action: drop

conformed 0 bps, exceed 0 bps, violate 0 bps

Class-map: class-default (match-any)

765505 packets, 441246343 bytes

5 minute offered rate 670000 bps, drop rate 0 bps

Match: any

Re: about bittorrent.pdlm,please help me

Hi ,

As per your output , policing is working fine for bittorent .

conformed 1206 packets, 454815 bytes; action: transmit

exceeded 111 packets, 149892 bytes; action: drop

violated 69 packets, 91163 bytes; action: drop

pls let me know what is the problem you are facing now.

regard

vanesh k

Community Member

Re: about bittorrent.pdlm,please help me

thx for your reply

that is a test on my backup router.if the test succeeded,i will do it on my router.But do not limiting the Bitcomet application now,i still have a upload(200k+) and download(200k+)on my test pc(only one). so i need your help,pls help me,thank u

regard

xfei

Re: about bittorrent.pdlm,please help me

Hi Saif,

Pls do one thing to see wheter bitcomet is using some other protocols also , under the police command , give a drop for the confirmed packets too .

pls check and let us know.

regards

vanesh k

Community Member

Re: about bittorrent.pdlm,please help me

regards

xfei

433
Views
1
Helpful
8
Replies
CreatePlease to create content