Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

about cisco 2500 dynamic nat

i use cisco 2500 to be my router

and i use pppoe

my ios is 12.2(15t)

i use dynamic nat to transfer 22 21 80 port to my local ip

but it is not work

below is my configuration

logging queue-limit 100

enable secret 5 xxxxxxxxxxxx

enable password xxxxxxx

!

ip subnet-zero

ip host xxxxxxx 192.168.1.3

ip name-server 168.x.x.1

ip dhcp excluded-address 192.168.1.2

ip dhcp excluded-address 192.168.1.3

!

ip dhcp pool ABC

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.2

dns-server 168.95.1.1

!

vpdn enable

!

vpdn-group homelee

request-dialin

protocol pppoe

!

!

!

!

interface Ethernet0

ip address 192.168.1.2 255.255.255.0

ip nat inside

no ip route-cache

no ip mroute-cache

!

interface Ethernet1

no ip address

no ip route-cache

no ip mroute-cache

pppoe enable

pppoe-client dial-pool-number 1

!

interface Serial0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

clockrate 64000

!

interface Serial1

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

interface Dialer1

ip address negotiated

ip access-group 101 out

ip nat outside

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username xxxxxxx@ip.hinet.net password 0 xxxxxxx

!

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source static tcp 192.168.1.3 21 59.xxx.xxx.xx 21 extendable

ip nat inside source static tcp 192.168.1.3 22 59.xxx.xxx.xx 22 extendable

ip nat inside source static tcp 192.168.1.3 80 59.xxx.xxx.xx 80 extendable

ip nat inside source static tcp 192.168.1.3 20 59.xxx.xxx.xx 20 extendable

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

!

line con 0

line aux 0

transport input all

line vty 0 4

password xxxxxxx

login

!

end

somebody can help me ??

thank you very much

  • LAN Switching and Routing
1 REPLY

Re: about cisco 2500 dynamic nat

Hi Lee

I dont think you will be able to do a dynamic NAT without any public(static) ip configured on your router.

you have your dialer interface configured for ip address negotiated which i feel may recieve dynamic ips on connecting to the SP..

In this case you wont be able to do or configure static nat in your router..

If you are sure about the public ip from your SP then you can configure a loopback interface and assign the same to that interface.

But in this case you need to make sure that your ISP have routing entry or attributes pointing towards your User ID for reaching the ip address..

regds

134
Views
0
Helpful
1
Replies
This widget could not be displayed.