Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Acccess to Internet using NAT

We have recently leased an internet connection in our office which comes from the service provider as radio link and BW is 2M. I have clients more than 60 that will share the connection and access internet. I have configured a Cisco 2600 router as below:

Building configuration...

Current configuration : 988 bytes

!

version 12.2

no service single-slot-reload-enable

no service timestamps debug uptime

no service timestamps log uptime

no service password-encryption

!

hostname Router

!

no logging on

enable secret 5 XXXXXXXXXXXXXXXXXXXXXXX

!

username xyz privilege 15 password 0 xyz

clock timezone GMT 6

ip subnet-zero

!

!

no ip finger

no ip domain-lookup

!

no ip dhcp-client network-discovery

!

!

!

interface Ethernet0/0

ip address 192.168.1.1 255.255.255.240

ip nat inside

full-duplex

!

interface Ethernet0/1

ip address 203.xx.xxx.xx 255.xxx.xxx.xxx

ip nat outside

full-duplex

!

ip nat pool Hide 203.xxx.xxx.51 203.xxx.xxx.60 netmask 255.xxx.xxx.xxx

ip nat inside source list 10 pool Hide overload

ip classless

ip http server

!

access-list 10 permit 192.168.1.0 0.0.0.15

!

line con 0

transport input none

line aux 0

line vty 0 4

password xxxx

login local

line vty 5 15

no login

!

end

So far I have read regard NAT it degrades performance as it need to translate every data packet comes from the source and goes to internet.

So a question comes in my mind is there any other way how I can share this connection among users with private ip address? Or NAT is the only method to share internet connection among users with private ip addresses?

If possible how?

Everyone's tags (4)
2 REPLIES
Purple

Acccess to Internet using NAT

Hi,

This is the only solution as private addresses are not routeable on the internet and routers should be configured to drop packets with a src IP in the RFC1918 range.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Acccess to Internet using NAT

Hi,

Thank you very much for the reply.

Regards,

Sayeed

283
Views
0
Helpful
2
Replies
CreatePlease to create content