Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

access point management ip

Hi all, if I have 2 ssid's on my access points , currently vlan 1 is the management ip, but I want it to be on vlan 2, what do I need to do for this ?

14 REPLIES
Community Member

Re: access point management ip

Remove the IP address on the VLAN 1 bvi and put an ip on the VLAN 2 BVI.

Community Member

Re: access point management ip

Hi, I cannot see the an interface called bvi2 ?, if so how do i create a bvi2, I basically added another ssid using the gui and mapped it to a vlan. how do I put the ip to this ? can you help

Community Member

Re: access point management ip

Hi on your AP you have 2 SSID's = Trunk Port (assuming Autonomous AP) then on the Fast Ethernet you will have 2 sub interfaces - simply remove the IP address on VLAN 1's subinterface and put an IP address on the sub interface for the VLAN that you would like to have as management. Ensuring that it lies in the same subnet that you have used for that specific VLAN.

Community Member

Re: access point management ip

can you please give me an example of this? so I can see what the config looks like, I would of thought that if I Just put the ip address on the BVI it would be ok? as im sure the radio for both ssid would bind to the BVI? would this work ?

Community Member

Re: access point management ip

this is exactly how I have this solved....

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

hold-queue 160 in

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.2

encapsulation dot1Q 2

service-policy input voice

service-policy output voice

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

!

interface FastEthernet0.44

encapsulation dot1Q 44

ip address 192.168.44.26 255.255.254.0

no ip route-cache

bridge-group 44

no bridge-group 44 source-learning

bridge-group 44 spanning-disabled

VLAN 44 is my main VLAN and also my management VLAN for all WLAN AP'S

This could also be done by setting up a VLAN in the GUI that wont be used, then going into the CLI and removing the Radio config for that VLAN - then you would have a Management-only VLAN configured :-)

Please rate if it helps...

Community Member

Re: access point management ip

Hi

What do I do with the BVI interface which I have at the moment, the BVI currently has the management ip on it, will the radios still bridge if I put the ip on the vlan interface ?

many thanks

Carl

Community Member

Re: access point management ip

bridge will still work - here is my BVI

interface BVI1

no ip address

no ip route-cache

so - not much doing there......

I have 3 VLAN's/SSID's on my AP's

and all work nicely - exactly how I want them to :-)

Community Member

Re: access point management ip

hi

I have done this , for some reason my clients associate then drop off now, what would be the normal way for assigning the management address to the ap for a certain vlan. I see by default the ssid maps to no vlan, is this correct ?

I am having major issues here.

many thanks

Carl

Community Member

Re: access point management ip

hi all

Can anyone please help on this asap, what is the normal way from start to finish, am I ok putting no ip address on the BVI? and also if I have vlan 1 mapped to an ssid, do i need to tick the native vlan box for this vlan, or should I keep it unticked ??

cheers

Community Member

Re: access point management ip

Do you have a Lab AP or 2 ?

How I done this is following.

Tried first with no auth for the clients.

then got the clients to work on the AP.

then get VLANS/SSID's on the AP

depends on the software/IOS version to how an SSID is configured (either Globally or Globally and on the interface or just on the interface)

SSID's should be configured(when) on the radio interfaces

then when you got this far , apply authentication......

That should then work....

Let me know if you got more problems - I myself learned this all by doing I have NO training in WLAN except for what I have read in Ciscopress books (and even then it is almost useless)

About the native VLAN that depends on what the native VLAN is on the Switch.....they must match

You DO NOT need an IP address on the BVI interface - it is there to help do a job - but it is not needed.

Community Member

Re: access point management ip

Hi, so will the ap function without the BVI, If I remove this would it stop working, and could I put the BVI address as part of my other new vlan, and will I be able to reach it if I put it on the same subnet as my other ssid ??

Community Member

Re: access point management ip

so will the ap function without the BVI - YES

If I remove this would it stop working - NO

could I put the BVI address as part of my other new vlan - YES - previously answered

will I be able to reach it if I put it on the same subnet as my other ssid - YES - as long as SSID is the VLAN you want the IP address to be on (same subnet)

:-)

Community Member

Re: access point management ip

So

Am I best to put the management ip on the BVI ?

Or on the fastethernet 0.212 subinterface for which the management vlan and ssid resides?

please confirm ?

Community Member

Re: access point management ip

Carl , there is no best way of doing this - you do what works for your network.

I have already told you how to do this on a subinterface.

203
Views
8
Helpful
14
Replies
CreatePlease to create content