Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Access Ports into Routed Ports

Dear Expert, I have Cisco 877 series Router, this type of router has 1 ADSL WAN port and 4 Ethernet LAN ports. The device will be connecting into the SHDSL circuit. It cannot use the ADSL WAN port since the SHDSL circuit is using Ethernet ports. Instead I will be using the LAN Ethernet ports (int Fa0) as WAN.

The said router can do the VLAN mapping and can do several VLANS. How can I used the LAN ethernet ports as WAN port for this case.

3 REPLIES
Hall of Fame Super Silver

Re: Access Ports into Routed Ports

Hello Carlos,

you need to create a second vlan

conf t

vlan 2

assigns the port that connect to SHDSL to vlan2

int fas0

switchport

switchport mode access

switchport access vlan 2

! configure SVI vlan2 as your WAN interface

interface Vlan2

Desc WAN

ip address x.x.x.x

or

ip address dhcp

no shut

ip nat outside

other ports will be in vlan1 that is your internal subnet

int vlan1

ip address 10.10.100.1 255.255.255.0

no shut

ip nat inside

!

ip nat source inside list 1 int vlan2 overload

access-list 1 permit 10.10.100.0 0.0.0.255

Hope to help

Giuseppe

Community Member

Re: Access Ports into Routed Ports

Many Thanks

I will try this one, let u know...

Community Member

Re: Access Ports into Routed Ports

Many thanks for the help, it is working.

145
Views
0
Helpful
3
Replies
CreatePlease to create content