Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Add another ethernet interface for more Bandwidth

I had a question about our ASR1006, we currently have two separate gigabitethernet connections coming into our ASR1006 from Fiber from two separate providers BGP. We are running BGP and OSPF, we currently only have one Ethernet connection coming from the ASR1006 to our Core switch which goes into a VLAN (Broadcast not point to point). How can we configure another Ethernet connection over to our Core to allow more bandwidth to get to our ASR?

Everyone's tags (6)
18 REPLIES

Add another ethernet interface for more Bandwidth

What is the speed on your two separate ISP connections?

The "Ethernet" connection from the ASR1006 to the core switch, is this FastEthernet or GigabitEthernet?

Are you running OSPF from your CORE to the ASR?

And are you just pushing a default route from the ASR to your core?

New Member

Add another ethernet interface for more Bandwidth

One is a 700mb burstable to 1gb

the other is 300mb burstable to 1gb

the ethernet connection is gigabitethernet from the asr to the core

Yes the ASR is an OSPF neighbor of the CORE, and we are pushing a full routing table to the Core

Add another ethernet interface for more Bandwidth

This is going to depend one many different aspects.

SO the OSPF network type from the ASR1006 to the Core is Broadcast, if you were to add another OSPF neighbor (link from the ASR to the Core), then from the Core to the ASR1006 you will have two ospf neighbors. Since by default, they will both have the same speed (1Gbps), they will have a cost of 1, unless you changed the reference bandwidth. Anyway, by default, OSPF should load balance (Which CEF is probably doing it). This should load balance based on per-destination.

So you could theorically use the two links at the same time.

You could change the COST for specifies routes on each router, so it uses one over the other.

New Member

Add another ethernet interface for more Bandwidth

I have the gigabitethernet interface configured the same as our original connection to the core (except different ip and subnet mask- which I think may be the issues) and it is plugged into the Core, the issue arrises i believe that I have my CORE / ASR / CMTS all configured into a vlan. The new connection that I added is on a different subnet than that Vlan since I cannot put the second connection in the same subnet that overlaps with the current interface connection.

Add another ethernet interface for more Bandwidth

What ESP module do you have on the ASR?

If you connect the interface from the ASR to the core with a /30 for example, add this into OSPF, then the core should have multiple routes to all the destinations received from the ASR. By default, a 1Gbps link, should have a cost of 1, which will be added to the cost.

As long as the costs are the same, it should do equal cost load balancing, thereby allowing you to use the two links.

But since OSPF, doesn't do unequal load balancing, they will have to be the same cost.

Or, you could have half the routes with a lower metric on one interface, and the other routes have a lower cost on the other.

New Member

Add another ethernet interface for more Bandwidth

ESP20

Should I configure an Ip address on the interface in the Core or put it in a seperate Vlan?

currently I have it with no ip address and switchport accesss into a new vlan i created.

The core sees it as a neigbor and has a Full/DR Priority 1

the other connection has Full/Drother Priority 1

Add another ethernet interface for more Bandwidth

Just to make sure we're on the same page..

On the core, they're are two different ports going to the ASR correct?

For Example...

gi0/0 on the core is going to gi0/0 on the ASR and gi0/1 on the core is going to gi0/1 (I know the interfaces may be different, this is just an example?

If this is correct, then you can configure both port in the same vlan, and have a broadcast network. One will be the DR and one will be the BDR. If this is the case, each port on the ASR going to the core will need an IP address.

You can also configure each in a separate vlan.

Either way, you should have equal cost routes, with a cost of most likely 1. It's going to load balance based on souce/dest hash. So you can test that out, to make sure it's working correctly.

New Member

Add another ethernet interface for more Bandwidth

The costs are 1 on each, and yes there are 2 seperate gigabitethernet ports going from the ASR to the Core (each it its own Vlan). I still do not have any traffic going over the new one. Here are my interface Configs.

ASR:

router ospf 1

network x.x.x.x 0.0.0.127 area 0.0.0.1

network x.x.x.x 0.0.0.7 area 0.0.0.1

interface GigabitEthernet0/0/0 (Existing Connection to 8/1)

ip address X.X.X.X 255.255.255.128

ip flow ingress

ip ospf 1 area 0.0.0.1

negotiation auto

interface GigabitEthernet0/0/5 (New Connection to 8/4)

ip address X.X.X.X 255.255.255.248

ip flow ingress

ip ospf 1 area 0.0.0.1

negotiation auto

CORE:

router ospf 1

log-adjacency-changes

redistribute connected

network X.X.X.X 0.0.0.127 area 0.0.0.1

network X.X.X.X 0.0.0.7 area 0.0.0.1

default-information originate always

interface GigabitEthernet8/4 (NEW Connection)

switchport

switchport access vlan 3

switchport mode access

no ip address

spanning-tree portfast

interface GigabitEthernet8/1 (Existing Connection)

switchport
switchport access vlan 10
switchport mode access
no ip address
spanning-tree portfast

interface Vlan3
ip address X.X.X.X 255.255.255.248
no ip redirects

ip nat outside

interface Vlan10
ip address X.X.X.X 255.255.255.128
no ip redirects
ip nat outside

Now I also have the IP of the new gige interface set us as a bgp neighbor in the Core, is this correct?

Re: Add another ethernet interface for more Bandwidth

Now, I'm a little confused. Let's get on the same page here.

Now I also have the IP of the new gige interface set us as a bgp neighbor in the Core, is this correct?

From my understanding, the BGP sessions are from the ASR to the ISP(s), and then OSPF from the ASR to the Core? Is this correct?

Because from what you said above, it sounds like you have a BGP session from the Core to the ASR?

I see the ospf config on the router, pushing out a default route to downstream ospf neighbors.

      

Can you post the results from 'show ip ospf neighbor' on the CORE.

Feel free to blank out any config you don't want the public to see obviously.

New Member

Add another ethernet interface for more Bandwidth

You are correct- I have removed the bgp neighbor from the core.

Neighbor ID     Pri   State           Dead Time   Address         Interface

ASR1006 -ID    1   FULL/DR         00:00:36    XXXX  Vlan3 -- (New Connection)

CMTS      0   FULL/DROTHER    00:00:34    XXXX     Vlan10

720VXR      1   FULL/DROTHER    00:00:39    XXXX    Vlan10

BACKUP CORE     1   FULL/BDR        00:00:37    XXXX   Vlan10

ASR1006-ID    1   FULL/DROTHER    00:00:34    XXXX    Vlan10

Add another ethernet interface for more Bandwidth

You also said that the Core switch is receiving full BGP routes from the ASR, is this correct?

Since you are running BGP from ASR to ISP(s), and OSPF from ASR to CORE, I'm assuming you have redistribution going on?

Can you post that config.

New Member

Add another ethernet interface for more Bandwidth

ASR:

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

ISP    4         xxxx 5104986   60951 25767651    0    0 5w3d       463431

ISP 2  4         xxxx    2629    2746 25767578    0    0 20:54:23        1

CORE   4        DDDD    2785  294873 25767657    0    0 1d22h           0

router bgp DDDD

bgp log-neighbor-changes

neighbor ISP 1 remote-as XXXX

neighbor ISP 2 remote-as XXXX

neighbor CORE remote-as DDDD

redistribute ospf 1 (is turned on under address-family)

CORE:

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

720VXR    4 DDDD  636077  635066 34043728    0    0 1d22h          89

ASR1006    4 DDDD 11173335  635095 34043728    0    0 1d22h      463442

router bgp DDDD

bgp log-neighbor-changes

neighbor 720VXR  remote-as DDDD

neighbor ASR1006 remote-as DDDD

Redistribute ospf 1 is not turned on under address family in core- should it be?

Re: Add another ethernet interface for more Bandwidth

Thanks Brandon.

On the ASR, I see three BGP neighbor commands. From my understanding they're should only be 2, which go to ISP1 and ISP2. I didn't think the CORE had any BGP commands.

redistribute ospf 1 (is turned on under address-family)

If this is done under address-family ipv4, you are redistributing all routes in OSPF process 1, into BGP, is this what you want to happen? With this configured, it's going to advertise your OSPF networks to your ISP(s).

From what I understand, you should have two BGP sessions on the ASR1006;

One to ISP1 and One to ISP2.

Then you will have two OSPF neighbors on the ASR1006 going to the core, and no BGP on the core.

Under 'router ospf 1' on the ASR, I would configure 'redistribute bgp '.

Then, on the Core, you will have ALL the BGP routes on the ASR1006 redistributed in to OSPF on the Core.

Now considering the fact that the only way for users to get to the Internet is to go to the ASR1006, I would make sure you are advertising a default route into your Core, with this, you should have two defaul routes with the same metric, and then load balancing should be performed.

Is this a live network? If so, I don't want to blow up your network, and just make usre to test things out first.

***** Understand that if you redistribute all BGP routes to OSPF, all other OSPF routers will have this as well *******

Re: Add another ethernet interface for more Bandwidth

I would take the following steps.

1. Get rid of he BGP going from the ASR1006 to the core

2. Verify that BGP is not configured on the core

3. Make sure they're are two OSPF neighbors on ASR1006 to the CORE

4. Verify on the Core, that they're are TWO ospf neighbors going to the ASR1006

5. On the ASR1006, I would do 'default information-originate always'

6. This will push a default route down to the Core

7. At this point, you should have two default routes with the same mask, cost, and administrative distance.

8. You should be able to load balance at this point

Of crouse, you know your network better than me, so just be careful with default routes

New Member

Add another ethernet interface for more Bandwidth

The core is configured as a bgp neighbor on the ASR and our 7200VXR, This has always been configured this way since I got involed in this network a few months ago. I just turned on a 2nd ISP into our ASR, (we have a 3rd ISP in the 720VXR that has been here for years as well). So I am not sure if this is why the core is configured as a bgp neighbor in each of our routers or not.

This is a live environment, so you are saying redistribute bgp (my asn correct)?

New Member

Add another ethernet interface for more Bandwidth

When you say to do a 'default information-originate always are meaning on bgp or ospf?

Add another ethernet interface for more Bandwidth

Thanks for the extra information Brandon, that makes more sense now.

So it sounds like you have three different ISPs.

So when your users go to the Internet, which link do they use? Because, from what I gather, before you added this other link, you already have currently two ISP providers.

What is the default route on the Core?

The BGP ASN on the core is, is it the same AS as is configured on the ASR? Just trying to understand if it's iBGP or eBGP.

New Member

Re: Add another ethernet interface for more Bandwidth

I apologize John as I just now saw this response.

You are correct, we have 3 different ISPs, before our users were load balancing between the 2 ISPs that we once had that are in the same Vlan. the default route in our core is for only one of our original ISPs, when I add our new connection in as the default route with the same metric, it then steals the traffic from the original default route, so I am able to pass traffic through the new port now but it is stealing the traffic that was originally going to our 7200VXR.

313
Views
0
Helpful
18
Replies