Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Adding an IP address to a Gigabit Port

The following scenario has proved problematic for me:

I have Cisco 356o Gig Switch that I am trying to implement as a L3 switch

- it will assume the routing responsibilities that my 3700 series router is currently doing

- after performing the following command: 3560HSCSW(config)#int Gi0/1

C3560HSCSW(config-if)#ip address 10.10.10.2, I recieve the error message below:

% Unrecognized command

- it seems apparent to me that I can not configure the Gig interface with an IP address

- Is this true? Am I doing something wrong here.

Essentially, I have this L3 switch prepped to handle routing for two VLANS and will connect to a router in the following scenario

Router A Fe0/0 = 10.10.10.1 connects to Gigabit Switch 10.10.10.2

I would really appreciate anyone's help with this configuration. Thank you very much.

  • LAN Switching and Routing
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Adding an IP address to a Gigabit Port

Hi,

this usually occurs, when the network masks include another interface, f.e

interface Gig0/0

ip address 10.1.0.1 255.255.0.0

interface Gig0/1

ip address 10.1.1.1 255.255.0.0

-> not accepted because 10.1.1.1 is part of the network 10.1.0.0 255.255.0.0 configured on Gig0/0

So make sure the network masks are configured correctly.

Regards, Martin

5 REPLIES

Re: Adding an IP address to a Gigabit Port

Hi

You need to make that as a L3 port before configuring an ip address on that.

Use no switchport under the interface config and configure ip address after that.

regds

Re: Adding an IP address to a Gigabit Port

Hi,

also make sure routing is turned on. So the config could look like this:

A)

ip routing

interface Gig0/1

description to router

no switchport

ip address 10.1.1.1 255.255.255.0

interface vlan 10

ip address 10.10.1.1 255.255.255.0

interface vlan 20

ip address 10.20.1.1 255.255.255.0

Finally you need some routing information

ip route ... !static

router ospf ... !starting an OSPF process to do the routing between router and 3560

network 10.0.0.0 0.255.255.255

router eigrp ... !starting an EIGRP process for the routing between router and 3560

network 10.0.0.0

The vlan interfaces (SVI) are used for inter-VLAN routing. You need to adjust interface naming and IP addresses to your environment.

Regards, Martin

New Member

Re: Adding an IP address to a Gigabit Port

Martin, thanks for you answer. It help me add the address to the interface, but now I am getting an error that states the address overlaps with GigabitEthernet0/1.

Any idea what this mean?

Re: Adding an IP address to a Gigabit Port

Hi,

this usually occurs, when the network masks include another interface, f.e

interface Gig0/0

ip address 10.1.0.1 255.255.0.0

interface Gig0/1

ip address 10.1.1.1 255.255.0.0

-> not accepted because 10.1.1.1 is part of the network 10.1.0.0 255.255.0.0 configured on Gig0/0

So make sure the network masks are configured correctly.

Regards, Martin

Purple

Re: Adding an IP address to a Gigabit Port

you can either make it a routed port or just create a layer 3 SVI for that interface and make sure the switchport is in that vlan , they will both do the same thing .

1763
Views
5
Helpful
5
Replies
This widget could not be displayed.