Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Adding EIGRP AS to Distribute-list command

Hi all,

I am doing redistribution between OSPF and EIGRP.

Router R1 is doing the redistribution .

Router R2 is running EIGRP with AS  100 and has connection to R1.

Router R3 is running only OSPF and has connection to R1.

********************************************************************************************************************************

R2 is running EIGRP and we only want to advertise the networks 10.1.1.1 and 10.1.3.1 to OSPF Router R3.

For this we do this on R1

Create ACL

access-list 70 permit 10.1.1.1

access-list 70 permit 10.1.3.1

Now

router  ospf 1

distribute-list 70 out  right?

This will  only allow 10.1.1.1 and 10.1.3.1 routes into the OSPF domain right ?

*********************************************************************************************************************

Second case

What if i apply this command under R1 

router ospf 1

distribute-list 70 out eigrp 100 ??????????????????

so my question is what difference eigrp 100 will make to distribute-list 70 out command.

Thanks

MAhesh

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Adding EIGRP AS to Distribute-list command

Hello Mahesh,

my understanding is that route filtering should impact on OSPF database content so I wouldn't expect R1 database to have more routes then those of the other devices. Again because it is link state and not distance vector like RIP and like EIGRP.

Hope to help

Giuseppe

6 REPLIES
Hall of Fame Super Silver

Re: Adding EIGRP AS to Distribute-list command

Hello Mahesh,

the command has to be combined with the redistribute command and it provides a way to perform route filtering on ASBR node.

router ospf 1

redistribute eigrp 100 subnets

+

distribute-list 70 out eigrp 100

this is equivalent to the use of a route-map in redistribution like

route-map EIGRP-INTO-OSPF permit 10

match ip address 70

router ospf 1

redistribute eigrp subnets route-map EIGRP-INTO-OSPF

to be noted being OSPF link state this is the only allowed use of distribute-list out, you should not be able to filter out an interface as you can do with EIGRP and RIP, RIPv2.

You need to specify the routing protocol with all its parameters so you need to use eigrp 100 and not only eigrp. In case of rip that has no process-id and no AS number you would have used only RIP

command syntax:


distribute-list {access-list-number | access-list-name} out [interface-name | routing-process | as-number]

When networks are redistributed, a routing process name can be specified as an optional trailing argument to the              distribute-list  command. Specifying this option causes the access list to be applied to  only those routes derived from the specified routing process.

see

http://www.cisco.com/en/US/docs/ios-xml/ios/iproute_pi/command/iri-cr-a1.html#GUID-E1133470-0A62-476B-A8D8-5E9231869A40

Hope to help

Giuseppe

Community Member

Adding EIGRP AS to Distribute-list command

Hi Giuseppe,

Thanks for reply back.

R1 is ASBR and also NSSA.

When on R1 i use these command

distribute-list 70 out   and when i add EIGRP 100 then OSPF database is same  on R1 and other routers in the Area 0

So this is normal?

Thanks

MAhesh

Hall of Fame Super Silver

Adding EIGRP AS to Distribute-list command

Hello Mahesh,

OSPF is link state and requires that database are in sync for each given area, for all routers that are member of that area including area 0 or an NSSA area.

R1 is ABR (0,NSSA-area) so the database section related to area 0 on R1 has to have the same content as the one we see on other backbone routers.

This means the filtering action using redistribute eigrp 100 + distribute-list 70 out eigrp 100 is performed at the database level that is the only way to do it with OSPF.

In other words, if all the EIGRP 100 routes were in R1 database, then  all of them would be flooded out in OSPF domain and filtering would be not effective.

Hope to help

Giuseppe

Community Member

Adding EIGRP AS to Distribute-list command

Hi Giuseppe,

R1 is ASBR and NSSA.

Correct me if i am wrong if R1 has routes in OSPF database that will be flooded out to all OSPF domain.

But if we do some router filtering on R1 and as result of that it filters those routes and now those routes are not in ospf

database right?

Now R1 will flood out contents of ospf database to other routers in ospf domain minus those filtered routes right?

Thanks

MAhesh

Hall of Fame Super Silver

Re: Adding EIGRP AS to Distribute-list command

Hello Mahesh,

my understanding is that route filtering should impact on OSPF database content so I wouldn't expect R1 database to have more routes then those of the other devices. Again because it is link state and not distance vector like RIP and like EIGRP.

Hope to help

Giuseppe

Community Member

Adding EIGRP AS to Distribute-list command

Hi Giuseppe,

Many thanks again.

Regards

MAhesh

573
Views
0
Helpful
6
Replies
CreatePlease to create content