Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Adding Metro E to connect remote site site

We currently have a routed connection to a site in a city accross the state.

The DR site is configured with a totally seperate VLAN config.

For example everything in the Main site is 10.100.x.x\24,

10.100.1.x\24 servers

10.100.2.x\24 printers

10.100.3.x\24 workstations

Remote site is 10.200.x.x\24

10.200.1.x\24 servers

10.200.2.x\24 printers

10.200.3.x\24 workstations

When we move from routed to Metro E to connect this site, is a trunk to the other site the way to go to connect the other site VLANs to the main site VLANS?

We have 5-060 VLANs in the main site and 20-30 VLANS in the remote site.

45 REPLIES
Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

The provider will give you a Layer2 handoff with a customer Vlan.

On the ISP facing interface, you can configure a trunk with the customer Vlan being the native Vlan.

For instance; customer Vlan 100

interface fx/x

switchport trun en do

switchport trun na vl 100

switchport mode trunk

switchport trun all vl 100,101

The 101 Vlan can be the Vlan where you create the p-t-p link for this MetroE so in your switches create Vlan 101 on L2 and L3 and assign the L3 Address as /30 subnet.

For instance:

Main Site

interface vlan 101

ip add 10.101.1.1 255.255.255.252

Remote Site

interface vlan 101

ip add 10.101.1.2 255.255.255.252

Then you can configure your routing protocol of choice and advertise the subnets from each location.

HTH,

__

Edison.

New Member

Re: Adding Metro E to connect remote site site

Thanks Edison,

At both ends, we are using OSPF locally to route the VLANs to all devices.

Also we are bridging several VLANs across the routed links.

I think I see where you are going with connecting the Layer 3 links across the span, but will the provider be handing off a trunk to me?

Also, what about the layer 2 VLANs?

We have an application that requires the failover server to be in the same subnet as the Primary.

This would be easy with just a layer 2 connection to the remote end.

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

The provider will have a dot1q-tunnel on their access port with a customer vlan as the native vlan.

You can configure 802.1q on your switches to carry multiple Vlans.

If you want to extend some L2 information over the MetroE, just allow those Vlans on the trunk. Make sure to perform manual pruning with the command I entered before 'switchport trunk all vl x,x,x'.

HTH,

__

Edison.

New Member

Re: Adding Metro E to connect remote site site

Oh, I see Edison, that cleared it up.

Basically I am routing over the layer 2 network and trunking the VLANs needed in both sites.

Am I loosing any benefit of the Metro E spanning the two sites by doing it this way?

I guess the only way to trunk everything is to change the addressing scheme in one of the sites correct?

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

Think of MetroE as interconnecting 2 switches together in your LAN.

The only caveat is the customer Vlan that must be untagged towards the carrier. Everything else is fair game, including CDP :) Nice to see your remote switches as directly connected CDP neighbors.

___

Edison.

New Member

Re: Adding Metro E to connect remote site site

Edison,

In my scenario, since I am already using OSPF in each respective site, and they are configured in the same area, once the trunk is configured, OSPF should form a neighbor adjacentcy in both sites across VLAN 101 is this correct?

And VLAN 101 is the path carrying all routed traffic across the link?

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

That's correct.

New Member

Re: Adding Metro E to connect remote site site

Hi Edison,

Great post here. My company is moving to ME for several of our remote sites. Could you please describe the setup if you are using routers (not switches) at your remote sites for the CE router where the provider will handoff? We will be doing a ME "hub and spoke" type of setup.

Thanks,

Brandon

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

ISP facing interface at the CE:

interface gx/x

no ip address

interface gx/x.x

encapsulation dot1q [Vlan_Given_By_ISP] native

interface gx/x.x

encapsulation dot1q [Your_Vlan]

ip address x.x.x.x y.y.y.y

interface gx/x.x

encapsulation dot1q [Your_Vlan]

ip address x.x.x.x y.y.y.y

etc.

__

Edison.

New Member

Re: Adding Metro E to connect remote site site

Hi Edison,

Thanks for this response. I am assuming this will be the HUB end. Can you give an example of what the remote site router config may look like? I think I know, but would like your input. Also will the [Your_Vlan] part be the vlan I come up with? For example if I say vlan 10 for site 1 then I will assign that to my subinterface on the HUB router and on the remote router use the same dot1q on the interface facing the provider?

Thanks,

Brandon

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

The Hub will have all the subinterfaces and IP subnets for the remotes in addition to the native subinterface for the ISP. The Remotes will have the native subinterface for the ISP in addition to the subinterface for the Hub with its corresponding subnet.

When I refer to the native subinterface for the ISP, it means you aren't tagging the Vlan on that subinterface while using the 'native' keyword on the encapsulation dot1q command.

___

Edison.

New Member

Re: Adding Metro E to connect remote site site

That makes sense! Man you have been more that helpful Edison. I will rate your reply.

Thanks,

Brandon

New Member

Re: Adding Metro E to connect remote site site

Edison,

If you are doing "router-on-a-stick" at the remotes will you just have to just make sure your "routed vlan" for the point-to-point" link is different and unique, not used in the LAN portion of your remote site? I hope I'm making sense.

Thanks,

Brandon

New Member

Re: Adding Metro E to connect remote site site

What I meant by that last post is you need to make sure the native the ISP gives you and your native at the remote is a different vlan number. Right?

-Brandon

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

You can re-use Vlans on this scenario as the router will break the tag at ingress from the MetroE network and send it routed back to the internal network. At the internal network the switch connecting to this router can apply another Vlan tag or leave the incoming traffic from the router untagged.

Your Vlan allocation concern would be if the router is also doing 'router-on-a-stick' internally.

__

Edison.

New Member

Re: Adding Metro E to connect remote site site

Hi Edison,

So say the below config is you current router-on-a-stick configuration for a remote site (before ME implementation). And the provider gives you a vlan of say 200 to use. How could you arrange this config for the remote?

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.10.1.208 255.255.255.0

!

interface FastEthernet0/0.2

description DHCP AP's

encapsulation dot1Q 2

ip address 10.10.2.1 255.255.255.0

ip helper-address 10.40.2.3

ip helper-address 10.40.2.4

!

interface FastEthernet0/0.3

description fhmi$access

encapsulation dot1Q 3

ip address 10.10.3.1 255.255.255.0

ip helper-address 10.40.2.3

ip helper-address 10.40.2.4

!

interface FastEthernet0/0.6

description Static IPs

encapsulation dot1Q 6

ip address 10.10.6.1 255.255.255.0

!

interface FastEthernet0/0.7

description PBX

encapsulation dot1Q 7

ip address 10.10.7.1 255.255.255.0

Thanks,

Brandon

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

That's your internal facing interface. This router will need a ISP facing interface.

On the ISP facing interface, say F0/1

interface FastEthernet0/1

no ip address

speed 100

full-duplex

!

interface FastEthernet0/1.200

description ISP Native Vlan

encapsulation dot1Q 200 native

interface FastEthernet0/1.xxx

description point-to-point subnet for Hub

encapsulation dot1Q xxx

ip address x.x.x.x y.y.y.y

New Member

Re: Adding Metro E to connect remote site site

Hi Edison,

You're correct...still waking up I guess...;-).

Thanks,

Brandon

New Member

Re: Adding Metro E to connect remote site site

Edison,

In my scenario (from the top of post), I have two sites, with two different VTP domains.

Would you suggest that I add the reote site to the VTP domain in the main site, or leave it seperate?

I will be routing all but two or three VLANs (with the possibility of more later).

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

Up to you. If you want to add/modify/delete Vlans for remote site from a HQ VTP server, then configure the same VTP domain across.

I personally wouldn't do that. Have the remotes have a different VTP domain (Server/Client) from the HQ.

New Member

Re: Adding Metro E to connect remote site site

Thanks Edison.

What is the reason that you would leave it seperate?

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

It provides some kind of Vlan management security.

You don't want a mistake on Vlan creation/modification/deletion to get propagated to other switches.

We usually recommend running VTP transparent in a switched network. Note: This has nothing to do with MetroE but just a general concept.

HTH,

__

Edison.

New Member

Re: Adding Metro E to connect remote site site

I am not sure what you are saying about the VTP,

So, with two 6509 switches at the core network with several 3550 access switches,

All would be transparent?

Currently we have the two 6509s running VTP, one is server the other is client and the rest are transparent.

New Member

Re: Adding Metro E to connect remote site site

Hi Edison,

Just curious, but could you give a brief config or explanation of the configuration if you had a switch (6500) at the hub end instead of routers?

Thanks,

Brandon

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

Much easier;

interface gx/x

description MetroE connection

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan [Metro_Vlan]

switchport trunk allow vlan [Metro_Vlan],[Common Vlans to be used for Remotes....]

interface vlan [remote 1]

description Site 1

ip address x.x.x.x y.y.y.y

interface vlan [remote 2]

description Site 2

ip address x.x.x.x y.y.y.y

New Member

Re: Adding Metro E to connect remote site site

Hi Edison,

So the HUB is a switch and the remotes are routers.

Would the interface on the remote routers sub interface pointing to the ISP (hand-off) reference dot1q of the vlan at the HUB?

Such as:

HUB switch:

interface gx/x

description MetroE connection

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 500

switchport trunk allow vlan 500,150,160

interface vlan 150

description Site 1

ip address 10.150.255.1 255.255.255.252

interface vlan 160

description Site 2

ip address 10.160.255.1 255.255.255.252

Remote site routers:

[remote 1]

interface FastEthernet0/1

no ip address

speed 100

full-duplex

!

interface FastEthernet0/1.1

description point-to-point subnet for Hub

encapsulation dot1Q 150

ip address 10.150.255.2 255.255.255.252

!

interface FastEthernet0/1.200

description ISP Native Vlan

encapsulation dot1Q 500 native

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.20.1.211 255.255.255.0

[remote 2]

interface FastEthernet0/1

no ip address

speed 100

full-duplex

!

interface FastEthernet0/1.1

description point-to-point subnet for Hub

encapsulation dot1Q 160

ip address 10.160.255.2 255.255.255.252

!

interface FastEthernet0/1.200

description ISP Native Vlan

encapsulation dot1Q 500 native

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.30.1.207 255.255.255.0

Thanks,

Brandon

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

You got it :)

New Member

Re: Adding Metro E to connect remote site site

Awesome,

And if I did go with the switch method at the HUB and say my remotes were 8MB ME connections to do QoS would at the hub end would I configure this under the VLAN sub-interfaces? I know a switch typically isn't as smart as a router (with QOS, shaping, etc...) so what would you advise for someone with these concerns.

Any recommendations?

Kind Regards,

Brandon

Hall of Fame Super Bronze

Re: Adding Metro E to connect remote site site

No shaping available on regular line cards on a 6500. You need a SIP with Ethernet SPAs. On the SPA, you would do shaping like a regular IOS router and apply the service-policy on the main interface.

HTH,

__

Edison.

514
Views
60
Helpful
45
Replies