Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Adding routers to home network

Hello,

I'm adding three routers to my home network, however I'm having trouble getting the routers to recognize the network. I have a core router connected to the home network via e0 and the other routers are linked via back to back cables to the core router. The core router can see the home network, however the other two routers cannot see anything past e0 on the core router. The home network is using 192.168.0.x, while the routers are using 10.x.x.x with e0 being 192.168.0.100.

I've tried using default network 192.168.0.0 in eigrp settings. It propogates the information to the other routers, but traceroutes continue to stop at the core router.

I've also tried using a static route, with distribute static in eigrp routing with no luck.

The only thing that seems to work is using the nat method. If you setup the default route, shouldn't this method work? or is there something I'm missing?

Thanks in advance

7 REPLIES

Re: Adding routers to home network

Can you post your netowrk topology

Narayan

New Member

Re: Adding routers to home network

I've attached a jpg of the network topology. Sorry for it's crudeness. If it's no ledgeable, I'll create a better one when I get home tonight.

Re: Adding routers to home network

With EIGRP

on router with seg 10.10.10.2/30

router eigrp 100

network 10.10.10.0 0.0.0.3

no auto-summary

on router with seg 10.10.10.1/30

router eigrp 100

network 10.10.10.0 0.0.0.3

network 10.10.10.8 0.0.0.3

no auto-summary

on router with seg 10.10.10.9/30

router eigrp 100

network 192.168.0.0 0.0.0.255

network 10.10.10.8 0.0.0.3

no auto-summary

with static routes

on router with seg 10.10.10.2/30

ip route 10.10.10.8 255.255.255.252 10.10.10.1

ip route 192.268.0.100 255.255.255.0 10.10.10.1

on router with seg 10.10.10.1/30

ip route 192.268.0.100 255.255.255.0 10.10.10.9

on router with seg 10.10.10.9/30

ip route 10.10.10.0 255.255.255.252 10.10.10.10

HTH, rate if it does

Narayan

New Member

Re: Adding routers to home network

Thanks for the info, but I've already tried the solution with eigrp.

This is the output I get from 10.10.10.1:

kuyaz2>sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

Gateway of last resort is 10.10.10.9 to network 192.168.0.0

10.0.0.0 is variably subnetted, 3 subnets, 2 masks

C 10.10.10.8 255.255.255.252 is directly connected, Serial0

C 10.10.10.0 255.255.255.252 is directly connected, Serial1

D 10.10.100.0 255.255.255.0

[90/2195456] via 10.10.10.2, 00:09:25, Serial1

D* 192.168.0.0 [90/2195456] via 10.10.10.9, 00:09:25, Serial0

As the output indicates, it recognizes the default gateway being out 10.10.10.10

Re: Adding routers to home network

Are you using the default-network command in the configurations.

Can you post your configurations

Narayan

New Member

Re: Adding routers to home network

When I set default network under eigrp 101, network 192.168.0.0 does not get advertised. The configuration of segment 10.10.10.9 is below.

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname kuyaz3

!

enable secret *****

!

ip subnet-zero

ip name-server 192.168.0.1

!

!

!

interface Ethernet0

ip address 192.168.0.100 255.255.255.0

no ip directed-broadcast

!

interface Ethernet1

no ip address

no ip directed-broadcast

shutdown

!

interface Serial0

no ip address

no ip directed-broadcast

shutdown

!

interface Serial1

ip address 10.10.10.9 255.255.255.252

no ip directed-broadcast

!

router eigrp 101

network 10.0.0.0

network 192.168.0.0

!

ip classless

!

Hall of Fame Super Bronze

Re: Adding routers to home network

If your destination address is out on the internet, you must NAT the source network (10.0.0.0) the same way you are NAT'ng the 192.168.0.0 network - routing alone won't do it since the internet has no way of knowing the 10.0.0.0 is coming from you.

1095
Views
0
Helpful
7
Replies
CreatePlease to create content