Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ADSL connection

Dear all,

I would like to inform me how to check the adsl configuration below, that works. I enter 'show ip route' and get external IPs, but I am not sure whether the router (837) needs more configuration for the completion of the dsl. I want also to configure the ethernet or fast ethernet to connect my laptop.

Cisco#sh startup-config

Using 1432 out of 131072 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Cisco

!

!

no aaa new-model

ip subnet-zero

!

!

ip audit notify log

ip audit po max-events 100

vpdn enable

!

vpdn-group pppoe

request-dialin

  protocol pppoe

!

no ftp-server write-enable

!

!

!

!

!

!

!

interface Ethernet0

ip address 192.168.1.25 255.255.255.0

ip nat inside

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

hold-queue 224 in

!

interface ATM0.1 point-to-point

pvc 8/35

  pppoe-client dial-pool-number 1

!

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet3

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet4

no ip address

shutdown

duplex auto

speed auto

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication pap callin

ppp pap sent-username ########### password 0 ###########

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

no ip http secure-server

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

line con 0

no modem enable

line aux 0

line vty 0 4

password ######

login

!

scheduler max-task-time 5000

!

end

4 REPLIES
Hall of Fame Super Silver

Re: ADSL connection

Hello Egeorgopoluos,

configuration looks like correct.

To use the additional FAST ethernet ports: they are treated like switch ports that belong to vlan1.

So the SVI vlan1 has to be configured:

int Vlan 1

ip address 192.168.2.1 255.255.255.0

! the SVI has to be explicitly enabled with no shut:

no shut

ip nat inside

add  the following line to ACL 1:

access-list 1 permit 192.168.2.0 0.0.0.255

this should allow you to connect the PC to one switch port on the router like Fas1 and to access the internet

Hope to help

Giuseppe

New Member

Re: ADSL connection

I cannot see any virtual interface as you mentioned above. The only thing I see is the below (BVI) and when I try to enter it I take the below message:

interface bVI 1
Integrated Routing and Bridging is not configured!

% No interface specified for interface_command

Hall of Fame Super Gold

Re: ADSL connection

BVI's are used by Wireless Access Points and 837 does not support this either.

New Member

Re: ADSL connection

do you know how to overcome this problem with the vlan interface ?

523
Views
0
Helpful
4
Replies
CreatePlease login to create content