Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ADSL Module Configuration

Hi,

I have applied the following configuration on my internet router my ADSL interface is up and the link protocol is also up but still is not getting an IP address and as consequence not able to communicate through it to my ISP nor to the internet. The configuration I have is:

interface ATM0

pvc 0/35

encapsulation aal5mux ppp dialer

bundle-enable

dsl operating-mode auto

bridge-group 1

exit

interface BVI1

ip address x.x.x.x 255.255.255.248

ip nat outside

Please let me know whether this ADSL configuration is alright or I need to fix anything in it.

Thanks,

Haitham

3 REPLIES
New Member

Re: ADSL Module Configuration

Which model are you using? Cisco 870 series??

Depending to the model you may need to create VLAN and "ip nat inside" to this interface so the Network translation may occur.

#Other than that my 878 need a DSL controller config for the g.shdsl connection. Have you created one?

!

controller DSL 0

mode atm

line-term cpe

line-mode 2-wire line-zero

dsl-mode shdsl symmetric annex A-B (your config might be different for ADSL)

line-rate auto

!

#How about the dialer interface? Have you created one to send your password and username?

!

interface Dialer1

description $FW_OUTSIDE$

bandwidth 1024

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp pap sent-username yourusername password 0 yourpassword

ppp ipcp dns request

!

# Created a default gateway to Dialer interface?

ip route 0.0.0.0 0.0.0.0 Dialer1

!

I hope it helps,

Best Regards,

Evren

New Member

Re: ADSL Module Configuration

...and a VLAN for nat inside?

!

interface Vlan1

description INSIDE

ip address 10.0.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

hold-queue 100 out

!

more info:

http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_guide_book09186a0080627060.html

New Member

Re: ADSL Module Configuration

Hi,

Thanks for your reply.. My router model is 2801, does the same config apply on this model as well?

I came across a configuration example for 2800 routers but it was not that detailed. I could only figure out that I need to create a BVI interface as I sent to you. Now, why do I need to create a VLAN for the nat inside?!

Attached is the configuration I prepared for my router, and my main problem is in bringing up the ADSL interface.

140
Views
0
Helpful
3
Replies
CreatePlease login to create content