Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Anyone seen this error code before? (%SYS-3-PORT_RX_BADCODE)????

We are running Sup720's (redundant) in Hybrid mode with MSFC3's...

Switch (enable) 2006 Dec 09 17:20:39 EDT -05:00 %SYS-3-PORT_RX_BADCODE:Po

rt 4/10 detected 2343 bad code error(s) in last 30 minutes

I tried searching for it and no doc's found....

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Anyone seen this error code before? (%SYS-3-PORT_RX_BADCODE)

Hi Friend,

Yes it's good idea to start with replacing the fiber patch cable. Last time when I have seen this problem was because of the bad fiber cable only.

Update us with the status.

HTH

Ankur

5 REPLIES
Cisco Employee

Re: Anyone seen this error code before? (%SYS-3-PORT_RX_BADCODE)

Hi Friend,

PORT_RX_BADCODE:Port [dec]/[chars] detected [dec] bad code errors in

last 30 minutes

Explanation

This message indicates that a port has been affected with an unknown protocol error. The first [dec] is the module number, [chars] is the port number, and the second [dec] is the number of inbound packets with unknown protocols encountered in the last 30 minutes.

Recommended Action

No action is necessary. This message is provided for information only.

Check this link

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/sw_8_5/msg_gd/emsg.htm#wp1016498

In similar instances I have observed this problem being related to a Layer 1 issue, for example a bad NIC or a faulty cable. Sometimes it could be an application sending "bad" packets. Please let me know what is connected to this interface. Make sure you change the cable connected to this interface and try moving the connection into another port. Monitor if the error message will persist on the new port.

HTH

Ankur

*Pls rate helpfull post

New Member

Re: Anyone seen this error code before? (%SYS-3-PORT_RX_BADCODE)

Hello! This is a gig interface ("port 4/10) on a cat6509...it is connected (over a WAN fiber link) to a 2950G switch at one of our school districts head-end (the port is setup for trunking). So maybe start with replacing the fiber patch cables?

Cisco Employee

Re: Anyone seen this error code before? (%SYS-3-PORT_RX_BADCODE)

Hi Friend,

Yes it's good idea to start with replacing the fiber patch cable. Last time when I have seen this problem was because of the bad fiber cable only.

Update us with the status.

HTH

Ankur

New Member

Re: Anyone seen this error code before? (%SYS-3-PORT_RX_BADCODE)

We replaced our side this morning...will monitor to see if the errors go away. If not, we'll replace the other end.

New Member

Re: Anyone seen this error code before? (%SYS-3-PORT_RX_BADCODE)

It's been a little over 6 hours since we replaced the fiber cable at our end, and NO errors are being reported! Looks like this solved it...thanks again!

Vince

628
Views
5
Helpful
5
Replies
CreatePlease to create content