Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Applying QoS settings to inbound layer 2 traffic

I have a 3750G switch (IOS 12.2).  I've got a server on a port off of this switch that sends out multicast traffic, but does not apply any QoS settings.  I'm trying to figure out how to add CoS or DSCP to all inbound traffic on the port (which is on a vlan operating at layer 2 only).  The documents I have found seem to assume that the inbound traffic already has some settings to trust.

Thanks,

-Ben Brown

Everyone's tags (4)
4 REPLIES
Cisco Employee

Applying QoS settings to inbound layer 2 traffic

Hello Ben,

In case the server is sending already marked traffic and you are agree with it you can preserve it with the following interface level command:

# mls qos trust dscp

In case you want to remark the traffic or apply a particular DSCP/CoS there is a few ways to do so, it would be helpful to get a port configuration in order to understand the way it's configured.

Thank you

-- 
Best regards,
Dmitry Skotnikov

-- Best regards, Dmitry Skotnikov
New Member

Applying QoS settings to inbound layer 2 traffic

Unfortunately, the traffic is not in any way marked coming out of the server.

My current port configuration is dead stupid:

interface GigabitEthernet1/0/22

description mediaroom server

switchport access vlan 101

switchport mode access

switchport nonegotiate

!

-Ben

Cisco Employee

Applying QoS settings to inbound layer 2 traffic

Hello Ben,

There is a few ways to mark incoming traffic in your case. I would suggest you to evalute the following two:

In order to modify QoS settings you should enable "mls qos" globally on a switch

!

mls qos

!

1. Default CoS for all incoming traffic

!

interface GigabitEthernet1/0/22

  mls qos cos

  mls qos trust cos

!

In this case all untagged traffic will be marked with for internal processing and DSCP will be rewritten accordingly to cos-dscp mutation map, from the table DSCP value which corresponds to configured CoS will be used You can check the map with the following command:

show mls qos maps cos-dscp

2. Marking accordingly to configured policy-map

!

! Either match only mcast traffic and mark it separately or mark all traffic from server

access-list 100 permit ip any 224.0.0.0 15.255.255.255

class-map CM-MCAST-MEDIAROOM

  match access-group 100

!

policy-map PM-MARK-MEDIAROOM

  class CM-MCAST-MEDIAROOM

    set dscp

  !

!

interface GigabitEthernet1/0/22

  service-policy input PM-MARK-MEDIAROOM

!

2a. Mark all incoming traffic

!

policy-map PM-MARK-MEDIAROOM

  class class-default

    set dscp

  !

!

interface GigabitEthernet1/0/22

  service-policy input PM-MARK-MEDIAROOM

!

-- 
Best regards,
Dmitry Skotnikov

-- Best regards, Dmitry Skotnikov
New Member

Applying QoS settings to inbound layer 2 traffic

I will give it a try.  Thanks.

967
Views
0
Helpful
4
Replies