Cisco Support Community
Community Member

ARP "incomplete" entry


I plugged an IP device into a 2960 Catalyst switch. The port is up, but there is no MAC address learned on it:

TNSWAGCS01002(config-if)#do sh mac add int fa0/16

          Mac Address Table


Vlan    Mac Address       Type        Ports

----    -----------       --------    -----


TNSWAGCS01002(config-if)#do sh int fa0/16

FastEthernet0/16 is up, line protocol is up (connected)

  Hardware is Fast Ethernet, address is 0064.40ee.f510 (bia 0064.40ee.f510)

  Description: --- STC ---

  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Half-duplex, 10Mb/s, media type is 10/100BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:01, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/0 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     14432 packets input, 923648 bytes, 0 no buffer

     Received 1392 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     48956 packets output, 3586289 bytes, 0 underruns

     0 output errors, 0 collisions, 18 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out



interface FastEthernet0/16

description --- STC ---

switchport access vlan 1400

switchport mode access

switchport port-security

switchport port-security violation restrict

switchport port-security mac-address sticky

priority-queue out

mls qos trust cos

spanning-tree portfast

spanning-tree bpduguard enable


I read that it may be a L1/L2 issue. We tried with another ethernet cable. We also tried with another IP device of the same model. That did not solve the issue.

Any idea would be appreciated.


Everyone's tags (2)

ARP "incomplete" entry


what is happening if you ping any IP from this device ?



Don't forget to rate helpful posts.
Community Member

Re: ARP "incomplete" entry

Hi Alain,

There are no issues with this switch. One of the symptoms of the issue is that a ping from the gateway to the host fails. The ARP "incomplete" entry appears on the connected router:

Internet            -   1cdf.0f1a.4258  ARPA   GigabitEthernet0/0.1300

Internet            0   Incomplete      ARPA  

Internet            -   1cdf.0f1a.4258  ARPA   GigabitEthernet0/0.1400

I did ARP debugs:

- debug arp

- debug arp table

- debug arp interface

- debug arp database

The debug output is in the file attached. Please note that:

- the IP address of the device generating the "incomplete ARP" is

- the IP address of the gateway is (subinterface on the branch router)

CreatePlease to create content