Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ASA and Router configuration

Currently this is our network setup

                         Sw1 Sw2 Sw3

                               | | |                                 Sw1 10.60.0.4; Sw2- 172.16.1.4; Sw3 192.168.128.4
                               | | |

10.60.0.1--------------Router----------------- 172.16.1.1

                               | | |

                               | | |

                               | | |

            192.168.128.1 | MPLS           ACLs, NAT, VPN tunnels are on the Router and Router is the Default Gateway

                                 |

                                 |

                    Internet Gateway

Now we are planning to install a ASA firewall and migrate the ACLS of 10.60.*.* network and 172.16.1.* network , Nat comments and VPN tunnels to the Firewall

Can the IP address of the Router remains the same as 10.60.0.1, 172.16.1.1 and could I assign the Firewall IPs as 10.60.0.3, 172.16.1.3 (or should I need to change the IPs of the Router as 10.60.0.3 , 172.16.1.3 and assign the Firewall IPs as 10.60.0.1, 172.16.1.1)

In that case the default gateway will be 10.60.0.1 (Router) or 10.60.0.3 (Firewall)

We are planning to set up the network as

                         Internet Gateway

                                  |

                                  |

                                  |

                            Firewall

                  10.60.0.? | | 10.60.0.? and which will be the default gateway Router or Firewall?

                                | |

                                | |

                           Sw1 Sw2

                               | |

                               | |

                 10.60.0.? | | 172.16.1. ?

                           Router

                              | |

                              | |

                              | |

          192.168.128.1    MPLS

Everyone's tags (3)
6 REPLIES

ASA and Router configuration

Hi,

Sorry. I couldn't understand your scenario well. But if your setup is like this SW1,2,3-->ASA-->Router-->Internet. Then your gateway should be preferred to be ASA with .1. And your rouer should be in public segment or sepearte segment as ASA outside interface is connected to the router.

Please let me know what is your exact setup. How the cotnnection from switches to asa/router is going through.

Please do rate if the given information helps.

By

Karthik

New Member

ASA and Router configuration

Currently it is Internet Gateway---> Router --> MPLS and Sw1, Sw2,Sw3 and the Router (10.60.0.1) is the default gateway.  We are planning  for to setup as Internet Gateway --> ASA --->Sw1, Sw2 ----> Router---> MPLS and Sw3.

Will the Router be the Default Gateway still? ACLs for Sw1 and Sw2 sunets , Nat and VPN tunnels will be on the ASA

New Member

ASA and Router configuration

Following is the configuration on the Router interfaces now

interface GigabitEthernet0/0

description ML LAN

ip address 192.168.128.1 255.255.255.0

ip access-group ml-in in

no ip redirects

no ip proxy-arp

ip accounting output-packets

ip nat inside

ip inspect SDM_LOW out

ip virtual-reassembly in

duplex auto

speed auto

media-type rj45

no mop enabled

interface GigabitEthernet0/1

description DMZ LAN

ip address 172.16.1.1 255.255.255.0

ip access-group dmz61in in

no ip redirects

no ip proxy-arp

ip accounting output-packets

ip nat inside

ip inspect SDM_LOW out

ip virtual-reassembly in

duplex auto

speed auto

media-type rj45

no mop enabled

!

interface FastEthernet0/0/0

description  Internet

switchport access vlan 10

no ip address

!

interface FastEthernet0/0/1

description MPLS

switchport access vlan 20

no ip address

!

interface FastEthernet0/0/2

description IT and LAN

switchport access vlan 30

no ip address

!

interface Vlan1

no ip address

!

interface Vlan10

description Internet

ip address 200.*.*.* 255.255.255.252

ip access-group Inet-In in

no ip redirects

no ip proxy-arp

ip nat outside

ip inspect SDM_LOW out

ip virtual-reassembly in

load-interval 30

no mop enabled

crypto map SDM_MAP_1

!

interface Vlan20

description  MPLS

ip address 10.100.0.62 255.255.255.252

!

interface Vlan30

description IT and LAN

ip address 10.60.0.1 255.255.0.0

ip nat inside

ip virtual-reassembly in

So to install the Firewall, how to configure the Router interfaces and Firewall interfaces.

Curently it is Internet ----> Router ----> Sw1(10.60.0.*),Sw2(192.168.128.*), Sw3 (172.16.1.*)

New Member

ASA and Router configuration

I am planning to install the ASA as Internet -----> ASA ----> Sw1(10.60.0.*), Sw3 (172.16.1.*)----> Router -----> MPLS & Switch3 (192.168.128.*)  So, how should I configure  the Router interfaces, ASA interfaces and IP routes

ASA and Router configuration

Hi,

So you are going to place ASA in between the internet gateway and the LAN. So you LAN switches default gateway should be ASA when it goes for accessing internet or any internet link based VPN setups. So you need to remove .1 ip for SW1 and 2 from the router and configure it in ASA as a multiple context or as the subinterfaces.

Please do rate if the given information helps.

By

Karthik

ASA and Router configuration

Hi,

Please clarify me few things on this scenario.

SW1 and Sw2 will access only Internet/VPN based connections or it has something to do with the MPLS for any LAN/WAN actions. How about the Sw3 what that will do... it doesn't goes to internet for any connection... it deals only with the MPLS.

Please do rate if the given information helps.

By

Karthik

720
Views
0
Helpful
6
Replies
CreatePlease to create content