Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ASA5505 booting into rommon.

Hello,

I need assistance to fix a problem with an ASA 5505. Device boots to rommon #0> and stays there.

The complete boot record follows:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -  - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

CISCO SYSTEMS

Embedded BIOS Version 1.0(12)13 08/28/08 15:50:37.45

Low Memory: 632 KB

High Memory: 507 MB

PCI Device Table.

Bus Dev Func VendID DevID Class              Irq

00  01  00   1022   2080  Host Bridge

00  01  02   1022   2082  Chipset En/Decrypt 11

00  0C  00   1148   4320  Ethernet           11

00  0D  00   177D   0003  Network En/Decrypt 10

00  0F  00   1022   2090  ISA Bridge

00  0F  02   1022   2092  IDE Controller

00  0F  03   1022   2093  Audio              10

00  0F  04   1022   2094  Serial Bus         9

00  0F  05   1022   2095  Serial Bus         9

Evaluating BIOS Options ...

Launch BIOS Extension to setup ROMMON

Cisco Systems ROMMON Version (1.0(12)13) #0: Thu Aug 28 15:55:27 PDT 2008

i2c_read_word_w_wait() error, slot = 0x0, device = 0x64, address = 134 byte coun

t = 2. Reason: I2C_UNPOPULATED_ERROR

Platform ASA5505

Ethernet0/0

i2c_write_byte_w_wait() error, slot = 0x0, device = 0x64, address = 128 byte cou

nt = 1. Reason: I2C_UNPOPULATED_ERROR

esw_reg_read: i2c_write_byte_w_wait(0) returned 0x6

Ethernet port 0 could not be initialized.

Default Interface number-0 Not Up

Use ? for help.

rommon #0>

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

I cannot access the device via web browser nor can I get into device root ciscoasa(config)# prompt.

Thanks in advance.

Enrique S.

I have tried the set options as suggested in https://learningnetwork.cisco.com/thread/34184. Values are saved until next boot. But device ports cannot be initialized. ASA is no longer in warranty. Will a working bin image copied from an inserted flash help? Will it help too to check / format disk:0 ?

15 REPLIES

ASA5505 booting into rommon.

have you tried the boot command in the rommon mode....

rommon>boot or rommon>boot ....

New Member

ASA5505 booting into rommon.

Hi Enrique,

Check if your compact flash card is inserted properly (think its on the left hand side of the ASA if am not mistaken). or it might be damage. if it is inserted properly kindly post the below output of:

sh disk0:

HTH.

Regards,

Terence

New Member

ASA5505 booting into rommon.

Hi Terrence,

Device is into rommon #

Here is the output:

rommon #0> sh disk0:

Please define the specific show command.

Valid "show" command arguments are:

   "idprom": display ID-PROM Fields

   "  info": display platform specific information

   "   gdb": display image gdb settings

   "   reg": display current TFTP port device registers

   "  stat": display current TFTP port state and stats

Seems that the command needs some more arguments.

Or did I do mistyped something?

Thanks.

P.D.

I have already checked the flash card. Read it under Windows and scanned it for errors. No errors returned.

I also tried with a new flash card (4Gb) formatted to FAT (the same as the Cisco original card) and copied the two root folders and a downloaded bin. image for the asa. It is a higher version. But behavior looks the same.

Do you have any suggestions / instructions?

Thanks in advance, Terrence.

Enrique S.

ASA5505 booting into rommon.

Hi Enrique,

By using boot command also if it is not booting...

If you wish to format the flash... you can do it using the erase command....

Erasing the Flash File System


Step 1 Connect to the ASA console port according to the instructions in "Accessing the Command-Line Interface" section.

Step 2 Power off the ASA, and then power it on.

Step 3 During startup, press the Escape key when you are prompted to enter ROMMON mode.

Step 4 To erase the file system, enter the erase command, which overwrites all files and erases the file system, including hidden system files.

rommon #1> erase [disk0: | disk1: | flash:]

New Member

ASA5505 booting into rommon.

Thank you Karthikeyan,

I am erasing flash now. Will let you know what happens after.

New Member

ASA5505 booting into rommon.

I tried with the original memory (after formatting and restoring the contents). I also tried with a new compac flash with the original .bin file and also with a different one. But in both cases I get the following error:

No images in /

Error 15: File not found

unable to boot an image

-------------------------------------

Thank you.

Enrique S.

Re: ASA5505 booting into rommon.

Hi

Please contact your Support you have an i2c error this is Not normal and indicates hardware or rommon issues.

Sent from Cisco Technical Support iPhone App

New Member

ASA5505 booting into rommon.

Hi Patrick,

Thank you. I am afraid I don´t have any support plan. Is the i2c a board component?

Is your general guess about this that it will be worth paying a one-time service with an authorized provider?

Wonder why this happened. Just had reset this device to defaults and managed to connect 2 cisco ip phones on the PoE ports. Lan ports worked fine too.

New Member

ASA5505 booting into rommon.

Hello,

I have the same error message...did you solve your problem? I just want to know if this is a software or a hardware problem but nobody knows...If this is a software problem, how can we try to solve it?

ASA5505 booting into rommon.

Hi

the i2c is part of computers it kind of bus for sensors and other things.

From my point of view exchange the asa.

Patrick

New Member

ASA5505 booting into rommon.

Ive got the same issue with my 5505.  It boots and gets the I2C_UNPOPULATED_ERROR.

full error:

i2c_write_byte_w_suspend() error, slot = 0x0, device = 0x40, address = 26 byte count = 1. Reason: I2C_UNPOPULATED_ERROR

The ASA is then un responsive and have to yank the power to reset.

Called TAC but its support contract expired.  Then called reseller for renewal options which came out to be just over $100.  I see other posts about this but no one has posted what happend.  Is this everyone elses experience?  Will I just ahve to pay the $100 for the contract renewal and no other fees for repairs?

New Member

Re: ASA5505 booting into rommon.

Hi, Had a similar issue and for me it was the PoE controller on the board. The part is LTC4259ACGW-1

New Member

ASA5505 booting into rommon.

Hi, Had a similar issue and it is the PoE controller on the board. The part is LTC4259ACGW-1

New Member

Re: ASA5505 booting into rommon.

Hi Keebs,

Where did you purchase this part? And did you get the ASA up and running again?

Thank you.

New Member

Re: ASA5505 booting into rommon.

Hi, I took another chip from a dead ASA to get it to work. You can look up this site:

http://www.linear.com/product/LTC4259A#orderinfo

Not sure of the package type but if you look at the specs it should show which to use for the ASA. Looks like it should be no more than 15 to buy a new one.

20774
Views
0
Helpful
15
Replies
CreatePlease login to create content