Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ASA5505: Inbound FTP "ignored"

Hi
 
I have an FTP server on inside interface, IP 10.10.40.40.
 
I have created the following rules to allow ftp and ftp-data inbound externally:
static (inside,outside) tcp interface ftp 10.10.40.40 ftp netmask 255.255.255.255
static (inside,outside) tcp interface ftp-data 10.10.40.40 ftp-data netmask 255.255.255.255
access-list outside_access_in extended permit tcp any host 10.10.40.40 eq ftp log disable
access-list outside_access_in extended permit tcp any host 10.10.40.40 eq ftp-data log disable
 
However, all attempts at inbound FTP fail. Full config is below:
 
 
ASA Version 8.2(5)
!
hostname ASA5505
names
!
interface Ethernet0/0
 description to_ISP
 switchport access vlan 200
!
interface Vlan10
 description inside-interface
 nameif inside
 security-level 100
 ip address 10.10.10.1 255.255.255.252
!
interface Vlan200
 description outside-interface
 nameif outside
 security-level 0
 pppoe client vpdn group BT
 ip address 255.255.255.255 pppoe setroute
!
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
object-group network NAS
access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit tcp any host 10.10.40.40 eq ftp log disable
access-list outside_access_in extended permit tcp any host 10.10.40.40 eq ftp-data log disable
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu dmz 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any dmz
icmp permit any echo dmz
icmp deny any echo-reply outside
icmp permit any outside
icmp permit any echo outside
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 10.10.10.0 255.255.255.0
nat (inside) 1 10.10.20.0 255.255.255.0
nat (inside) 1 10.10.30.0 255.255.255.0
nat (inside) 1 10.10.40.0 255.255.255.0
static (inside,outside) tcp interface ftp 10.10.40.40 ftp netmask 255.255.255.255
static (inside,outside) tcp interface ftp-data 10.10.40.40 ftp-data netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 80.x.x.x 1
route inside 10.10.10.0 255.255.255.0 10.10.10.1 1
route inside 10.10.20.0 255.255.255.0 10.10.10.1 1
route inside 10.10.30.0 255.255.255.0 10.10.10.1 1
route inside 10.10.40.0 255.255.255.0 10.10.10.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 10.0.0.0 255.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet 10.0.0.0 255.0.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group BT request dialout pppoe
vpdn group BT localname 
vpdn group BT ppp authentication chap
vpdn username password ***** store-local
 
threat-detection basic-threat
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect ip-options
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
  inspect pptp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:aecb9042a375f6fa1a7c6a0d6489aed2
: end
24
Views
0
Helpful
0
Replies
CreatePlease login to create content