Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

assigning IP address using DHCP server to client in several vlan

Hi all,

I'm having difficulty about IP address assignment. I have 2 vlan which is VLAN 1 and VLAN 100. My DHCP server is in VLAN 1. I have 2 pc which is reside in VLAN 1 and VLAN 100. My PC in VLAN 1 able to get ip from DHCP server, but my PC in VLAN 100 can't get ip from DHCP server. Below is my current configuration:

CORE Switch configuration:

!

ip routing

!

vlan 100

!

interface Vlan1

ip address 192.168.1.220 255.255.255.0

no ip mroute-cache

no clns route-cache

!

interface Vlan100

description *** int vlan 100 ***

ip address 192.168.100.1 255.255.255.0

ip helper-address 192.168.1.210

no clns route-cache

!

interface FastEthernet1/0/15

description ** to 2900 fa 0/2 trunk ***

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

load-interval 30

!

ACCESS Switch configuration:

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/17

spanning-tree portfast

!

interface FastEthernet0/18

switchport access vlan 100

spanning-tree portfast

!

interface VLAN1

ip address 192.168.1.158 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

My first PC connected to int fa 0/17 able to get ip from DHCP server, but my second PC connected to int fa 0/18 unable to get ip from DHCP server. Is there any missing configuration that I should add into CORE switch or ACCESS switch ?

Thank in advance.

1 REPLY

Re: assigning IP address using DHCP server to client in several

Hi,

Have you defined an address pool in the DHCP server for network 192.168.100.0/24 ?

Istvan

110
Views
0
Helpful
1
Replies