Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Assistance with VLAN setup on Cisco Small Biz Network

Hi.

I am trying to setup a small biz network that is structured as follows

Single 887 Router (ADSL)

4 x SG300-28P switches

3 x AP541N AP's

In the past i had a guest VLAN on the 887 which was plugged into a guest AP. I set the switchport on the router to ACCESS mode so that when the AP was plugged into it, it was automaticaly setup on the guest vlan.

I have the new APs now and i want to make the whole network aware of the guest vlan, and also setup a secondary SSID on the APs that put the users on that SSID on the guest vlan. Details are as follows

interface FastEthernet0

switchport access vlan 100 (this was the old switchport that the single guest AP was plugged into)

!

interface FastEthernet1 (this is the switchport that goes to the first SG300 which are then cascaded

!

interface Vlan1 (internal vlan)

ip address 192.168.0.253 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Vlan100 (Guest vlan)

ip address 10.0.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

On the Switches i have added another vlan called guest and is VLAN100. When plugging into the switch you get given DHCP from the main vlan (VLAN1).

I have plugged the AP into the same switch and setup an SSID on VLAN100 though you dont get given an address from the DHCP server on that VLAN (the DHCP server for the GUEST VLAN100 is on the 887). After more testing ive realised that even if i self assign an address on the VLAN100 subnet whilst on the GUEST SSID i still cant communicate with the router.

Im not too familir with the tagging settings on the switch ports. Is there something i need to do for the switch to understand that there is vlan1 an vlan100 on the port that comes from the router?

Any assistance would be greatly appreciated

Cheers

Pete

Everyone's tags (5)
2 REPLIES
New Member

Re: Assistance with VLAN setup on Cisco Small Biz Network

The ports where the access point are need to be set for trunking and allow vlan 1,100. Then on the ap assign guest vlan to guest ssid.

Sent from Cisco Technical Support iPhone App

New Member

Assistance with VLAN setup on Cisco Small Biz Network

Hi Paul

Thanks for your reply, in essense i understand that bit.. though im not sure of the settings.

On the SG300 you can set the ports to be excluded, tagged, or untagged for each vlan and im not sure what these settings should be.

Out of interest, i set one port to be EXCLUDED to VLAN1, and UNTAGGED to VLAN100 expecting that switchport to then be locked down to VLAN100. After doing that and plugging a PC onto that port it doesnt get DHCP from that VLAN, and even if i set the IP address to be fixed i cant ping the ROUTER on that VLAN100...

Do i need to have any specific settings on the CIsco ROUTER so that the SG300 understands whcih port the router is on and that VLAN100 lives on it?

513
Views
0
Helpful
2
Replies