Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Auto-negotiation between Cisco switch and pc's

Can anyone please help with this, my users are unable to access ftp sites when both the pc NIC and switch port are set to auto-negotiate.

I suspect traffic is generally not being passed properly but that is the main complaint.

I have not set any speed or duplex settings on the switch port but the server nic reports an error as attached.

Both side negotiate the link as the same thing but there are errors on the switch port and the error in event viewer till we hard code both ends.

The switch is a 3560 with IOS version 12.2(35)SE5.

Any help will be much appreciated.

Regards,

Mo.

  • LAN Switching and Routing
3 REPLIES
Purple

Re: Auto-negotiation between Cisco switch and pc's

Are you trunking to this pc ? There will be errors because the switch is negotiating 100/half duplex which creates a collision domain . If you look at the warning on the nic it says it will only advertise 1000 so that may be causing the problem as the switchport is only 100 meg. You will occasionally run into this even after all these years and you have to hardcode the port. you can check for updated drivers from Intel.

New Member

Re: Auto-negotiation between Cisco switch and pc's

I remember watching some videos when ever you see auto you should "Auto not to" bottom line auto negotiation works sometimes and sometimes it does not. I would suggest hard coding both switchport and pc. If you have the switch set to auto and the PC set to 100/full it will fall back to 100/half yuck. Maybe try a driver update but from past experiences intel driver updates wont fix this issue.

Gold

Re: Auto-negotiation between Cisco switch and pc's

Untrunk the switchport.

"switchport mode access"

Keeping auto neg. is ok. hard coding is ok. as a general rule, i try to have both sides set to the same (whether its hardcoded or auto neg).

Gig ports/NIC's are supposed to default to 1000/full.

10/100 ports/NIC's default to 10/half.

So if a NIC/switchport doesn't receive a fast link pulse, it defaults to one of those.

902
Views
0
Helpful
3
Replies
This widget could not be displayed.