Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Auto QoS on 4507R-E

Hello -

I have a 4507R-E chassis with Supervisor IV running IOS 12.2(50)SG.  I am trying to configure "auto qos voip trust" on some of the uplink ports.  When I try to configure it on a port that is in a channel group, I get the error "AutoQoS Error: AutoQoS can not be configured on member port(s) of a port-channel".  I have also tried configuring it on the channel interface, but it is not an available command under the channel interface.  Is there a way to do auto qos on the channel interfaces or their member ports or does it have to be configured manually?

Thanks,

Andy

Everyone's tags (2)
12 REPLIES
Community Member

Re: Auto QoS on 4507R-E

i am in the same boat here.  Any word on this?

Re: Auto QoS on 4507R-E

Hello -

I have a 4507R-E chassis with Supervisor IV running IOS 12.2(50)SG.  I am trying to configure "auto qos voip trust" on some of the uplink ports. When I try to configure it on a port that is in a channel group, I get the error "AutoQoS Error: AutoQoS can not be configured on member port(s) of a port-channel".  I have also tried configuring it on the channel interface, but it is not an available command under the channel interface.  Is there a way to do auto qos on the channel interfaces or their member ports or does it have to be configured manually?

Thanks,

Andy

Hi Andy,

Check out the below Bug ID CSCsv03316

Symptom:

AutoQoS cannot be configured on member port(s) of a port-channel.
Switch#sh runn int fa 3/1
channel-group 2 mode on -- Port in etherchannel
Switch#conf t
Switch(config)#int fa 3/1
Switch(config-if)#auto qos voip trust
AutoQoS Error: AutoQoS can not be configured on member port(s) of a port-channel

Conditions:

This problem is seen in 12.2(40)SG (and later releases) on K2 based supervisors such as SupV-10GE.
The problem is not seen in 12.2(37)SG.
Workaround:

Do not use Auto Qos. Take the configuration that would be generated by Auto Qos and apply it manually to a port.

Hope to Help !!

Ganesh.H

Remember to rate the helpful post

Community Member

Re: Auto QoS on 4507R-E

So on my 4507 with SupVI the other trunk links I have configured have generated the following commands:

interface GigabitEthernet1/3

auto qos voip trust

switchport mode trunk

service-policy input AutoQos-VoIP-Input-Cos-Policy

service-policy output AutoQos-VoIP-Output-Policy

Would I then apply the 2 service-policies to each of the 4 interfaces in the port-channel or to the port-channel itself?

Re: Auto QoS on 4507R-E

So on my 4507 with SupVI the other trunk links I have configured have generated the following commands:

interface GigabitEthernet1/3

auto qos voip trust

switchport mode trunk

service-policy input AutoQos-VoIP-Input-Cos-Policy

service-policy output AutoQos-VoIP-Output-Policy

Would I then apply the 2 service-policies to each of the 4 interfaces in the port-channel or to the port-channel itself?

As per the workaround you need to apply those policy individually on physical ports of the etherchannel.

Hope to Help !!

Ganesh.H

Remember to rate the helpful post

Community Member

Re: Auto QoS on 4507R-E

Here is what I get trying to enter the commands:

router(config-if)# service-policy input AutoQos-VoIP-Input-Cos-Policy

% A service-policy with non-queuing actions should be attached to the port-channel associated with this physical port.

router(config-if)# service-policy output AutoQos-VoIP-Output-Policy

% A service-policy with non-queuing actions should be attached to the port-channel associated with this physical port.

router(config-if)# interface Port-channel1

router(config-if)# service-policy input AutoQos-VoIP-Input-Cos-Policy

router(config-if)# service-policy output AutoQos-VoIP-Output-Policy

% A service-policy with queuing actions can be attached in output direction only on physical ports.

Community Member

Re: Auto QoS on 4507R-E

Was this resolved?  I have the same issue as the person in the previous post.

Community Member

Re: Auto QoS on 4507R-E

Hi,

Is it this case resolved because i also face same problem need help!!!!!!

thanks

-Thor

Community Member

Re: Auto QoS on 4507R-E

Hi,

No, it was not resolved. I need this resolved as well. Please post back if you get a solution.

Cisco Employee

Re: Auto QoS on 4507R-E

Hi Andy,

'auto qos voip trust' is a command to prioritize traffic on an interface connected to an IP Phone. Thats the reason this command is not supported on etherchannels.

If traffic from your IP Phone is already marked, you can just trust the marking by 'qos trust cos' on the uplinks which should take care of sending the traffic to the correct queue on the core switch.

However on etherchannels, you can still go ahead and apply the configuration generated from using 'auto qos voip trust' on a non bundled port.

Following steps worked for me:

1. 'sh run int gx/y' for port you want to bundle

2. bundle those ports with 'channel-group <#> mode on'

3. 'sh policy-map' to check the name of the policy map generated using auto qos voip trust   (for me the policy map was 'autoqos-voip-policy')

4. go to config mode on the physical-ports, and do

service-policy input autoqos-voip-policy

service-policy output autoqos-voip-policy

Following is sample configuration from a lab switch:

WS-C4507R#sh policy-map

  Policy Map autoqos-voip-policy

    Class class-default

      dbl

! sample port having auto qos voip trust configured

interface GigabitEthernet7/1

qos trust cos

auto qos voip trust

tx-queue 3

   bandwidth percent 33

   priority high

   shape percent 33

service-policy output autoqos-voip-policy

end

!

interface GigabitEthernet7/2

channel-group 1 mode on

service-policy input autoqos-voip-policy

end

interface GigabitEthernet7/3

channel-group 1 mode on

service-policy output autoqos-voip-policy

end

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

end

Hope this helps,

Shashank

Please rate this answer if you found the content useful

Community Member

Re: Auto QoS on 4507R-E

Ok, I'll explain the issue again, as your solution does not seem to work.  The AutoQos policy that you switch generated, must be different than ours.

The AutoQos policy won't apply to the etherchannel, even when you place already created AutoQos policy on the interface using the 'service-policy' command.  If you attempt to place it on the Etherchannel/port-channel, it tells you to place it on the physical port.  When you try to place it on the physical port, it tells you to place it on the port-channel.  It's a circle.

4506_SW#sh policy-map
  Policy Map AutoQos-VoIP-Input-Dscp-Policy
    Class AutoQos-VoIP-Bearer-Dscp
      set qos-group 46
    Class AutoQos-VoIP-Control-Dscp26
      set qos-group 26
    Class AutoQos-VoIP-Control-Dscp24
      set qos-group 24

  Policy Map AutoQos-VoIP-Input-Cos-Policy
    Class AutoQos-VoIP-Bearer-Cos
      set qos-group 46
    Class AutoQos-VoIP-Control-Cos
      set qos-group 24

  Policy Map AutoQos-VoIP-Output-Policy
    Class AutoQos-VoIP-Bearer-QosGroup
      set dscp ef
      set cos 5
      priority
     police cir percent 33
       conform-action transmit
       exceed-action drop
    Class AutoQos-VoIP-Control-QosGroup26
      set dscp af31
      set cos 3
      bandwidth remaining percent 5
    Class AutoQos-VoIP-Control-QosGroup24
      set dscp cs3
      set cos 3
      bandwidth remaining percent 5
    Class class-default
      dbl


Single trunking port to router with 'auto qos voip trust' applied: 
interface GigabitEthernet2/1
switchport trunk allowed vlan 100,500
switchport mode trunk
auto qos voip trust
spanning-tree portfast trunk
service-policy input AutoQos-VoIP-Input-Cos-Policy
service-policy output AutoQos-VoIP-Output-Policy

Ports inluded in etherchannel: 
interface GigabitEthernet1/3
switchport trunk allowed vlan 100,500
switchport mode trunk
channel-group 1 mode on
'service-policy input AutoQos-VoIP-Input-Cos-Policy' (when I enter that, I get the following below)
% A service-policy with non-queuing actions should be attached to the port-channel associated with this physical port.
'service-policy output AutoQos-VoIP-Output-Policy' (when I enter that, I get the following below)
% A service-policy with non-queuing actions should be attached to the port-channel associated with this physical port.
!
interface GigabitEthernet1/4
switchport trunk allowed vlan 100,500
switchport mode trunk
channel-group 1 mode on
'service-policy input AutoQos-VoIP-Input-Cos-Policy' (when I enter that, I get the following below)
% A service-policy with non-queuing actions should be attached to the port-channel associated with this physical port.
'service-policy output AutoQos-VoIP-Output-Policy' (when I enter that, I get the following below)
% A service-policy with non-queuing actions should be attached to the port-channel associated with this physical port.

interface Port-channel1
switchport
switchport trunk allowed vlan 100,500
switchport mode trunk
spanning-tree portfast trunk
service-policy input AutoQos-VoIP-Input-Cos-Policy
'service-policy output AutoQos-VoIP-Output-Policy' (when I enter that, I get the following below)
% A service-policy with queuing actions can be attached in output direction only on physical ports.
(well, I tried putting it on the physical port above, and the error, which is noted above, says, it must be applied on the port-channel.  It is a loop). 

Community Member

Re: Auto QoS on 4507R-E

Hi,

I facing exactly which show at above post.Really Need help!!!

-thanks

Thor

Community Member

Re: Auto QoS on 4507R-E

I have a 4507R-E lite with sup 6L-E and having problems with QoS commands, is the QoS commands different in this than a 4506?

If some one pls point me to a document on QoS for the above model 4507R-E lite with sup 6L-E, i looked at the enterprise QoS SRND and also the medianet QoS they all reference the 4500 series nothing in specific for this. i tried the same commands used on 4506 but they dont work on the 4507R-E.

any help is appreciated and thanks.

Prabhu

12560
Views
10
Helpful
12
Replies
CreatePlease to create content