Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Auto RP w/MSDP Peers

Hi Routing and Switching Experts,

Can you please help me to evaluate this Auto RP w/MSDP configuration and tell me what is incorrect or missing.

According to my colleague, I was supposed to add:

access-list 1 permit 239.0.0.0 0.255.255.255

ip pim rp-address 192.168.10.1 1

which I have, but it has not resolved the problem. Any thoughts?

Best Regards,

JRossi

6504-1

ip multicast-routing   distributed

interface Loopback10

ip address 192.168.10.1   255.255.255.0

ip pim sparse-mode

!

interface Loopback20

ip address 192.168.20.1   255.255.255.0

ip pim sparse-mode

ip pim rp-address   192.168.10.1 1

ip pim send-rp-announce   Loopback20 scope 16 group-list 11

ip msdp peer 192.168.30.1   connect-source Loopback20

access-list 1 permit 239.0.0.0 0.255.255.255

access-list 10 permit   239.11.11.11

access-list 11 permit   239.0.0.0 0.255.255.255

ip msdp originator-id   loopback20

router ospf 100

network 192.168.20.0   0.0.0.255 area 0

network 192.168.30.0   0.0.0.255 area 0

6504-2

ip multicast-routing   distributed

interface Loopback10

ip address 192.168.10.1   255.255.255.0

ip pim sparse-mode

!

interface Loopback30

ip address 192.168.30.1   255.255.255.0

ip pim sparse-mode

ip pim rp-address   192.168.10.1 1

ip pim send-rp-announce   Loopback30 scope 16 group-list 11

ip msdp peer 192.168.20.1   connect-source Loopback30

access-list 1 permit 239.0.0.0 0.255.255.255

access-list 10 permit   239.11.11.11

access-list 11 permit   239.0.0.0 0.255.255.255

ip msdp originator-id   loopback30

router ospf 100

network 192.168.20.0   0.0.0.255 area 0

network 192.168.30.0   0.0.0.255 area 0

11 REPLIES

Re: Auto RP w/MSDP Peers

ip pim send-rp-discovery seems to be missing I think. You need this mapping agent. Ensure you have the listener command set on others, though i think new ios does this already?

You do not really need the access-list and the static RP entry in my view, unless you have specific requirement..

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Re: Auto RP w/MSDP Peers

Hello, John.

If you had only these two routers it would work.

But to make auto-rp to work with some environment you should add:

  • ip pim autorp listener - to enable autorp in caces of spars-mode;
  • use at least two mapping agents - "ip pim send-rp-discovery ...
  • add respective loopbacks into IGP (6504-1 - 192.168.10.1 + 192.168.20.1; 6503-2 192.168.10.1 and 192.168.30.1);

Are you trying to implement anycast RP? In this case you should make Lo10 to become RP.

Anycast RP example could be found here:

http://www.cisco.com/en/US/docs/ios/solutions_docs/ip_multicast/White_papers/rps.html

but they use sparse-dense mode, so missing autorp listener

PS: why don't you use BSR?

Cisco Employee

Auto RP w/MSDP Peers

Hi John,

The "send-rp-announce" and "send-rp-discovery" should be using the anycast address (lo10) as described in the following document:

http://www.cisco.com/en/US/docs/ios/solutions_docs/ip_multicast/White_papers/rps.html

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: Auto RP w/MSDP Peers

Hi All,

It looks like I had an Auto-RP line configured that was unneccisary. After removing the rp-announce command and adding the network 192.168.10.0 into area 0, the MSDP peers came up, but the "show ip pim rp" still resulted in a no output.

6504-1#sh ip pim rp

6504-1#

It wasn't until I added the following commands to the VLAN SVI that I could even ping 239.11.11.11.

Is that normal behavior? Why?

For Example:

6504-1(config)#int vl 129

6504-1(config-if)#ip pim sparse-mode

6504-1(config-if)#do sh ip pim rp

6504-1(config-if)#ip igmp join-group 239.11.11.11

6504-1#sh ip pim rp

Group: 239.255.255.250, RP: 192.168.10.1, next RP-reachable in 00:01:18

Group: 239.9.9.9, RP: 192.168.10.1, next RP-reachable in 00:01:20

Group: 239.11.11.11, RP: 192.168.10.1, next RP-reachable in 00:01:21

I changed the configuration as follows:

6504-1

ip   multicast-routing distributed

interface   Loopback10

ip   address 192.168.10.1 255.255.255.0

ip   pim sparse-mode

!

interface   Loopback20

ip   address 192.168.20.1 255.255.255.0

ip   pim sparse-mode

ip   pim rp-address 192.168.10.1 11

ip   msdp peer 192.168.30.1 connect-source Loopback20

access-list   10 permit 239.11.11.11

access-list   11 permit 239.0.0.0 0.255.255.255

ip   msdp originator-id loopback20

router   ospf 1

network   192.168.10.0 0.0.0.255 area 0

network   192.168.20.0 0.0.0.255 area 0

network   192.168.30.0 0.0.0.255 area 0

6504-2

ip   multicast-routing distributed

interface   Loopback10

ip   address 192.168.10.1 255.255.255.0

ip   pim sparse-mode

!

interface   Loopback30

ip   address 192.168.30.1 255.255.255.0

ip   pim sparse-mode

ip   pim rp-address 192.168.10.1 11

ip   msdp peer 192.168.20.1 connect-source Loopback30

no   access-list 10 permit 239.11.11.11

access-list   11 permit 239.0.0.0 0.255.255.255

ip   msdp originator-id loopback30

router   ospf 1

network   192.168.10.0 0.0.0.255 area 0

network   192.168.20.0 0.0.0.255 area 0

network   192.168.30.0 0.0.0.255 area 0

I removed ACL 10 because it only pointed to 239.11.11.11. According to our "X" multicast expert, we needed the entire subnet to be allowed, just in case we need to create and use additional multicast groups. Also, there were no rp-address statements referencing ACL 10.

Does this make sense to the multicast experts online?

Any additional advice or assitances would be appreciated.

Best Regards,

JRossi

Cisco Employee

Auto RP w/MSDP Peers

Hi John,

Your updated configuration is plain Anycast RP. Which is fine, but you will need to configure a static RP on all other routers needing to deliver multicast in your network. The initial configuration was a combination of Anycast RP and auto-rp, where you wouldn't need to configure a static RP on all routers as it would be discovered via auto-rp.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: Auto RP w/MSDP Peers

Hi Harold,

I am reading the white paper you sent me.

How could I modify the configuration to use Auto RP with MSDP peers?

Before our multicast guy left the company, I believe it was his plan to use Auto RP. I just need to make sure that there is a statement which allows the entire 239.0.0.0 /8 subnet, which I believe in the ACL is 239.0.0.0 0.0.0.255.

Best Regards,

John

Cisco Employee

Re: Auto RP w/MSDP Peers

Hi John,

Well, you do not need MSDP peers if you run Auto RP by itself. You will need msdp peers in the context of Anycast RP. The following section of the white paper covers Anycast RP with Auto RP to distribute the Anycast RP address.

http://www.cisco.com/en/US/docs/ios/solutions_docs/ip_multicast/White_papers/rps.html#wp1036139

How many routers do you have in your network? Depending on the number of routers, it might be just fine to go and configure the static RP on all routers that need to support multicast. If the number of routers needing to support multicast is high, it might be easier to use Auto RP to distribute the Anycast RP address.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: Auto RP w/MSDP Peers

Hi Harold,

This is a Multicast POC @ a single location with 2 core 6509's.

This is mostly for our wireless network, which has 2 different multicast groups.

The first is for the Multicast Redirect feature which uses 239.9.9.9.

Our controllers use 239.2.2.2 and 239.11.11.11 is utilized for a medical application that uses video. In the end, we will have 15 locations with dual 6k switches.  I will play with the configuration to see how Auto RP works, but Anycast RP might be fine. I was told that our primary requirement was to ensure that Multicast was implmented  w/ fault tolerence. I assume the use of the static RP configured on both sides facilitates that?

Do you see any problem with the existing configuration?

Best Regards,

John

Cisco Employee

Re: Auto RP w/MSDP Peers

Hi John,

If your multicast network consists of only these two 6500, I do not see any advantage in deploying Auto-RP. You could just use Anycast RP with static RP. This would be much simpler.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: Auto RP w/MSDP Peers

Hi Harold,

I set something up in GNS3 to simulate an Auto RP configuration.

R1 - Setting to announce as RP

ip pim send-rp-announce f1/0 scope 16 group-list 11

access-list 11 permit 239.0.0.0 0.255.255.255

R1#sh ip pim rp mapping

PIM Group-to-RP Mappings

This system is an RP (Auto-RP)

Group(s) 239.0.0.0/8

  RP 192.168.10.1 (?), v2v1

    Info source: 192.168.10.3 (?), elected via Auto-RP

         Uptime: 00:33:18, expires: 00:02:21

R2 - Setting to Mapping Agent

ip pim send-rp-discovery int f1/0 scope 16

ip pim autorp listener

R2#sh ip pim rp mapp

PIM Group-to-RP Mappings

This system is an RP-mapping agent (FastEthernet1/0)

Group(s) 239.0.0.0/8

  RP 192.168.10.1 (?), v2v1

    Info source: 192.168.10.1 (?), elected via Auto-RP

         Uptime: 00:34:42, expires: 00:02:18

R3

R3#sh run int f1/0

!

interface FastEthernet1/0

ip address 192.168.12.1 255.255.255.0

ip pim sparse-mode

ip igmp join-group 239.11.11.11

ip ospf 1 area 0

duplex auto

speed auto

!

ip pim autorp listener

So, a couple of questions.

1. Why when I ping the Mcast Grp address, do I only get responses from the 11 and 12 subnet? Shouldn't the RP at 10.1 also respond or do I only get responses from the mapping agent?

2. When I take down R1, which has the RP announce command configured, why doesn't the multicast group go down?

I thought that when the OSPF dead timer expired, the multicast group would become unavailable?

R3#ping 239.11.11.11 re 500

Type escape sequence to abort.

Sending 500, 100-byte ICMP Echos to 239.11.11.11, timeout is 2 seconds:

!

Reply to request 0 from 192.168.12.1, 16 ms

Reply to request 0 from 192.168.12.1, 272 ms

Reply to request 1 from 192.168.12.1, 24 ms

Reply to request 1 from 192.168.12.1, 36 ms

Reply to request 1 from 192.168.12.1, 32 ms

!! R1 !!

Reply to request 1 from 192.168.11.2, 32 ms

Reply to request 1 from 192.168.11.2, 32 ms

Reply to request 2 from 192.168.12.1, 24 ms

Reply to request 2 from 192.168.12.1, 36 ms

Reply to request 2 from 192.168.12.1, 32 ms

Best Regards,

John

Cisco Employee

Re: Auto RP w/MSDP Peers

Hi John,

1- Unless you have other receivers for group 239.11.11.11, only the interfaces configured with "ip igmp join-group 239.11.11.11" will respond to the ping. The RP and mapping agent do not respond to ping to this multicast group unless they are configured wit that samre command.

2- The entry for the multicast group will remain for a certain time even if it is not being used.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
740
Views
0
Helpful
11
Replies
CreatePlease to create content