Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Auto-RP works in sparse mode -- it shouldn't!

Without "ip pim autorp listener" Auto-RP should not work in sparse mode as it cannot properly send the multicast packets it needs to operate. But in my lab it seems to work no matter what I do. Clearing mroute table, clearing RP mappings... nothing, still works.

How is that possible?

2 REPLIES
Cisco Employee

Re: Auto-RP works in sparse mode -- it shouldn't!

Borek,

This is normal behavior if all routers are directly connected to the RP. This is because the directly connected routers receive the announce and discovery messages regardless.

These messages though are not propagated beyond the directly connected routers without configuring the interfaces as sparse-dense-mode or "ip pim autorp listener" on these same routers.

Try having one router not directly connected to the RP and you will see that it will not automatically learn the address of the RP.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Auto-RP works in sparse mode -- it shouldn't!

The multicast source was not directly connected (in fact, there were two hops to RP). I tried to set-up another source-receiver pair and that did not work... so maybe there was some state retained in my network for some time?

159
Views
0
Helpful
2
Replies