Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AutoInstall on the switch

Hi all,

  It seems like I can't get the "Would you like to terminate AutoInstall" message on the switch when I reloaded it with no config. Any ideas? Is this feature not supported on the switch, or do I need a specific command to enter this mode? I'm running a 3560 with 12.2(58)SE. Thanks.

Regards,

Angela

Everyone's tags (1)
20 REPLIES
Bronze

AutoInstall on the switch

Hi,

Is the switch connected to the network before reloading it?

Best regards,

Giorgos

New Member

AutoInstall on the switch

Yes, it's connected to the network and all configurations, including VLAN.DAT, are erased. But I doubt if it has anything to do with network connectivity.

Regards,

Angela

Bronze

Re: AutoInstall on the switch

The Autoinstall process begins when a networking device that does not have any files in its NVRAM is connected to the network. It needs network connectivity to work.

Regards,

Giorgos

New Member

Re: AutoInstall on the switch

Hi,

i don't know why it doesn't launch but you can still run it manually:

SW-3560#setup

          --- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: yes

...

Regards,

-Guillaume

Bronze

AutoInstall on the switch

Hi,

Autoinstall and Setup are two different things. Autoinstall loads configuration files automatically while Setup provides guidance to configure a device for the first time.

If you want to enter the system configuration dialog (setup) you can also switch to configuration-register 4142:

config t

config-reg 4142

exit

reload

But this is different than Autoinstall.

Best regards,

Giorgos

New Member

AutoInstall on the switch

Hi Giorgos,

you're right I missunderstood

But by the way i tried the command:

     Switch(config)#conf-reg 4142

but it doesn't exist and i havn't found the equivalent command furthermore if i do a sh version, my configuration register is 0xF. So That's wired i'll investigate on it later.

Regards,

-Guillaume

Bronze

AutoInstall on the switch

Oops, my mistake!

This command is used only on routers and the configuration register used to clear is 2142, not 4142 which is a typo.

Sorry about that.

The correct command used on switches, is the one you said in your previous message.

Thanks for the correction!

Giorgos

New Member

AutoInstall on the switch

Hi Guillame,

  I see that message "Continue with configuration dialog?", but the message I want is "Do you wish to continue with AutoInstall?". Which should pop up after saying no at the dialog

Regards,

Angela

Bronze

AutoInstall on the switch

Is there a DHCP server connected to the network? Besides network connectivity, Autoinstall feature, needs DHCP connectivity as well.

Regards,

Giorgos

New Member

AutoInstall on the switch

Hi,

I tried with my 3560 and here is the result:

-Erase startup

-delete flash:vlan.dat

-reload

Model                        SW Version  

----------------                  -------------------              

WS-C3560-24PS         12.2(50)SE5               

Press RETURN to get started!

*Mar  1 00:00:37.396: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down

*Mar  1 00:00:59.433: %SYS-5-RESTART: System restarted --

Technical Support: http://www.cisco.com/techsupport

Compiled Tue 28-Sep-10 13:21 by prod_rel_team

*Mar  1 00:01:30.437: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

*Mar  1 00:01:42.626: AUTOINSTALL: Vlan1 is assigned 10.x.x.86

*Mar  1 00:01:52.633: AUTOINSTALL: Obtain tftp server address (opt 150) 10.x.x.66

*Mar  1 00:01:52.633: AUTOINSTALL: Obtain default router (opt 3) 10.x.x.1

%Error opening tftp://10.x.x.66/network-confg (Timed out)

%Error opening tftp://10.x.x.66/cisconet.cfg (Timed out)

So i havn't seen the "Would you like to terminate AutoInstall" message but it run by itself quickly if i don't touch anything. At least we know the normal behavior now.

Do you have this behavior too?

-Guillaume

New Member

AutoInstall on the switch

Hi,

  @Giorgos: Yes, there is a Windows 2008 acting as the DHCP server on the network (although not on the same subnet, I have configured the router with helper-address command). And for this scope, I have set the TFTP server (option 150 I believe) and the bootfile name (option 60 something, I believe).

  @Guillame: I'm not sure I have seen this message when the switch boots up with an empty configuration though. However, I may not be paying attention. I will update with new information.

Regards,

Angela

Bronze

AutoInstall on the switch

Angela,

Have you verified the DHCP scope is working on that subnet? Have you checked it on another device of that subnet, a PC for example?

Regards,

Giorgos

New Member

AutoInstall on the switch

Yes, there is an AP using the same scope, and it's working fine (registered at the WLC and available with show cdp neighbors)

Regards,

Angela

Hall of Fame Super Gold

Re: AutoInstall on the switch

It seems like I can't get the "Would you like to terminate AutoInstall" message on the switch when I reloaded it with no config.

In enable mode, type "setup" and see what happens.

Hmmmm ... 12.2(58)SE ... Do you want to try using Zero-Touch Smart Install?

New Member

Re: AutoInstall on the switch

I get it now, it's not I don't get the message, it's because the message is the first to appear, and when I hit "enter" several times to start, it just skips that message because it defaults to "yes" (skip it).

Now, I try to reload the switch and wait for the message, but it never shows up. Using 'setup' only brings the 'Would you like to enter initial configuration?' message, not what I wanted. And the even trickier thing: I try to type 'no' then hit enter, but I never got into AutoInstall. And the Cisco IOS actually tricks me with the message "Press RETURN to get started!". If I press return, it will just skip AutoInstall. What should I do?

Regards,

Angela

PS: leo, how can I choose to use Zero Touch instead of AutoInstall? Thanks.

PPS: I finally successfully said 'no' to the 'Would you like to terminal AutoInstall?' message, but it's useless. The switch never allowed me to enter AutoInstall. See below:

Would you like to terminate autoinstall? [yes]: n

         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: n

Would you like to terminate autoinstall? [yes]: n

Switch>What do I do now?

Message was edited by: angela zou

Hall of Fame Super Gold

AutoInstall on the switch

PS: leo, how can I choose to use Zero Touch instead of AutoInstall? Thanks.

Hi Angela,

Follow the attachment.  It's a step-by-step guide about how-to configure Zero-Touch.

New Member

Re: AutoInstall on the switch

  Not sure what you mean Leo, the only thing I see is how the file should be stored on the TFTP server, no tips about how to start Zero Touch.

Regards,

Angela

Hall of Fame Super Gold

AutoInstall on the switch

no tips about how to start Zero Touch.

If you enable the VStack, this starts up Zero-Touch.  The doco I've attached will teach you how to enable Zero-Touch and implement it.

New Member

Re: AutoInstall on the switch

Um, no stackwise in the design plan, yet.

Hall of Fame Super Gold

AutoInstall on the switch

Um, no stackwise in the design plan, yet.

No stackwise.

The main objective where I find Zero Touch useful is when you plan to deploy alot of switches.  When you connect the new switch to your VStack director the new switch will boot up, copy a configuration template and download the correct IOS from the VStack director.  You specify what exact IOS and configuration for a specific switch.

When the new switch boots up, it will have the correct IOS and a configuration.

3907
Views
0
Helpful
20
Replies