Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AutoQoS on Catalyst 3750 LAN switches

I'm a bit perplexed why the AutoQoS macro does not implement "priority-queue out" when configured on the 3750 platform running certain versions of software. The only other platform I have experience with AutoQos is on the 4500 and it enables priority queuing as expected. So what's up with autoqos on the 3750 on version 12.2(35)SE5?

When it comes to configuring QoS on campus user/phone access ports there are some important settings that can and should be considered but one can argue that enabling the priority queue is the single most impactful or important command. So I was very surprised and concerned when I didn't see priority-queue out. Cisco describes AutoQoS as a simple, quick way of deploying QoS on the LAN and it precludes you from having to learn all of the differences between hardware platforms. But is it true that this tool produces an incomplete config solution? Let me know if I am missing something.

Here is an example of what AutoQoS produces when applied to a 4507 with WS-X4648-RJ45V+E:

(other interface commands are left out for simplicity)

interface GigabitEthernet5/25
description XYZ

switchport mode access
auto qos voip cisco-phone
qos trust device cisco-phone
service-policy input AutoQos-VoIP-Input-Cos-Policy
service-policy output AutoQos-VoIP-Output-Policy

policy-map AutoQos-VoIP-Output-Policy

class AutoQos-VoIP-Bearer-QosGroup

   set dscp ef

   set cos 5

    priority  <<<<<<<<< LOOK HERE, Priority queuing is enabled as expected

    police cir percent 33

class AutoQos-VoIP-Control-QosGroup26

   set dscp af31

   set cos 3

    bandwidth remaining percent 5

class AutoQos-VoIP-Control-QosGroup24

   set dscp cs3

   set cos 3

    bandwidth remaining percent 5

class class-default

    dbl

Here is an example of what AutoQoS produces when applied to a 3750 running version 12.2.(35)SE5: (no priority-queue out)

interface GigabitEthernet1/0/36

switchport access vlan 8

switchport mode access

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

1 REPLY
New Member

AutoQoS on Catalyst 3750 LAN switches

My Cisco SE directed me to this bug which could explain this behavior. Even though my software release isn't listed in the known affected versions I'm going to accept this as the reason and move on:

Bug detail:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCee22591

I have noticed in later release IOS 12.2(58)SE2 priority queue is enabled as expected.

2840
Views
0
Helpful
1
Replies