Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Avaya phones and Cisco 2960S switch problem

I am experiencing problems with our Cisco 2960-S POE switch.

Our scenario is as follows: Cisco 2960 -> Avaya 4606 IP phone -> Windows XP PC

Whenever I plug the phone initially the phone  comes online without problem as does the PC.  However once the user logs  on to the PC and their user profile starts being pulled down and the  phone loses its connection to the Avaya phone system.

I am transitioning over to Cisco switches from  3com (4400,4500,5500) switches.  Both the PC and the Avaya 4606 work  fine with our 3com equipment but not with our Cisco equipment using the  same scenario as above

Has anyone else come across this problem or come has come up with a fix??

Thanks your your help in advance!

Everyone's tags (6)
14 REPLIES
Hall of Fame Super Gold

Re: Avaya phones and Cisco 2960S switch problem

Can you post the configuration of the interface?

Can you also post the output to the following commands:

1.  sh interface ;

2.  sh controller e ;

3.  sh version; and

4.  sh log

New Member

Re: Avaya phones and Cisco 2960S switch problem

leolaohoo - see attached.

Silver

Avaya phones and Cisco 2960S switch problem

Hi,

3Com and Cisco use slightly different port and voice vlan configuration settings. Can you please post the working 3Com port configuration (e.g. for 4500 family) and your current 2960S port (interface) configuration.

Thanks & Regards,

Antonin

New Member

Re: Avaya phones and Cisco 2960S switch problem

This is the config for the Cisco 2960S

interface GigabitEthernet1/0/3

switchport access vlan 60

switchport mode access

switchport voice vlan 61

spanning-tree portfast

This is the config for the 3COM 4500

interface Ethernet1/0/1

stp edged-port enable

port link-type hybrid

port hybrid vlan 61 tagged

port hybrid vlan 60 untagged

undo port hybrid vlan 1

port hybrid pvid vlan 60

broadcast-suppression PPS 3000

priority trust

packet-filter inbound link-group 4999 rule 0

Silver

Avaya phones and Cisco 2960S switch problem

Hi,

Thanks for the information supplied. Will you please add the "auto qos voip trust" command under the Gi1/0/3 interface and see if there is any progress.

Best regards,

Antonin

Hall of Fame Super Gold

Re: Avaya phones and Cisco 2960S switch problem

Thanks for the post of the output requestion.  Here are my questions:

1.  Uptime of the switch is 25 minutes.  This sure doesn't give me a good picture.

2.  What is connected to Gi 1/0/3?  Why did the interface negotiate to HALF duplex?

3.  Have you tried configuring Gi 1/0/3 as a trunk port and allow VLAN 60 and 61 only?

phone loses its connection to the Avaya phone system

If the Avaya phone system is connected to the Cisco switch, can you post the "sh interface " and "sh controller e " please?

Avaya phones and Cisco 2960S switch problem

Hello Chris,

We have 4625IP phones connected to 3560 POE switches and work with no issues (even when users connect laptops via phone PC port). Below is working config...

interface GigabitEthernet0/2

description 1st Flr IP Phones

switchport access vlan

switchport trunk encapsulation dot1q

switchport mode access

switchport voice vlan

auto qos voip trust ---> This command will automatically generate multiple QOS related config on interface and in         

                                   global mode as well.

spanning-tree portfast

!

Also, the phones negotiate at 100/Full.

hth

MS

New Member

Re: Avaya phones and Cisco 2960S switch problem

@amikat - I have tried that but it does not seem to make any difference.  The PC still loses connection.

@leolaohoo - As for your questions -

     1. - The switch has been bounced multiple times - that is why there is such a low uptime.

     2. - An Avaya 4606 IP phone and Windows XP pc is connected to this interface.  The Avaya 4606 are know to only negogiate to 100/half(in some of my buildings that only negogiate to 10half!). I have tried hard-coding speed/duplex to see if that would solve the problem, but it did not.

     3. - Yes, I have tried that as well, and the PC will still lose its connection.

This is the config I used:

          switchport mode trunk

          switchport trunk native vlan 60

          switchport trunk allowed vlan 60,61

          spanning-tree portfast trunk

The Avaya phone system itself is connected to a 3com core switch in our data center.

@mvsheik123 - Thanks for the config.  I've 4610's and 4620's in my enterprise and they are not having issues like the 4606 are.  In talking with Avaya, the 4606 phones are actually hubs and anything greater than 4610's are switches.

I've even tried disabling QOS and spanning-tree and tried a 'vanila' config and it still isn't working.

Thanks to everyone who has chimed in help so far, it has much appreciated!! I'm glad to know you guys have been thinking along the same lines I have been trying.  I've just never been this stumped with a Cisco problem like this!!

Silver

Re: Avaya phones and Cisco 2960S switch problem

Hi,

Thanks for the information supplied.

You can try few other configs if you like:

1) Activate the egress expedite queue via the "priority-queue out" interface command (under the Gi1/0/3 interface).

2) I understand that your Avaya 4606 is configured via DHCP. I would guess that you have already set Option 176 L2Q and L2QVLAN parameters. You can also try to explicitly set L2QAUD and L2QSIG parameters - Cisco recommends the values 5 and 3 respectively.

Will you please post the "sh mac add dyn | i Gi1/0/3" command output.

Thanks & Regards,

Antonin

New Member

Re: Avaya phones and Cisco 2960S switch problem

Thanks for the suggestions. 

I activated the 'priority-queue out' and it does not seem to have an affect.

I explicitly set the L2QAUD and L2QSIG parameters and it not help the situation.  Also, when I ran the command

"sh mac add dyn | i Gi1/0/3" I did not get any output.  Should I have?

Silver

Avaya phones and Cisco 2960S switch problem

Hi,

Thanks for the reply. Via the requested command output which should display the mac addresses of both the Avaya phone and PC I wanted to check the VLAN assignment. None of my 2960S switches run 15.0 release of IOS so perhaps the output changed at that particular version - can you please modify the command as "sh mac add dyn | i 1/0/3" and see if you get any output.

In addition to that I have checked again the output you have provided earlier and noticed that your Gi1/0/3 is negotiated at 100Mbps/half duplex with lots of collisions. As your speed and duplex settings are at default auto/auto this could be symptom of the fact that the other end settings are hardcoded as 100Mbps/full. So can you please try to configure "speed 100" and "duplex full" under the Gi1/0/3 interface and see if there is any progress.

Thanks & Regards,

Antonin

New Member

Avaya phones and Cisco 2960S switch problem

Was this issue ever resolved? I am having the exact same problems with Avaya 4612 phones and a 2960S switch. I have tried all the things mentioned here but it still disconnects when the pc becomes more acitve.

Thanks

New Member

Avaya phones and Cisco 2960S switch problem

Actually no - Cisco was not able to give a resolution to us.  They seemed to be stumped and pointed the finger at Avaya saying I needed to talk with them.

New Member

Avaya phones and Cisco 2960S switch problem

Are you using a 2960S with full POE (740 W) or 370 W ?.If you are using a 370W PoE switch,it might be drawing more power..i had the same kind of issue with Avaya Phones...it was more to do with the PoE not with the configuration..

10716
Views
0
Helpful
14
Replies
CreatePlease to create content