Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

back to back connection on single device (global to vrf)

Dear All,

I am trying to get a topology working using GNS3 Alpha 6 IOU L2 device, but actually the same issue applies to GNS3 using 3660 16ESW. I have not tried on real device, so maybe that is my issue :( In the real world it will be a 6500 Sup720

I have a single device, and would like to make a connection between the global route table and a vrf.

So I would have 1 interface on global, and one interface on vrf.

In GNS, I create a topology like this:

router e1/0 - switch port #1
router e1/1 - switch port #2

This creates a cable from one interface to another


Then the configuration is posted below.

Ping doesn't work, I don't even see a CDP neighbor.

I wonder if GNS supports the back2back connection (router connection to itself).

Any ideas? (theoretically it should work)

I have also tried make the interfaces e1/0 & e1/1 as the routed port, same issue. (Note that this is the only way to test it using GNS3 standard as 3660 does not support mac-address set on vlan interfaces)

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! CONFIG on IOU
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ip vrf UNSEC-BDR
rd 10.131.148.21:65002
!
interface Ethernet1/0
description border router to LAN (outside)
switchport access vlan 363
!
interface Ethernet1/1
description LAN to border router (inside)
switchport access vlan 364
!
interface Vlan363
description BDR to LAN (outside) - mac hsrp only possible on IOU
ip vrf forwarding UNSEC-BDR
ip address 10.8.16.21 255.255.255.240
mac-address 0000.0363.0001
!
interface Vlan364
ip address 10.8.16.18 255.255.255.240



!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! CONFIG on GNS
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!



ip vrf UNSEC-BDR
rd 10.131.148.21:65002
!
interface Ethernet1/0
description border router to LAN (outside)
no switchport
ip vrf forwarding UNSEC-BDR
ip address 10.8.16.21 255.255.255.240
!
interface Ethernet1/1
description LAN to border router (inside)
no switchport
ip address 10.8.16.18 255.255.255.240
!

Everyone's tags (1)
151
Views
0
Helpful
0
Replies