Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Bad connection between 2nd trunk port on switch

Hi

I have been trying to trunk to 2960  switches and can't seem to get a proper connection. I am using packet  tacer. The 1st switch already has a trunk port going to a router and the  router has port is trunked and has sub ints for each of vlans 2 and 3  and each sub trunk has respective  native encap vlan configured. My  management vlan is vlan 3. And I don't have an int vlan1 only int vlan  3. The router and the 1st siwtch work fine. But now I am trying to get  another trunk port with second switch. I configured both ints for  trunking using native vlan 1. Now the links are in up state but both  ends are not leds green, one is orange. And I have only int vlan 3 as  with other switch and ip in same subnet as managment ip but cannot ping.  Strange thing vtp info can pass but no connection to other switch vlans  and router etc, only local connectivity. Plz help, below is the configs  of the rotuer and two switches. It is switch 1 that is giving me beans  to connect to the rest.

topology1.jpg

Router0

version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname RouterA
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
username admin secret 5 $1$mERr$vPOtdREpWgzFVVY37SB2h/
!
!
!
!
!
ip name-server 0.0.0.0
!
!
!
!
!
!
interface Loopback0
  description management
  ip address 192.168.1.1 255.255.255.0
!
interface Loopback1
  ip address 192.168.2.1 255.255.255.224
!
interface FastEthernet0/0
  no ip address
  duplex auto
  speed auto
!
interface FastEthernet0/0.1
  encapsulation dot1Q 1 native
  ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0.2
  encapsulation dot1Q 2
  ip address 10.5.0.1 255.255.255.0
!
interface FastEthernet0/0.3
  encapsulation dot1Q 3
  ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/1
  description management
  no ip address
  duplex auto
  speed auto
!
interface Serial0/0
  ip address 172.16.1.1 255.255.255.252
!
interface Serial0/1
  no ip address
!
interface FastEthernet1/0
  no ip address
  duplex auto
  speed auto
!
interface FastEthernet1/1
  no ip address
  duplex auto
  speed auto
!
router rip
  version 2
  network 172.16.0.0
  network 192.168.1.0
  network 192.168.2.0
  no auto-summary
!
ip classless
!
!
access-list 1 permit 192.168.4.0 0.0.0.255
access-list 1 permit host 192.168.4.2
!
!
!
!
!
!
!
line con 0
line vty 0 4
  access-class 1 in
  password 7 08316C5D1A2E5505165A
  login
!
!
!
end

Switch 0 (connected to Router 0)

version  12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname SwitchA
!
no logging console
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
ip name-server 0.0.0.0
!
username admin password 7  08651D0A043C3705561E0B54322E2B3C2B063137324232064274
!
spanning-tree portfast default
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
  switchport access vlan 3
!
interface FastEthernet0/6
  switchport access vlan 3
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
  switchport access vlan 2
!
interface FastEthernet0/14
  switchport access vlan 2
!
interface FastEthernet0/15
  switchport access vlan 2
!
interface FastEthernet0/16
  switchport access vlan 2
!
interface FastEthernet0/17
  switchport access vlan 2
!
interface FastEthernet0/18
  switchport mode trunk
!
interface FastEthernet0/19
  switchport access vlan 2
  switchport mode access
!
interface FastEthernet0/20
  switchport access vlan 2
!
interface FastEthernet0/21
  switchport access vlan 2
!
interface FastEthernet0/22
  switchport mode access
!
interface FastEthernet0/23
  switchport access vlan 2
!
interface FastEthernet0/24
  switchport mode trunk
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
  no ip address
!
interface Vlan3
  ip address 192.168.4.10 255.255.255.0
!
ip default-gateway 192.168.4.1
!
!
access-list 1 permit 192.168.4.0 0.0.0.255
access-list 1 permit host 192.168.4.1
line con 0
!
line vty 0 4
  access-class 1 in
  password 7 08316C5D1A2E5505165A
  login
line vty 5 15
  login
!
!
end

Switch 1 (connected to Switch0) (This is the second  switch which I cannot get connected to rest of network properly)

version  12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
  switchport access vlan 3
!
interface FastEthernet0/6
  switchport access vlan 3
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
  switchport mode trunk
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
  no ip address
!
interface Vlan3
  ip address 192.168.4.20 255.255.255.0
!
ip default-gateway 192.168.4.1
!
!
line con 0
!
line vty 0 4
  login
line vty 5 15
  login
!
!
end

3 REPLIES

Re: Bad connection between 2nd trunk port on switch

Hi

Use show interface fastethernet 0/18 trunk , show interface fastethernet 0/23 trunk, show interface fastethernet 0/18 trunk and check whether the trunking is on.

if possible post the output here.

regds

New Member

Re: Bad connection between 2nd trunk port on switch

Hi,

Yes is up via sh switchport

Switch0

Switch0#sh int f0/24 switchport (connected to Router, 1st trunk on Switch0) (works well with communication and inter vlan routing)

Name: Fa0/24
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none

Switch0

Switch0#sh int f0/18 switchport (connected to Switch 1) (second trunk on Switch0)
Name: Fa0/18
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false


Switch 1 (can't ping Switch0 nor Router) (connected to second trunk on Switch 0)

Switch1#sh int f0/18 switchport

Name: Fa0/18
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false

VTP info is passing so I know the 2nd trunk between Switch0 and Switch1 is up. But for some reason, I don't know why they cannot ping each other. On both switches they both have SVI's in vlan 3. SVI vlan 1 is up also on bith switches but no ip's assigned. I am using SVI's only on vlan 3. My managment vlan is vlan 3. Objective is to have all my devices be managed by subnet assigned to vlan 3 SVI's. Router int f0/0.3 (vlan3) is 192.168.4.1, Switch 0 int vlan 3 is 192.168.4.10 and Switch 1 int vlan 3 is 192.168.4.20. Only Switch 1 cannot ping the rest of devices. Its port led is green but on the other end on Switch 0 its orange. Appreciate input, I am confused , but maybe somehing i am missing

New Member

Re: Bad connection between 2nd trunk port on switch

My problem was stp putting the port in blocking stat to avoid loop. That inturn was breaking the trunk. I created etherchannel between the two switches and this solved things.

585
Views
0
Helpful
3
Replies
CreatePlease to create content