Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Bad Perfomance L2tpv3 tunnel

Hope someone can give me any idea or suggestion.

I got a problem performance with a Static PE-to-PE Layer2 L2tp tunnel.

The line between the end point of the tunnel suppose to be 100Mbits/s. If I check it without tunnel (I mean with all the same devices but doing normal routing) I got around 5Mbytes/s which could be ok. But when I turn on the tunnel the bandwidth fall down to 0.8Mbytes/s.

How can be that? It could be because my router get so busy or could be any configuration problem. Is that normal?

The L2tp Tunnel are between two Cisco 2610XM with next features:

Cisco 2621XM with 127102K/3970K bytes of memory.

2 FastEthernet interfaces

32K bytes of NVRAM.

32768K bytes of processor board System flash (Read/Write)

IOS: c2600-adventerprisek9-mz.124-16.bin (which need 128 DRAM and 32 Flash, according Cisco WebSite)

The configuration I am using for the tunnel is:

!

l2tp-class l2tp-Param

hidden

authentication

hostname ###

password 7 ###

retransmit initial retries 30

!

pseudowire-class lnk

encapsulation l2tpv3

protocol none

ip local interface Loopback0

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

xconnect ### ### encapsulation l2tpv3 manual pw-class lnk

l2tp id ### ###

l2tp cookie local 4 ###

l2tp cookie remote 4 ###

l2tp hello l2tp-Param

!

I would be very grateful with any suggestion. Thanks.

2 REPLIES
New Member

Re: Bad Perfomance L2tpv3 tunnel

Any suuggestion about this issue?

Thanks in forward.

New Member

Re: Bad Perfomance L2tpv3 tunnel

Could be an MTU issue causing fragmentation.

Try ip pmtu max xxxx under your pseudowire-class

You may also experiment with

ip mtu and ip tcp adjust-mss under your F0/0 interface

308
Views
0
Helpful
2
Replies