Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Bandwidth Reservation-1841

Hi,

I have 10 Mbps Internet Leased Line connected to serial interface of Cisco 1841 Router.I want to reserve bandwidth say 2 Mbps dedicated for my CEO.

I am i can use CBWRQ QoS tool to reserve the bandwidth. But i suppose that, this QoS tool plays role only during Congestion.

How to reserve Bandwidth permanently? Can any help me

R.B.Kumar

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Blue

Re: Bandwidth Reservation-1841

R.B

You could use the priority command and use a class-map to identify your CEO's traffic eg.

access-list 101 permit ip host any

class-map CEO

match access-group 101

policy-map CEO

class CEO

priority 2000

int s0/1

service-policy output CE0

Your CEO would be guaranteed 2Mbps at all times although he may get more if the line is not busy. Your CEO PC/laptop would need a static IP address.

Jon

Hall of Fame Super Blue

Re: Bandwidth Reservation-1841

Hi R.B

My understanding is this is a minimum bandwidth guarantee so he will always get it.

If there is no congestion then he should get his 2Mbps of traffic anyway. Only if there is not enough bandwidth for his 2Mbps on the line will the QOS config become effective.

This is the way i understand it.

Jon

6 REPLIES
Hall of Fame Super Blue

Re: Bandwidth Reservation-1841

R.B

You could use the priority command and use a class-map to identify your CEO's traffic eg.

access-list 101 permit ip host any

class-map CEO

match access-group 101

policy-map CEO

class CEO

priority 2000

int s0/1

service-policy output CE0

Your CEO would be guaranteed 2Mbps at all times although he may get more if the line is not busy. Your CEO PC/laptop would need a static IP address.

Jon

New Member

Re: Bandwidth Reservation-1841

Hi Jon,

Nice to see you again.

In fact i am also using the same configuration in my router and it is working perfectly.

But i understood from various document that this is effective only during congestion period.

I am asking you is there any other method by which i can permanently fix this bandwidth to him.

R.B.Kumar

Hall of Fame Super Blue

Re: Bandwidth Reservation-1841

Hi R.B

My understanding is this is a minimum bandwidth guarantee so he will always get it.

If there is no congestion then he should get his 2Mbps of traffic anyway. Only if there is not enough bandwidth for his 2Mbps on the line will the QOS config become effective.

This is the way i understand it.

Jon

Super Bronze

Re: Bandwidth Reservation-1841

What Jon suggests, and you say you're already using, I would recommend against. Reason being, good chance CEO traffic from time to time will want to exceed 2 Mbps and if there's other traffic it will be policed. (Policing tends to slam TCP traffic rather hard.)

I would suggest either:

!CEO should get a minimum of 2 Mbps, may obtain up to 10 Mbps if available

policy-map myCBWFQ

class CEO

bandwidth remaining percent 20

class class-default

bandwidth remaining percent 80

or

!CEO will max at 2 Mbps but will attempt to queue, not initially drop, when over 2 Mbps

policy-map myCBWFQ

class CEO

priority percent 50

shape average percent 20

class class-default

fair-queue

PS:

(BTW: about your congestion concern with what you're doing now. If there no congestion, you don't need to "reserve" the 2 Mbps since it's LLQ and there's available bandwidth.)

Hall of Fame Super Blue

Re: Bandwidth Reservation-1841

Joseph

Problem with this approach is that CEO cannot see the need for a network upgrade as he always gets a very good service :-)

Must admit i'm not really in favour of giving CEO's any preferential treatment if it can be helped for this very reason. And there is a very good chance in my experience that the CEO traffic is actually a lot less critical to business that some of the other traffic altho of course the CEO often doesn't see it like that.

So i suggested policing knowing full well it would impact the traffic if there was congestion. I guess i was just in a difficult mood :-)

Jon

Super Bronze

Re: Bandwidth Reservation-1841

Now Jon, my suggestion doesn't really guarantee the CEO always receives very good service since the CEO is still limited to either a max of 2 Mbps or a minimum of 2 Mbps.

If I had suggested a configuration giving the CEO priority to all 10 Mbps, perhaps your point would be valid, but even then, the CEO might not find 10 Mbps sufficient so you might be approved for a bandwidth upgrade. ;)

255
Views
0
Helpful
6
Replies