Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

basic cisco 837 adsl configuration : slow connectivity

as title, this is my configuration:

Current configuration : 2545 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname QSI-BRD
!
boot-start-marker
boot-end-marker
!
memory-size iomem 5
!
no aaa new-model
!
!
!
!
ip cef
ip domain name qsilocal.org
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
vpdn enable
!
!
!
!
username admin privilege 15 secret 5 $1$ER6A$4AmF0Z7GhTlra4DTp3Ixi1
!
!

!
!
!
interface Ethernet0
  ip address 192.168.0.1 255.255.255.0
  ip nat inside
  ip virtual-reassembly
  hold-queue 100 out
!
interface Ethernet2
  no ip address
  shutdown
  hold-queue 100 out
!
interface ATM0
  no ip address
  no atm ilmi-keepalive
  dsl operating-mode auto
  pvc 8/35 
   pppoe-client dial-pool-number 1
  !
!
interface FastEthernet1
  duplex auto
  speed auto
!
interface FastEthernet2
  duplex auto
  speed auto
!
interface FastEthernet3
  duplex auto
  speed auto
!         
interface FastEthernet4
  duplex auto
  speed auto
!
interface Dialer0
  ip address negotiated
  ip mtu 1492
  ip nat outside
  ip virtual-reassembly
  encapsulation ppp
  dialer pool 1
  ppp authentication chap callin
  ppp chap hostname andreafl@liberolight
  ppp chap password 7 04481F03092042470848
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
no ip http secure-server
!
ip nat inside source list 100 interface Dialer0 overload
!         
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
!
!
!
control-plane
!
banner motd ^C
                             _
       .::::::::::.        -(_)====u         .::::::::::.
     .::::''''''::::.                      .::::''''''::::.
   .:::'          `::::....          ....::::'          `:::.
  .::'             `:::::::|        |:::::::'             `::.
.::|               |::::::|_ ___ __|::::::|               |::.
`--'               |::::::|_()__()_|::::::|               `--'
  :::               |::-o::|        |::o-::|               :::
  `::.             .|::::::|        |::::::|.             .::'
   `:::.          .::\-----'        `-----/::.          .:::'
     `::::......::::'                      `::::......::::'
       `::::::::::'                          `::::::::::'

     This is the QSI International School of Brindisi Router
     You are supposed to be here only if Authorized,
     if you are not, please go away, all not authorized
     accesses are logged and will be pursued by law.
^C
!
line con 0
  logging synchronous
  login local
  no modem enable
line aux 0
line vty 0 4
  no login
!
scheduler max-task-time 5000
end

what i'm experiencing is a very slow (or missing) internet browsing on some websites. the browsers look to hang waiting for something, maybe a reply from the server. some webistes like google are just fast, others like cisco.com take forever, and sometimes nothing is shown on screen. Using a sitecom home router, the connection works flawless. I'm experiencing a similar issue with a 1841 (and a different provider) with a similar configuration...

what's wrong? i honeslty can't figure it out!

thanks for help

Everyone's tags (2)
2 REPLIES
New Member

Re: basic cisco 837 adsl configuration : slow connectivity

the problem was the mtu!

no ip mtu

into the DIaler interface solved the issue.

for people how's interested my configration is here (only dyndns is missing)

Building configuration...

Current configuration : 4546 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname QSI-BRD
!
boot-start-marker
boot-end-marker
!
memory-size iomem 5
!
no aaa new-model
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1
!
ip dhcp pool 1
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 8.8.8.8
   domain-name qsilocal.org
!
!
ip cef
ip domain name qsilocal.org
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
vpdn enable
!
!
!
crypto pki trustpoint TP-self-signed-147684749
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-147684749
revocation-check none
rsakeypair TP-self-signed-147684749
!
!
crypto pki certificate chain TP-self-signed-147684749
certificate self-signed 01
  3082024A 308201B3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31343736 38343734 39301E17 0D313031 32333030 32333835
  345A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3134 37363834
  37343930 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  DA3DC187 6463975B 54599934 EF3E390B 6ECCFAA6 6B7A0B57 A83E8D5A 25CF387B
  3DE3986E B8DD2EDB 71C81DED F48465AA 2C2561C4 8567DBBF D9BF1671 337C3A31
  D1898B90 C416FFC9 598D6C4D 2B2FD4BE 85E7DB42 09A8B534 3180004C 0B50C1D4
  B7C3CB99 252F45C4 A4EB1EC3 880B7777 EFD906F6 BFAE323F CD79CC12 718A9515
  02030100 01A37430 72300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
  11041830 16821451 53492D42 52442E71 73696C6F 63616C2E 6F726730 1F060355
  1D230418 30168014 6D6F9041 F2101788 D173D187 0AD349F6 6E12F5AC 301D0603
  551D0E04 1604146D 6F9041F2 101788D1 73D1870A D349F66E 12F5AC30 0D06092A
  864886F7 0D010104 05000381 81009C75 E5153641 659699D3 F12ACEE5 6F694303
  6483E631 51BE9D69 4AAEFC44 9835035F 0E05AEFF 6B59A2E7 F04FFDDC 98742495
  47F7154F 0B71431F 2651FAB5 38B957E9 EDFE93FA A0BB4F6A AB643F33 81779422
  8867EF4C 96E8B443 38870A4E 48F3B7AB 94D5173C 456E03FF 95000837 45F787B1
  EC64D76A 830A1000 5CEE6214 E6D0
  quit
username admin privilege 15 secret 5 $1$ER6A$4AmF0Z7GhTlra4DTp3Ixi1
!
!
ip ssh version 2
!
!
!
!
interface Ethernet0
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
hold-queue 100 out
!
interface Ethernet2
no ip address
shutdown
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
!
interface FastEthernet1
duplex auto
speed auto
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname andreafl@liberolight
ppp chap password 7 04481F03092042470848
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
ip http authentication local
ip http secure-server
ip http max-connections 2
!
ip nat inside source list 100 interface Dialer0 overload
!
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
no cdp run
!
!
!
control-plane
!
banner motd ^C
                            _
      .::::::::::.        -(_)====u         .::::::::::.
    .::::''''''::::.                      .::::''''''::::.
  .:::'          `::::....          ....::::'          `:::.
.::'             `:::::::|        |:::::::'             `::.
.::|               |::::::|_ ___ __|::::::|               |::.
`--'               |::::::|_()__()_|::::::|               `--'
:::               |::-o::|        |::o-::|               :::
`::.             .|::::::|        |::::::|.             .::'
  `:::.          .::\-----'        `-----/::.          .:::'
    `::::......::::'                      `::::......::::'
      `::::::::::'                          `::::::::::'

    This is the QSI International School of Brindisi Router
    You are supposed to be here only if Authorized,
    if you are not, please go away, all not authorized
    accesses are logged and will be pursued by law.
^C
!
line con 0
logging synchronous
login local
no modem enable
line aux 0
line vty 0 4
logging synchronous
login local
transport input ssh
!
scheduler max-task-time 5000
end

New Member

what is your password for

what is your password for this config?
"username admin privilege 15 secret 5 $1$ER6A$4AmF0Z7GhTlra4DTp3Ixi1"

2908
Views
0
Helpful
2
Replies