Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Basic router config

Hi,

I must be losing it. I'm setting up a 1721 router internally on my nework. I've configured both interfaces and both are up up. I've configured a default route and a name server but I can't seem to get it to route. can anyone see anything obvious?

Router#sho run
Building configuration...

Current configuration : 706 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$jynz$4oGBbyDEp2dk17MPN3i3t/
enable password *******

!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
!
ip name-server 192.168.200.200
!
ip cef
!
!
!
!
interface Ethernet0
ip address 192.168.200.236 255.255.255.0
half-duplex
!
interface FastEthernet0
ip address 172.16.0.254 255.255.0.0
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.200.1
no ip http server
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Router#

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Basic router config

Eggzter100 wrote:

The IP Route 172.16.0.0 255.255.0.0 fastethernet0

And IP Route 192.168.200.0 255.255.255.0 ethernet0

commands didn't work. I still can't ping anything on the 192 network except 192.168.200.236.

What is the default-gateway set to on all devices on the 192.168.200.x network ?

If you can't ping the 192.168.200.1 address then check that device to see if it has a route for the 172.16.0.0 pointing back to 192.168.200.236.

It sounds like all the 192.168.200.x devices are using a default-gateway that is not your router ie. probably the 192.168.200.1 device and this is missing a route.

Note that if you have no control over the 192.168.200.1 device then you can NAT your 172.16.x.x addresses to 192.168.200.236 so that the 192.168.200.1 device would know where to send return packets but it would be easier to configure a route on the 192.168.200.1 device if you have access eg.

ip route 172.16.0.0 255.255.0.0 192.168.200.236

Jon

12 REPLIES
VIP Super Bronze

Re: Basic router config

Hi,

Can you ping the opposite site of each interface ie 192.168.200.1?

Reza

New Member

Re: Basic router config

From inside the 172.16.0.0 network I can't ping 192.168.200.1. From the router I can ping both sides. The default gateway from the 172.16.0.0 network is 172.16.0.254.

Re: Basic router config

I don't see a route to the 172 network?

Mike

VIP Super Bronze

Re: Basic router config

From inside the 172.16.0.0 network can you ping 192.168.200.236?

Do you have the correct default on the device your pinging from?

Re: Basic router config

I think you could add this and it would work

ip route 172.16.0.0 255.255.0.0 FastEthernet0

Mike

New Member

Re: Basic router config

The IP Route 172.16.0.0 255.255.0.0 fastethernet0

And IP Route 192.168.200.0 255.255.255.0 ethernet0

commands didn't work. I still can't ping anything on the 192 network except 192.168.200.236.

Hall of Fame Super Blue

Re: Basic router config

Eggzter100 wrote:

The IP Route 172.16.0.0 255.255.0.0 fastethernet0

And IP Route 192.168.200.0 255.255.255.0 ethernet0

commands didn't work. I still can't ping anything on the 192 network except 192.168.200.236.

What is the default-gateway set to on all devices on the 192.168.200.x network ?

If you can't ping the 192.168.200.1 address then check that device to see if it has a route for the 172.16.0.0 pointing back to 192.168.200.236.

It sounds like all the 192.168.200.x devices are using a default-gateway that is not your router ie. probably the 192.168.200.1 device and this is missing a route.

Note that if you have no control over the 192.168.200.1 device then you can NAT your 172.16.x.x addresses to 192.168.200.236 so that the 192.168.200.1 device would know where to send return packets but it would be easier to configure a route on the 192.168.200.1 device if you have access eg.

ip route 172.16.0.0 255.255.0.0 192.168.200.236

Jon

New Member

Re: Basic router config

Hi Jon,

Yeah, I got there in the end. Thanks for your input though.

Regards

Egg

New Member

Re: Basic router config

I can ping the 192.168.200.236 address from the 172 network which has got the correct gatway configured, but I can't pin anything else on the 192 network.

VIP Super Bronze

Re: Basic router config

can you check to see if 192.168.200.1 is actually configure on that device. Is it another router?

New Member

Re: Basic router config

Yes it's another router out to the internet and the default gateway from the 192 network.

New Member

Re: Basic router config

Are you using a routing protocol?  I don't see one in the config.

do a "show ip route" and see what you get.

you'll probably just see two connected interfaces only.

If you use eigrp or ospf, they'll automatically grab the connected interfaces.

try this:

config t

router eigrp

network 192.168.0.0

network 172.16.0.0

!

end

That should get you moving right along.

597
Views
0
Helpful
12
Replies