cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
758
Views
0
Helpful
3
Replies

Basic switch configuration

kabeer350
Level 1
Level 1

hi

I need help about Cisco switch 2960 issue how i give IP address gateway in switch if there more than two vlan  and how configure  telnet command 

plz help me 

3 Replies 3

John Blakley
VIP Alumni
VIP Alumni

You can have one management vlan available. Let's say it's vlan 1 which is default. To configure:

int vlan 1

ip address 192.168.1.1 255.255.255.0

no shut

 

A basic telnet session is:

line vty 0 4

password cisco

 

You can get more granular with usernames like using local accounts and radius authentication for telnet as well. You'll also need an enable password before you can telnet:

enable secret cisco

HTH,

John

HTH, John *** Please rate all useful posts ***

thanks a lot john

if we create extra vlan and not access any interface and just give ip address and not shut command then it work

 

Pedro Lereno
Level 1
Level 1

Hi,

Do you have Lan Lite or Lan Base license (check with "show version")? LAN LITE does not permit routing.

With LAN BASE:

sdm prefer lanbase-routing // save before your config, you may loose some configuration

reload the switch

 

Example for gateway configuration:

vlan 10

vlan 20

interface vlan 10

ip address 10.0.10.1 255.255.255.0

interface vlan 20

ip address 10.0.20.1 255.255.255.0

 

For telnet:

username name privilege 15 secret password

line vty 0 15

login local

transport input all

 

But, do not use telnet (all traffic passes on clear including passwords), use instead ssh if the switch permits:

hostname switch

ip domain name company.com

crypto key generate rsa general-keys modulus 2028

line vty 0 15

login local

transport input ssh

 

Hope this could help you!

 

Regards,

 

Pedro Lereno

 

 

 

 

Review Cisco Networking products for a $25 gift card