Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Basic UC520 Configuration

Hi All,

I'm starting preparations to study for my CCNA voice. My company let me borrow a UC520 router to practice phone configurations, however I've been having a hard time getting a basic configuration going. My phones aren't receiving DHCP responses from the router. 

I wanted to configure the router so that it was connected to my linksys router so I could configure it from anywhere in the house. Since the router only has 1 WAN port, I configured that with a 192.168.1.0/24 address and a default gateway pointing to my home router. This allows me to ping addresses on the internet and use telnet to configure my router from in my house.

 

I wanted to make the phones on a separate network so I created a vlan for voice and a dhcp pool VOICE which should hand out ip addresses in the 172.16.1.0 /24 network with a default gateway that is a subinterface for fa0/0. This is where I think I'm going wrong, but not sure how to do this if I want my phones to be on a separate subnet. Here's a copy of my running config.

 

 

dot11 syslog
ip source-route
ip cef
!
!
ip dhcp excluded-address 172.16.1.1 172.16.1.5
ip dhcp excluded-address 172.16.2.1 172.16.2.5
!
ip dhcp pool VOICE
 network 172.16.1.1 255.255.255.0
 dns-server 8.8.8.8
 default-router 172.16.1.1 255.255.255.0
 option 150 ip 172.16.1.1 255.255.255.0
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 sip
  registrar server expires max 600 min 60
!
!
!
!
!
voice-card 0
!
!
!
license udi pid UC520W-8U-4FXO-K9 sn FTX1144Y0WM
username josh privilege 15 secret 4 X4ZqtPJ///KxuEWxHSsJrv3beQVnz2ise/xj8fF6eFU
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.149 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0.50
 encapsulation dot1Q 50
 ip address 172.16.2.1 255.255.255.0
!
interface Integrated-Service-Engine0/0
 ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/1/0
 switchport voice vlan 10
 no ip address
!
interface FastEthernet0/1/1
 switchport voice vlan 10
 no ip address
!
interface FastEthernet0/1/2
 switchport voice vlan 10
 no ip address
!
interface FastEthernet0/1/3
 switchport voice vlan 10
 no ip address
!
interface FastEthernet0/1/4
 switchport voice vlan 10
 no ip address
!
interface FastEthernet0/1/5
 switchport voice vlan 10
 no ip address
!
interface FastEthernet0/1/6
 switchport voice vlan 10
 no ip address
!
interface FastEthernet0/1/7
 switchport voice vlan 10
 no ip address
!
interface FastEthernet0/1/8
 switchport access vlan 50
 switchport voice vlan 10
 no ip address
!
interface Dot11Radio0/5/0
 no ip address
 shutdown
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
voice-port 0/4/0
 auto-cut-through
 signal immediate
 input gain auto-control
 description Music On Hold Port
!
!
!
!
!
telephony-service
 max-ephones 10
 max-dn 50
 ip source-address 172.16.1.1 port 2000
 max-conferences 4 gain -6
 transfer-system full-consult
!
!
ephone-dn  1
 number 100
!
!
ephone  1
 device-security-mode none
 mac-address A44C.11A0.D056
 button  1:1
!
!
!
line con 0
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
line vty 0 4
 login local
 transport input telnet ssh
!
end

 

 

Of course, any help is appreciated! Thank you!

 

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Hi,1-You have 2 default

Hi,

1-You have 2 default routes as follows:

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 0.0.0.0 0.0.0.0 192.168.1.1

you don't need both.  I recommend deleting this one.

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

2-The issue with your config is that you are trying to configure 2 subnets over the same link (fa0/0).  So this means you have to trunk the interface form your switch to the Linksys router with dot1.q. You have done so for subnet 172.16.1.1 255.255.255.0 but not for subnet 192.168.1.149 255.255.255.0

so, you have to change your config to look something like this:

 

interface FastEthernet0/0
 duplex auto
 speed auto

interface FastEthernet0/0.9

encapsulation dot1Q 9
 ip address 192.168.1.149 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 172.16.1.1 255.255.255.0

now, you also need to trunk the Linksys router interface with dot1.q.

If you have NAT statements on the Linksys and the phones need to have access to Internet, you also need to add 172.16.1.1 255.255.255.0 to your NAT.

HTH

 

 

 

 

 

 

4 REPLIES
VIP Super Bronze

Hi,Can you change this:ip

Hi,

Can you change this:

ip dhcp pool VOICE
 network 172.16.1.1 255.255.255.0

to this and test again?

ip dhcp pool VOICE
 network 172.16.1.0 255.255.255.0

HTH

New Member

Hi Reza, Thank you for the

Hi Reza,

 

Thank you for the replay. As soon as I posted that, I noticed that mistake and changed it, but the phones are still not  getting IP addresses. 

VIP Super Bronze

Hi,1-You have 2 default

Hi,

1-You have 2 default routes as follows:

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 0.0.0.0 0.0.0.0 192.168.1.1

you don't need both.  I recommend deleting this one.

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

2-The issue with your config is that you are trying to configure 2 subnets over the same link (fa0/0).  So this means you have to trunk the interface form your switch to the Linksys router with dot1.q. You have done so for subnet 172.16.1.1 255.255.255.0 but not for subnet 192.168.1.149 255.255.255.0

so, you have to change your config to look something like this:

 

interface FastEthernet0/0
 duplex auto
 speed auto

interface FastEthernet0/0.9

encapsulation dot1Q 9
 ip address 192.168.1.149 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 172.16.1.1 255.255.255.0

now, you also need to trunk the Linksys router interface with dot1.q.

If you have NAT statements on the Linksys and the phones need to have access to Internet, you also need to add 172.16.1.1 255.255.255.0 to your NAT.

HTH

 

 

 

 

 

 

New Member

Hi Reza, Thank you again for

Hi Reza,

 

Thank you again for your response. As far as I can tell, my linksys router does not support vlan tagging sad.  When I remove the ip configuration from int fa0/0 and assign the ip address to fa0/0.9, I lose connectivity through telnet in my home network. 

If I need to, I will just scrap the idea of being able to work from anywhere in my house, though I feel there should be some way for me to get it going. We'll see! 

 

-Josh

361
Views
0
Helpful
4
Replies
CreatePlease to create content