cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
390
Views
10
Helpful
2
Replies

Basic Vlan routing question

bryanrobh
Level 1
Level 1

I am connecting a 4503 to a 2950.  I have native Vlan 1 between them on the trunk.  On that vlan 1 the subnet is 172.16.138.0.  The default gateway on the 2950 is 172.16.138.1.  There are devices attached to the 2950 that are all subnet 172.16.98.0.  I need to be able to get those devices to talk to the 4503. The only vlan I had on the 2950 is vlan 1.   I made another vlan on the 2950 but when I try to no sh it I get kicked out of the switch.     Any ideas?              

2 Replies 2

John Blakley
VIP Alumni
VIP Alumni

The 2950 is a L2 switch and can only have a single vlan interface for management. When you're creating a new vlan, it's kicking you out because the 4500 doesn't have the vlan configured to support the new vlan that you're creating. That being said, you should be able to do the following to route your other subnet:

If the 4500 vlan 1 subnet is 172.16.138.0/24, and you're wanting to create 172.16.98.0/24, you'll need to do it on the 4500.

4500: (Assuming you want to create vlan 10)

vlan 10

int vlan 10

ip address 172.16.98.1 255.255.255.0

Then you'll need to trunk the port that leads to the 2950 - assume that's fa0/1

int fa0/1

switchport trunk encaps dot1q

switchport mode trunk

Then on the 2950, you'll need to keep your vlan 1 interface:

int vlan 1

ip address 172.16.138.2 255.255.255.0

ip default-gateway 172.16.138.1 <-- this is to get to the management vlan interface above from another subnet

Then create your vlan that matches on the 4500 (vlan 10)

vlan 10

Trunk the port that leads to the 4500 (assuming f0/1)

int fa0/1

switchport trunk encaps dot1q

switchport mode trunk

Then the ports that you want on vlan 10, you'll put in the vlan:

int range fa1/2-48

switchport mode access

switchport access vlan 10

Your hosts will use 172.16.98.1 as a default gateway, but that traffic will be routed at the 4500 series switch. The 2950 cannot do the routing for you, but it can carry the vlan information that you need.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***

glen.grant
VIP Alumni
VIP Alumni

  You are getting confused between a layer 2 vlan on the 2950  and creating the layer 3 SVI for switch management.  As John said the address on the switch is to manage it only so when you create another svi and no shut it , you killed yourself because your telnet session came in on the other vlan which shut down when you did a no shut on the new SVI because only 1 can be active at a time.  John explained everything else you need to do .

Review Cisco Networking products for a $25 gift card