Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

bfd with ospf

I am seeing lots of the errors below on routers BFD is enable on and i suspect the problem is related to the BFD timers are too low. Below is config on one of the routers. I have removed some configs for confidential reasons. I am seeing the errors every 1mins...

Config

#######

interface GigabitEthernet2/1/1
  bandwidth 100000
ip address *******
ip ospf network point-to-point
ip ospf cost 1000
ip ospf hello-interval 3
ip ospf dead-interval 10
ip ospf bfd
load-interval 30
media-type rj45
speed 100
duplex full
no negotiation auto
bfd interval 100 min_rx 100 multiplier 5
service-policy output INT_OUT
end

router ospf 1
log-adjacency-changes
timers throttle spf 100 2000 10000

bfd interval 50 min_rx 50 multiplier 5

Logs

######

Mar 12 13:24:55.851 GMT: %OSPF-5-ADJCHG: Process 1, Nbr ******* on GigabitEthernet2/1/1 from FULL to DOWN, Neighbor Down: BFD node down
Mar 12 13:24:57.779 GMT: %OSPF-5-ADJCHG: Process 1, Nbr ******** on GigabitEthernet2/1/1 from LOADING to FULL, Loading Done

Verification

###########

sh bfd neighbors *********** details

OurAddr       NeighAddr     LD/RD  RH/RS  Holddown(mult)  State     Int
*************   **********    74/113    Up        416  (5 )   Up        Gi2/1/1       
Session state is UP and not using echo function.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 100000, MinRxInt: 100000, Multiplier: 5
Received MinRxInt: 100000, Received Multiplier: 5
Holddown (hits): 416(0), Hello (hits): 100(117697)
Rx Count: 79630, Rx Interval (ms) min/max/avg: 80/104/90 last: 84 ms ago
Tx Count: 79557, Tx Interval (ms) min/max/avg: 80/104/90 last: 64 ms ago
Elapsed time watermarks: -1 0 (last: 0)
Registered protocols: OSPF
Uptime: 02:29:15
Last packet: Version: 1            - Diagnostic: 0
             State bit: Up         - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 5         - Length: 24
             My Discr.: 113          - Your Discr.: 74
             Min tx interval: 100000    - Min rx interval: 100000
             Min Echo interval: 0

sh ip ospf neighbor gigabitEthernet 2/1/1 detail
Neighbor *********, interface address **************
    In the area 0.0.0.0 via interface GigabitEthernet2/1/1, BFD enabled
    Neighbor priority is 0, State is FULL, 6 state changes
    DR is 0.0.0.0 BDR is 0.0.0.0
    Options is 0x12 in Hello (E-bit L-bit )
    Options is 0x52 in DBD (E-bit L-bit O-bit)
    LLS Options is 0x1 (LR)
    Dead timer due in 00:00:09
    Neighbor is up for 02:30:15
    Index 4/4, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec

Any ideas?

6 REPLIES
Hall of Fame Super Silver

Re: bfd with ospf

Hello Francisco,

the OSPF adjacency looks like stable:

>> Neighbor is up for 02:30:15

and the holddown hit counter is zero:

>> Received MinRxInt: 100000, Received Multiplier: 5
Holddown (hits): 416(0), Hello (hits): 100(117697)

At least in this time interval BFD behaviour appears correct.

Have you increased the timers?

Hope to help

Giuseppe

Re: bfd with ospf

Hi Giuseppe,

We havent increased any of the timers. We are currently using the timers i mentioned above and both OSPF & BFD looks stable based on the output but we are seeing constantly the logs.

Previoius setup i have done for BFD i used 300ms and a multipler of 3 and that seemed to work fine without any errors.

I thought the BDF timer and multipler was too low. "bfd interval 50 min_rx 50 multiplier 5"

The interface on the peers are gig but the BW on the circuit is 100mb between sites spanned geographically  between india and singapore..

I was gonna test my config in a lab but havent had the time yet to.

Any ideas?

Hall of Fame Super Silver

Re: bfd with ospf

Hello Francisco,

>>

I thought the BDF timer and multipler was too low. "bfd interval 50 min_rx 50 multiplier 5"

The interface on the peers are gig but the BW on the circuit is 100mb between sites spanned geographically  between india and singapore..

I guess the delay is in the order of 20-40 msec over the path.

Well, I would stay at 4* RTT on the path just to be in a reasonable rate: there is little sense on having a BFD frequency comparable to delay on the path.

However, as I wrote before your BFD statistics look like well in last hours.

>> The interface on the peers are gig but the BW on the circuit is 100mb

This should be handled if possible with appropriate QoS tools.

if possible because what you can do is platform dependent.

Ideally a hierarchical QoS with a parent policy shaping all traffic within 100 Mbps and a child policy that implements a scheduler with also a traffic class for OSPF and BFD is the best solution.

Without QoS tools applied there is chance for BFD or OSPF hello packets to be discarded if total traffic exceeds  the 100 Mbps.

Hope to help

Giuseppe

Re: bfd with ospf

Giuseppe,

We do have LLQ and CBWFQ enable. See below. What i do not see is a match for BFD unless BFD falls under DSCP class cs6 for routing traffic by default. I believe BFD uses UDP port 3784 for destination and ensulation and source port range 49152 to 65535. Policy-map is not showing any drops though!

class-map match-all Routing_Traffic

  match access-group name Routing_Traffic

policy-map INT_OUT
class Routing_Traffic
    bandwidth remaining percent 5

ip access-list extended Routing_Traffic
remark >> accept dscp cs6 <<
permit ip any any dscp cs6
remark >> BGP <<<
permit tcp any eq bgp any
permit tcp any any eq bgp
remark >> HSRP <<
permit udp any host 224.0.0.2 eq 1985
remark >> U_MARK_ROUTINGQ-version-2 <<

sh policy-map interface gigabitEthernet 2/1/1

Class-map:Routing_Traffic (match-all)
      7998 packets, 1643564 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: ip dscp cs6 (48)
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0
      bandwidth remaining 5%

Class-map: class-default (match-any)
      23 packets, 5208 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any
      Queueing

Francisco

Hall of Fame Super Silver

Re: bfd with ospf

Hello Francisco,

you are doing the best for this link.

Actually, matching rate for routing protocol traffic class is too low as you noted.

I would suggest to enable IP BFD with a lan switch in between to use SPAN and do a packet capture to see how these BFD packets are coded.

http://www.ietf.org/id/draft-ietf-bfd-v4v6-1hop-11.txt

your understanding is correct UDP port 3784 and 3785 (echo) on one side.

But I don't see a spec about DSCP.

To be noted I remember that some RSVP messages use DSCP 0 I saw this on a packet capture.

Hope to help

Giuseppe

Re: bfd with ospf

Giuseppe,

Just to let you know i increased the BFD  timer and multipler and that stopped bfd logs.

Cheers

Francisco

4002
Views
0
Helpful
6
Replies
CreatePlease to create content