Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP - command no syncronization

Hello,

I have a question regarding the topology shown:

http://docwiki.cisco.com/w/images/3/39/S4590.jpg

Are already configured command "no syncronization" on routers A and B

!Router A

network 150.10.0.0

neighbor 3.3.3.4 remote-as 100

neighbor 2.2.2.1 remote-as 300

no synchronization

!Router B

router bgp 100

network 150.10.0.0

neighbor 1.1.1.2 remote-as 400

neighbor 3.3.3.3 remote-as 100

no synchronization

!Router D

router bgp 400

neighbor 1.1.1.1 remote-as 100

network 175.10.0.0

Example taken from  http://docwiki.cisco.com/wiki/Internetworking_Case_Studies_--_Using_the_Border_Gateway_Protocol_for_Interdomain_Routing#Using_the_Border_Gateway_Protocol_for_Interdomain_Routing

What if the router D comes a package from his own network whose destination is 172.10.1.1?

If I run the command "no syncronization" in the B router, this router will happen to the router 170.10 Route D.

That being the router D will install the 172.10 route in its routing table

If router D comes a packet destined for 172.10.1.1, the router D is going to move to B.

The question is:

What will happen to that package?

What about the package router B?

Is the package will reach C?

Please help me?

Regards.

Sabrina

1 ACCEPTED SOLUTION

Accepted Solutions

BGP - command no syncronization

Okay, I see what you're asking now. In your scenario, sync being disabled doesn't apply. If you sent a package from D to C or vice versa, the packet would get there fine with one catch. The two routers in between are ibgp neighbors. IBGP doesn't change the next hop when it passes the route to it's neighbors. For example, if C was advertising 172.10.0.0/24 to router A, A will advertise to B. A is going to advertise the route exactly like C advertised it by telling B that to get to 172.10.0.0/24, go to router C's wan interface. The problem with that is that router B may not know how to get to router C's wan interface. To resolve this, "next-hop-self" needs to be configured on router A for the router B neighbor. That way, router A can modify the next hop to itself for router B to be able to use.

After doing a little testing, it doesn't seem like enabling sync on the two edge routers affects anything and traffic still passes. If I enable sync on the two middle routers (A and B), the two edge routers do not get the route from the other. (C doesn't see D.)

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
4 REPLIES

BGP - command no syncronization

Sabrina,

In your example, synchronization wouldn't have an effect. The synchronization problem comes into play when you have a router that's running bgp and an igp (ospf, eigrp, rip). The rule states that bgp cannot put into it's table a route learned unless it's also known by the igp. In your example, bgp is the only thing running so you wouldn't have an issue. The packet will get everywhere it needs to. The same page has another diagram that is more focused on the problem with router E running an igp with routers A and B. If router A learned of a route from router C and then advertised it to router B, router B couldn't advertise it to router D until it learned the same route from router E. The default now is synchronization is disabled.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

BGP - command no syncronization

John,

Thank you very much for your prompt response.

I beg your pardon, I generated a confusion. I was wrong. The IP packet is destined 170.10.1.1 (no 172.10.1.1)

Again I ask:

What will happen to that package?

What about the package router B?

Is the package will reach C?

BGP - command no syncronization

Okay, I see what you're asking now. In your scenario, sync being disabled doesn't apply. If you sent a package from D to C or vice versa, the packet would get there fine with one catch. The two routers in between are ibgp neighbors. IBGP doesn't change the next hop when it passes the route to it's neighbors. For example, if C was advertising 172.10.0.0/24 to router A, A will advertise to B. A is going to advertise the route exactly like C advertised it by telling B that to get to 172.10.0.0/24, go to router C's wan interface. The problem with that is that router B may not know how to get to router C's wan interface. To resolve this, "next-hop-self" needs to be configured on router A for the router B neighbor. That way, router A can modify the next hop to itself for router B to be able to use.

After doing a little testing, it doesn't seem like enabling sync on the two edge routers affects anything and traffic still passes. If I enable sync on the two middle routers (A and B), the two edge routers do not get the route from the other. (C doesn't see D.)

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: BGP - command no syncronization

why the package will not reach its destination?

If A B I teach that "A knows" how to reach 172.10.0.0, then A could not discard the packet. YC was the one who taught him to A to C "knows" how to get to 172.10.0.0, meaning that C is not going to drop the packet if you receive a package like that.

Where then the package will fail?

339
Views
0
Helpful
4
Replies