Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

BGP not Redistributing into EIGRP

Trying to setup a mock backup scenario with a few routers. BGP is working ok, but not redisributing in EIGRP

Basic Setup:

RA <-> RB <-> RD <-> RSw F

I have the following configured on each box.

Router A:

int e0

ip address 10.216.110.1 255.255.255.0

int loopback 0

ip address 10.205.10.1

EIGRP 100

network 10.0.0.0

BGP 64001

redistribute eigrp 100

network 10.0.0.0

neighbor 10.216.110.2 remote-as 64002

no sync

no auto-summary

Router B:

int e0

ip address 10.216.110.2 255.255.255.0

int e1

ip address 10.216.200.2 255.255.255.0

BGP 64002

network 10.0.0.0

neighbor 10.216.110.1 remote-as 64001

neighbor 10.216.200.1 remote-as 64004

no sync

no auto-summary

Router D:

int e0

ip address 10.216.200.1 255.255.255.0

int e1

ip address 10.200.100.2 255.255.255.0

EIGRP 100

redistribute bgp 64004

network 10.0.0.0

BGP 64004

redistribute eigrp 100

network 10.0.0.0

neighbor 10.216.200.2 remote-as 64002

no sync

no auto-summary

Switch 4506 F:

ip routing

int vlan 1

ip address 10.200.100.1 255.255.255.0

int loopback 0

ip address 10.205.105.1

EIGRP 100

network 10.0.0.0

......

What happens is all loopback interfaces and routes from Router A make it to B & D. All routers from Switch F make it to Router D, B, and A. But the routes from A & B that are seen in D do not get redistributed into EIGRP to F. Any ideas?

5 REPLIES

Re: BGP not Redistributing into EIGRP

Hi,

I guess this is something to do with the Route Summarization / Auto Summary.

Request you to paste the sh ip route output from the D and F devices.

Regards,

Wilson Samuel

Gold

Re: BGP not Redistributing into EIGRP

When you redistribute things into eigrp you must specify a metric or use the default metric command. If you don't it sorta ignore the redistribution command. I think the only one that works without a metric is another eigrp or igrp.

Purple

Re: BGP not Redistributing into EIGRP

this may apply in your case may need no auto summary on the EIGRP process.

By default, BGP does not accept subnets redistributed from IGP. To advertise and carry subnet routes in BGP, use an explicit network command or the no auto-summary command. If you disable auto-summarization and have not entered a network command, you will not advertise network routes for networks with subnet routes unless they contain a summary route.

EIGRP summary routes are given an administrative

value of 5. You cannot configure this value.

RIP Version 1 always uses automatic summarization. If you are using RIP Version 2, you can turn off automatic summarization by specifying no auto-summary. Disable automatic summarization if you must perform routing between disconnected subnets. When automatic summarization is off, subnets are advertised.

Examples

The following example disables automatic summarization for process eigrp 109:

router eigrp 109

no auto-summary

Re: BGP not Redistributing into EIGRP

Hi Jacob,

When you redistribute routes from BGP into an IGP, by default only EBGP routes are redistributed.

You can issue the bgp redistribute-internal command followed by clearing all BGP sessions to permit the redistribution of IBGP routes in addition to EBGP routes.

(config-router)#bgp redistribute-internal

#clear ip bgp *

HTH, rate if it does

Narayan

Bronze

Re: BGP not Redistributing into EIGRP

hi

i totaly agree with the post of (tdrais), when you redistribute route into rip/IGRP/EIGRP the metric is infinity that means that the redistributed routes are unreachable ( not present in the routing table ) so you have to specify a seed metric for that. use (default-metric a b c d e ) or (redistribute bgp xxx metric a b c d e).

HTH

2390
Views
7
Helpful
5
Replies