Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP problem

Hi,
need to configure a BGP between 2 switched cisco 3750.
I've configured the BGP but I can't distribute the net 200.168.57.168/27 to the sw3750NUMBER2 (see below the conf.).
Please can someone help me ?
sw3750NUMBER1
!
interface Vlan3231
description ** BGP session interface **
ip address 169.254.231.1 255.255.255.248
!
router bgp 65534
no synchronization
bgp router-id 169.254.231.1
bgp log-neighbor-changes
network 192.168.57.128 mask 255.255.255.224
neighbor 169.254.231.5 remote-as 65532
neighbor 169.254.231.5 transport path-mtu-discovery
neighbor 169.254.231.5 description ** to - sw3750NUMBER2 - Vlan3231 **
neighbor 169.254.231.5 update-source Vlan3231
neighbor 169.254.231.5 soft-reconfiguration inbound
neighbor 169.254.231.5 prefix-list 169.254.231.5-in in
neighbor 169.254.231.5 prefix-list 169.254.231.5-out out
no auto-summary
!
!
ip prefix-list 169.254.231.5-in seq 5 permit 169.254.231.0/29
!
ip prefix-list 169.254.231.5-out seq 5 permit 169.254.231.0/29
ip prefix-list 169.254.231.5-out seq 10 permit 192.168.57.128/27
ip prefix-list 169.254.231.5-out seq 15 permit 200.168.57.128/27
!
sw3750NUMBER2
!
interface Vlan3231
description ** BGP session interface **
ip address 169.254.231.5 255.255.255.248
!        
router bgp 65532
no synchronization
bgp router-id 169.254.231.5
bgp log-neighbor-changes
network 169.254.231.0 mask 255.255.255.248
neighbor 169.254.231.1 remote-as 65534
neighbor 169.254.231.1 transport path-mtu-discovery
neighbor 169.254.231.1 description ** to - sw3750NUMBER1 - Vlan3231 **
neighbor 169.254.231.1 update-source Vlan3231
neighbor 169.254.231.1 soft-reconfiguration inbound
neighbor 169.254.231.1 prefix-list 169.254.231.1-in in
neighbor 169.254.231.1 prefix-list 169.254.231.1-out out
no auto-summary
!
!
ip prefix-list 169.254.231.1-in seq 5 permit 192.168.57.128/27
ip prefix-list 169.254.231.1-in seq 10 permit 169.254.231.0/29
ip prefix-list 169.254.231.1-in seq 15 permit 200.168.57.128/27
!
ip prefix-list 169.254.231.1-out seq 5 permit 169.254.231.0/29
!
sw3750NUMBER1#
sw3750NUMBER1#$eighbors 169.254.231.5 advertised-routes
BGP table version is 6, local router ID is 169.254.231.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.57.128/27
                    0.0.0.0                  0         32768 i
Total number of prefixes 1
itmil-calinf0r2-sw01DCMItoDCVR#sh ip bgp                                
BGP table version is 6, local router ID is 169.254.231.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
r> 169.254.231.0/29 169.254.231.5            0             0 65532 i
*> 192.168.57.128/27
                    0.0.0.0                  0         32768 i
* i                 192.168.57.130           0    100      0 i
* i                 192.168.57.129           0    100      0 i
sw3750NUMBER1#sh ip bgp neighbors 169.254.231.5        
BGP neighbor is 169.254.231.5,  remote AS 65532, external link
Description: ** CL - InfracomVR - sw3750masterVR - Vlan3231 **
  BGP version 4, remote router ID 169.254.231.5
  BGP state = Established, up for 00:02:03
  Last read 00:00:03, last write 00:00:29, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                139         40
    Notifications:         24         99
    Updates:               31         19
    Keepalives:          1571       1571
    Route Refresh:          1          1
    Total:               1766       1742
  Default minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
  BGP table version 6, neighbor version 6/0
  Output queue size : 0
  Index 3, Offset 0, Mask 0x8
  3 update-group member
  Inbound soft reconfiguration allowed
  Incoming update prefix filter list is 169.254.231.5-in
  Outgoing update prefix filter list is 169.254.231.5-out
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               1          1 (Consumes 52 bytes)
    Prefixes Total:                 2          1
    Implicit Withdraw:              1          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          1
    Used as multipath:            n/a          0
                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Bestpath from this peer:              1        n/a
    Total:                                1          0
  Number of NLRIs in the update sent: max 1, min 1
  Address tracking is enabled, the RIB does have a route to 169.254.231.5
  Address tracking requires at least a /29 route to the peer
  Connections established 17; dropped 16
  Last reset 00:02:15, due to User reset
  Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Mininum incoming TTL 0, Outgoing TTL 1
Local host: 169.254.231.1, Local port: 38162
Foreign host: 169.254.231.5, Foreign port: 179
Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)
Event Timers (current time is 0xAC9D4E0):
Timer          Starts    Wakeups            Next
Retrans             6          0             0x0
TimeWait            0          0             0x0
AckHold             4          3             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            1          0       0xAD0DC62
DeadWait            0          0             0x0
iss:  995371965  snduna:  995372167  sndnxt:  995372167     sndwnd:  16183
irs:   16606577  rcvnxt:   16606752  rcvwnd:      16210  delrcvwnd:    174
SRTT: 165 ms, RTTO: 1172 ms, RTV: 1007 ms, KRTT: 0 ms
minRTT: 8 ms, maxRTT: 300 ms, ACK hold: 200 ms
Flags: higher precedence, nagle, path mtu capable, md5
Datagrams (max data segment is 1440 bytes):
Rcvd: 10 (out of order: 0), with data: 6, total data bytes: 174
Sent: 11 (retransmit: 0), with data: 6, total data bytes: 201
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: BGP problem

r.taccon wrote:

Hi,
need to configure a BGP between 2 switched cisco 3750.
I've configured the BGP but I can't distribute the net 200.168.57.168/27 to the sw3750NUMBER2 (see below the conf.).
Please can someone help me ?
sw3750NUMBER1
!
interface Vlan3231
description ** BGP session interface **
ip address 169.254.231.1 255.255.255.248
!
router bgp 65534
no synchronization
bgp router-id 169.254.231.1
bgp log-neighbor-changes
network 192.168.57.128 mask 255.255.255.224
neighbor 169.254.231.5 remote-as 65532
neighbor 169.254.231.5 transport path-mtu-discovery
neighbor 169.254.231.5 description ** to - sw3750NUMBER2 - Vlan3231 **
neighbor 169.254.231.5 update-source Vlan3231
neighbor 169.254.231.5 soft-reconfiguration inbound
neighbor 169.254.231.5 prefix-list 169.254.231.5-in in
neighbor 169.254.231.5 prefix-list 169.254.231.5-out out
no auto-summary
!
!
ip prefix-list 169.254.231.5-in seq 5 permit 169.254.231.0/29
!
ip prefix-list 169.254.231.5-out seq 5 permit 169.254.231.0/29
ip prefix-list 169.254.231.5-out seq 10 permit 192.168.57.128/27
ip prefix-list 169.254.231.5-out seq 15 permit 200.168.57.128/27
!

Is this a typo in your router bgp config because you do not have a network statement for that route so unless you are receiving it from another peer you will need to add in a network statement. You will also need an entry in the routing table on switch1 for that network

router bgp 65534

network 200.168.57.128 mask 255.255.255.224

Jon

1 REPLY
Hall of Fame Super Blue

Re: BGP problem

r.taccon wrote:

Hi,
need to configure a BGP between 2 switched cisco 3750.
I've configured the BGP but I can't distribute the net 200.168.57.168/27 to the sw3750NUMBER2 (see below the conf.).
Please can someone help me ?
sw3750NUMBER1
!
interface Vlan3231
description ** BGP session interface **
ip address 169.254.231.1 255.255.255.248
!
router bgp 65534
no synchronization
bgp router-id 169.254.231.1
bgp log-neighbor-changes
network 192.168.57.128 mask 255.255.255.224
neighbor 169.254.231.5 remote-as 65532
neighbor 169.254.231.5 transport path-mtu-discovery
neighbor 169.254.231.5 description ** to - sw3750NUMBER2 - Vlan3231 **
neighbor 169.254.231.5 update-source Vlan3231
neighbor 169.254.231.5 soft-reconfiguration inbound
neighbor 169.254.231.5 prefix-list 169.254.231.5-in in
neighbor 169.254.231.5 prefix-list 169.254.231.5-out out
no auto-summary
!
!
ip prefix-list 169.254.231.5-in seq 5 permit 169.254.231.0/29
!
ip prefix-list 169.254.231.5-out seq 5 permit 169.254.231.0/29
ip prefix-list 169.254.231.5-out seq 10 permit 192.168.57.128/27
ip prefix-list 169.254.231.5-out seq 15 permit 200.168.57.128/27
!

Is this a typo in your router bgp config because you do not have a network statement for that route so unless you are receiving it from another peer you will need to add in a network statement. You will also need an entry in the routing table on switch1 for that network

router bgp 65534

network 200.168.57.128 mask 255.255.255.224

Jon

1186
Views
0
Helpful
1
Replies
CreatePlease to create content