Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Anonymous
N/A

BGP redistribution to EIGRP

Hi all,

I'm trying to redistribute BGP to EIGRP and vice versa. I am succussfully redistributing EIGRP to BGP, but can't get EIGRP routes into BGP.

                

Here's my config. Any guidance or assistance would be very much appreciated. 

router eigrp 100

network 10.18.72.0 0.0.0.255

redistribute static route-map DEFAULT_ROUTE

redistribute bgp 65535

passive-interface default

no passive-interface FastEthernet0/0

!

router bgp 65535

bgp router-id 172.18.2.1

bgp log-neighbor-changes

redistribute eigrp 100 route-map EIGRP_REDISTRIBUTE

neighbor 172.18.2.2 remote-as 65535

neighbor 172.18.2.2 password ciscobgp

no auto-summary

ip access-list extended EIGRP_ROUTES_TO_BGP

permit ip any any

!

!

ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0

!

route-map EIGRP_REDISTRIBUTE permit 20

match ip address EIGRP_ROUTES_TO_BGP

!

route-map DEFAULT_ROUTE permit 10

match ip address prefix-list DEFAULT

Thanks in advance.

Neil

Male extra pilule pour bander
Everyone's tags (3)
6 REPLIES

Re: BGP redistribution to EIGRP

Add "bgp redistribute-internal" to your bgp process. By default, iBGP doesn't redistribute into an IGP. The reason for this is simply the amount of routes that a bgp router can receive could overload an igp very easily, so you would definitely want to filter routes out when doing this.

After you add this, clear your bgp neighbors and you should start seeing routes.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Anonymous
N/A

BGP redistribution to EIGRP

ohn - thanks very much for this. Did the trick.

I appreciate the explanation too.

New Member

hey bro,have you found a

hey bro,have you found a solution already to work out this problem,i also have a similiar question like yours.  

if you found a solution ,and it did work,mail to 381545803@qq.com ,to help me solve it,thank you!

New Member

Hey Guys,I think the problem

Hey Guys,

I think the problem is that you don't have a metric assigned to the redistribution statement under eigrp.

redistribute bgp 65535 metric 100000 500 255 1 1500

Thanks,

Mark

New Member

This is exactly what I needed

This is exactly what I needed.

Thank you!

New Member

Yep, adding the bgp

Yep, adding the bgp redistribute-internal to the BGP config and redistribute bgp <AS_NUM> metric 100000 500 255 1 1500 to the EIGRP config sorted this out for me... so both of these answers combined from [@j.blakley] & makrez969 did the trick. Thanks!

27956
Views
58
Helpful
6
Replies