cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
579
Views
0
Helpful
6
Replies

BGP Routing Problem using Route-map

Sabby0115
Level 1
Level 1

Hello Everyone

I have an issue with BGP routing lab. I want to ping loopback 1 from R1 to loop 6 in R6 & vice versa , but i don’t want any other router into routing table except BGP peers & loopback1,6&7. All other config is working fine is working well. but in R2 under bgp process when I do redistribute ospf 1 route-map xyz it won’t pass the ping to the destination. I am putting my config file so you guys can find my error.

bgp1.png

hostname R1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

!

interface Loopback1

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip address 172.30.1.1 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

router ospf 1

router-id 1.1.1.1

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0

network 172.30.1.1 0.0.0.0 area 0

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

end

----

R2

-----

hostname R2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

interface FastEthernet0/0

ip address 172.30.3.2 255.255.255.252

duplex auto

speed auto

!

interface Serial0/0

ip address 62.150.1.1 255.255.255.252

clock rate 2000000

!

interface FastEthernet0/1

ip address 172.30.1.2 255.255.255.252

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

router ospf 1

router-id 2.2.2.2

log-adjacency-changes

redistribute bgp 5500

network 172.30.1.2 0.0.0.0 area 0

default-information originate always

!

router bgp 5500

no synchronization

bgp log-neighbor-changes

redistribute ospf 1 route-map OSPF_FILTER

neighbor 62.150.1.2 remote-as 777

neighbor 172.30.3.1 remote-as 5500

no auto-summary

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

access-list 1 permit 1.1.1.1

access-list 1 deny   172.30.1.0 0.0.0.255

!

route-map OSPF_FILTER permit 10

match ip address 1

!

!

!

control-plane

!

!

!

end

----

R3

-----

hostname R3

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

interface FastEthernet0/0

ip address 172.30.3.1 255.255.255.252

duplex auto

speed auto

!

interface Serial0/0

ip address 62.150.2.1 255.255.255.252

clock rate 2000000

!

interface FastEthernet0/1

ip address 172.30.2.2 255.255.255.252

ip ospf priority 0

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

router ospf 1

router-id 3.3.3.3

log-adjacency-changes

network 172.30.2.2 0.0.0.0 area 0

!

router bgp 5500

no synchronization

bgp log-neighbor-changes

neighbor 62.150.2.2 remote-as 777

neighbor 172.30.3.2 remote-as 5500

no auto-summary

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

end

----

R4

-----

hostname R4

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 62.150.1.2 255.255.255.252

clock rate 2000000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

ip address 168.187.1.1 255.255.255.252

clock rate 2000000

!

router bgp 777

no synchronization

bgp log-neighbor-changes

redistribute connected

neighbor 62.150.1.1 remote-as 5500

neighbor 168.187.1.2 remote-as 911

no auto-summary

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

end

---

R5

-----

hostname R5

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 62.150.2.2 255.255.255.252

clock rate 2000000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

ip address 168.187.2.1 255.255.255.252

clock rate 2000000

!

router bgp 777

no synchronization

bgp log-neighbor-changes

redistribute connected

neighbor 62.150.2.1 remote-as 5500

neighbor 168.187.2.2 remote-as 711

no auto-summary

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

end

------

R6

-----

hostname R6

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

interface Loopback1

ip address 6.6.6.6 255.255.255.255

!

interface Loopback60

ip address 160.6.60.1 255.255.255.0

!

interface Loopback66

ip address 160.6.66.1 255.255.255.0

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 168.187.1.2 255.255.255.252

clock rate 2000000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

ip address 7.30.1.1 255.255.255.252

clock rate 2000000

!

router bgp 911

no synchronization

bgp log-neighbor-changes

redistribute connected route-map ROUTE_FILTER_160

neighbor 7.30.1.2 remote-as 711

neighbor 168.187.1.1 remote-as 777

no auto-summary

!

ip forward-protocol nd

ip route 160.6.60.0 255.255.255.0 Null0

ip route 160.6.66.0 255.255.255.0 Null0

!

!

ip http server

no ip http secure-server

!

ip access-list standard BLOCK-160

permit 160.6.60.0 0.0.0.255

permit 160.6.66.0 0.0.0.255

deny   any

!

!

route-map ROUTE_FILTER_160 deny 10

match ip address BLOCK-160

set origin igp

!

route-map ROUTE_FILTER_160 permit 15

!

!

!

control-plane

!

!

end

-----

R7

-----

!

hostname R7

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

interface Loopback1

ip address 7.7.7.7 255.255.255.255

!

interface Loopback70

ip address 170.7.70.1 255.255.255.0

!

interface Loopback77

ip address 170.7.77.1 255.255.255.0

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 168.187.2.2 255.255.255.252

clock rate 2000000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

ip address 7.30.1.2 255.255.255.252

clock rate 2000000

!

router bgp 711

no synchronization

bgp log-neighbor-changes

redistribute connected route-map ROUTE_FILTER_170

neighbor 7.30.1.1 remote-as 911

neighbor 168.187.2.1 remote-as 777

no auto-summary

!

ip forward-protocol nd

ip route 170.7.7.0 255.255.255.0 Null0

ip route 170.7.77.0 255.255.255.0 Null0

!

!

ip http server

no ip http secure-server

!

ip access-list standard BLOC-170

permit 170.7.70.0 0.0.0.255

permit 170.7.77.0 0.0.0.255

deny   any

!

!

route-map ROUTE_FILTER_170 deny 10

match ip address BLOC-170

!

route-map ROUTE_FILTER_170 permit 20

!

!

!

control-plane

!

end

Thanking you in Advance....

Sabby

(lab pic is attached)

6 Replies 6

Hi Sarbjit,

Please include keyword subnet in OSPF redistributions and check if problem still persists...

HTH,

Smitesh

PS: Please rate helpful posts...

Thanks for reply....no it is not working...i ping from R2 it is pinging... but when i ping it with source fa0/1 failed....

Hello Sarabjit,

Are you trying to ping from source f0/1 of R2? If yes, then it won't ping. The reason is, your access-list denies the network to be advertised into the eBGP.

Do you see the route for 1.1.1.1/32 on R4 ?

R4#sh ip route

Codes: deleted

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

B       1.1.1.1 [20/11] via 62.150.1.1, 00:00:05

     168.187.0.0/30 is subnetted, 2 subnets

B       168.187.2.0 [20/0] via 168.187.1.2, 00:00:06

C       168.187.1.0 is directly connected, Serial0/1

     6.0.0.0/32 is subnetted, 1 subnets

B       6.6.6.6 [20/0] via 168.187.1.2, 00:00:06

     7.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

B       7.7.7.7/32 [20/0] via 168.187.1.2, 00:00:06

B       7.30.1.0/30 [20/0] via 168.187.1.2, 00:00:06

     62.0.0.0/30 is subnetted, 1 subnets

C       62.150.1.0 is directly connected, Serial0/0

yh it showing in there

Sabby0115
Level 1
Level 1

fixed......i restarted the lab...it works

Sabby0115
Level 1
Level 1

Thanks...All for your kind support

Review Cisco Networking products for a $25 gift card