Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP with two isps and extra configs

Hello,

We have:

ISP-A

ISP-B

BOTH ISP's have BGP passwords set.

We want to be multihomed with those ISP's, but we have 4 blocks of IP's to announce.

208.65.XX.XX /22

208.66.XX.XX /22

208.75.XX.XX /22

76.76.XX.XX /19

Basically what we want done is setup multihoming with redundancy on both. But we want to force traffic of 76.76.XX.XX /19 out on ISP-B and if that ISP is down, then it should route through ISP-A.

Basically when both are UP, the traffic from all subnets except 76.76.XX.XX /19 should go through ISP-A, and 76.76.XX.XX /19 through ISP-B. IF ISP-A is down, then everything should route through ISP-B (redundancy).

So we need:

1. Multihoming

2. Redundancy

3. Priority of 76.76.XX.XX /19 through ISP-B

Can someone provide an exact list of commands and configs which should be done?

Thank You

3 REPLIES
New Member

Re: BGP with two isps and extra configs

I wanted to add, that the 3 other networks should route always through ISP-A when it is available and not down.

Basically, I want the 3 ISP's to advertise all my routes and then I control what goes out from where.

Thank You

Re: BGP with two isps and extra configs

Hi,

If you want few of your IP's traffic exit via. one ISP and other via another ISP then it is not possible with BGP.

but yes,

If you want that  some of your LAN ip's incoming traffic will come via. one ISP i.e 76.76.xx.xx/19 and rest from other LAN IP's traffic come via another ISP then it is possible with below pasted config.

-------for ISP-A-----

208.65.XX.XX /22

208.66.XX.XX /22

208.75.XX.XX /22

76.76.XX.XX /19

ip prefix-list ISP-A-PRIMARY permit 208.65.XX.XX /22
ip prefix-list ISP-A-PRIMARY permit 208.66.XX.XX /22
ip prefix-list ISP-A-PRIMARY permit 208.75.XX.XX /22

ip prefix-list ISP-B-PRIMARY permit 76.76.XX.XX /19

route-map ISP-A-OUT  permit 10
match ip address prefix-list ISP-A-PRIMARY

route-map ISP-A-PRIMARY-OUT  permit 10
match ip address prefix-list ISP-B-PRIMARY
set as-path-prepend 65001 65001 65001

router bgp 65001

  neighbor 10.10.10.1 remote-as XXXX
  neighbor 10.10.10.1 activate
  neighbor 10.10.10.1 route-map ISP-A-OUT out
  no auto-summary
  no synchronization
  bgp dampening
  exit-address-family

-------for ISP-B-----

route-map ISP-B-OUT  permit 10
match ip address prefix-list ISP-B-PRIMARY

route-map ISP-B-PRIMARY-OUT  permit 10
match ip address prefix-list ISP-A-PRIMARY

set as-path-prepend 65001 65001 65001

router bgp 65001
  neighbor 10.10.10.5 remote-as XXXX
  neighbor 10.10.10.5 activate
  neighbor 10.10.10.5 route-map ISP-B-OUT out
  no auto-summary
  no synchronization
  bgp dampening
  exit-address-family

If you want to affect your outgoing traffic then it depends upon what your ISP is advertising to you.

If you want to use both your ISP to affect outgoing traffic then you need to do some manipulation to what your ISP is advertising to you.

Regarding your next query you can ak your both ISP to permit all your four prefix.

please mark a post as complete if it really solved your problem.

Regards

mahesh

Hall of Fame Super Silver

Re: BGP with two isps and extra configs

Hello Mahesh,

you have used two different names for the route-map blocks for ISP A  but the concept is clear.

However, with BGP you are covering the return path from internet to the border router not how traffic is sent out to the internet.

If a routing decision has to be  taken based on the source address, like in the request from original poster, we need to realize that BGP cannot do this : even if it has many tools and it is rich in features BGP is still a dynamic routing that attempts to route based on destination address only.

In order to implement a route traffic to ISPB when source is in range 76.76.x.x/19 we need to use policy based routing on edge router(s)

access-list 111 permit ip 76.76.x.x 0.7.255.255 any

route-map net76toISPB permit 10

match  address 111

set ip next-hop

on internal interface(s) that receive traffic to the internet we  need to apply a PBR rule invoking the above route-maps (that work on live traffic not on routing updates as the route-maps used in BGP router process)

interface g0/0

ip policy route-map net76toISPB

in order to prefer ISPA to ISPB you can take advantage of weight if the BGP border router is only one or from BGP local preference

router 65001

neigh ISPA local-preference 200

neigh ISPA route-map ISP-A-out out

Hope to help

Giuseppe

429
Views
0
Helpful
3
Replies