Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Bizarre Network Issue When a Powered Down Server Melted The Network

The setup 2 6506’s with single SUP32’s in each, running OSPF with one area, SW6 is Full/DR & SW8 is Full/BDR. HSRP is configured on both switches with SW6 Active and SW8 Standy. IP SLP is configured with a single vserver using VLAN14 and SW6 is standby and SW8 is operational. One 2003 server using VLAN12 and its configured with dual nics, one goes to SW6 & one goes to SW8 and both nics are setup in a team.

Now the problem: The server guys were migrating a server, normal stuff right. Well when they powered off the old server, SW6 processor spiked and SW8 had no issues. When I look at the logs the associated interface for the server, goes up down several times on both switches. Then I see OSPF neighbors for VLAN 12 switch from FULL to DOWN and LOADING to FULL on both switches. Then my HSRP bounces back and forth between Standby and Active for all VLANS on both switches. I also saw duplicate address for my IP SLP on VLAN 14.

This problem continued with OSPF bouncing back and forth, VLANS flapping, HSRP bouncing for thirty minutes as I tried to figure out the problem. It was only after the server guy came back to me and said his migration failed and he had to start up the old server again. Then it became clear to me that this single server had taken out my switch and caused major issues to my network. How can a single server cause this much issue? Any thoughts would be greatly appreciated.

2 REPLIES

Bizarre Network Issue When a Powered Down Server Melted The Netw

HI Bret,

at very first impression i would think about the Server being able to inject OSPF packets in your network and/or BPDU. It would be great if you could send the config of the OSPF process and the switch port where this server was connected to.

As firts attempt i would make sure that a passive-interface command is in place for the fastethernet that is connecting the server as a portfast of course.. And defninitely you should ask to the server guys about the capabilities of the new server and the NICs configuration.

Alessio

New Member

Bizarre Network Issue When a Powered Down Server Melted The Netw

Thanks for the ideas Alessio, and using passive interface was my first thoughts as well. However, I was able to fix my issue this morning. Apparently, this was monitoring server at one time. So I did a packet capture of the server interface and saw several devices sending SNMP traps to the server, devices like WLC, server, routers etc. My guess is the problem occurred when the SNMP trap was sent to the server. When it couldn’t find it, a broadcast was sent from the sending device, or the packet got to the destination and continued to look for it causing some sort of loop. I really cannot explain it, but after cleaning up those SNMP devices I was able to successfully shut the server down.

158
Views
0
Helpful
2
Replies