Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Bond two VDSL connections with dual EHWIC-VA-DSL-A?

Can it be done?  I have a Cisco 1921 with two of these cards.  Thanks to

Mithun Puttamadaiah on another post i got the config going.  Theres a surprising lack of documentation on this card.

But I do have 2 vdsl lines coming into this facility, so how do i go about bonding them together?

My first assumption is i need to configure ATM.

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Bond two VDSL connections with dual EHWIC-VA-DSL-A?

Hello.

What are the services provider sells you with the links?

Is it just simple Internet access?

Have I understood you correctly, that:

  • you have different set of credentials per link;
  • each link has different IP-address assigned;
  • the service (links) are provided by some provider;
  • you are using the links for Internet access.

If so, then to utilize both links you need to ask your provider to bundle the links together, into single L3 interface.

PS: your diagram has no port names, so I don't understand what is the role for E0/1/0 and E0/0/0.

PS2: why do you use dialer-pool 1 and 2 on both ATM0/0/0 and ATM0/1/0? Why do you use dialer-pool on Ethernet interfaces?

PS3: if you are not sure about configuration, then for implementation it worth to have anybody on site with 3G modem to allow you remote access.

4 REPLIES

Bond two VDSL connections with dual EHWIC-VA-DSL-A?

Hello.

Could you share your current configuration and interconnection diagram?

If you are using ppp encapsulation and both lines are terminated on a single remote device, you could use ppp multilink. Otherwise you may use equal-path load balancing with capable IGP.

New Member

Re: Bond two VDSL connections with dual EHWIC-VA-DSL-A?

Sure thing.  This is just a config that I pieced together.  No idea what works or doesn't since it needs to be shipped to the remote location.  But this is for starters at least....I know if have the Bell.ca modems in the attached pic, i'm thinking they will actually be removed.  I'd rather come right from the wall jacks to the router on the outside.  Gig 0/0 will patch over to X3 on the Sonicwall, and X0 will patch over to the switch. 

I still need to lock it down, but right now I'm more interested in just getting an internet connection since I'll be configuring the final version remotely with no IT support on the remote end.

DPAI#sh run

Building configuration...

Current configuration : 2786 bytes

!

! Last configuration change at 17:37:54 UTC Tue Feb 4 2014

version 15.2

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname DPAI

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

no ipv6 cef

no ip source-route

!

!

!

!

!

ip cef

multilink bundle-name authenticated

!

!

!

license udi pid CISCO1921/K9 sn FGL1532220J

!

!

!

!

controller VDSL 0/0/0

operating mode vdsl2

sra

!

controller VDSL 0/1/0

operating mode vdsl2

sra

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface ATM0/0/0

no ip address

ip nat outside

ip virtual-reassembly in

no atm ilmi-keepalive

pvc 0/35

  pppoe-client dial-pool-number 2

  pppoe-client dial-pool-number 1

!

!

interface Ethernet0/0/0

no ip address

pppoe enable group global

pppoe-client dial-pool-number 2

pppoe-client dial-pool-number 1

!

interface ATM0/1/0

no ip address

ip nat outside

ip virtual-reassembly in

no atm ilmi-keepalive

pvc 8/35

  pppoe-client dial-pool-number 2

  pppoe-client dial-pool-number 1

!

!

interface Ethernet0/1/0

no ip address

pppoe enable group global

pppoe-client dial-pool-number 2

pppoe-client dial-pool-number 1

!

interface Dialer1

mtu 1460

ip address 70.55.236.225 255.255.255.0

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap chap callout

ppp chap hostname txxxx@bellnet.ca

ppp chap password 7 044F5B515E725E4B0E

ppp pap sent-username txxxx@bellnet.ca password 7 044F5B515E725E4B0E59

!

interface Dialer2

mtu 1460

ip address 76.70.1.69 255.255.255.0

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 2

dialer-group 2

ppp authentication pap chap callout

ppp chap hostname txxxx@bellnet.ca

ppp chap password 7 03100B5D5F5C334949

ppp pap sent-username txxxx@bellnet.ca password 7 09581E5F405605170C4C

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip nat source static tcp 192.168.1.253 4433 interface GigabitEthernet0/0 4433

ip nat inside source list 99 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 99 permit 192.168.1.0 0.0.0.255

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

!

end

And yes, the dialer info, ATM, pretty much anything with the VA-DSL-A card I was pretty much winging.  If you see anything that's not needed/wrong/incomplete or just plain nonsensical, by all means let me know.  It's connecting to 2 VDSL lines in Ontario and Bell Canada does not support this config.

Thanks again.

Re: Bond two VDSL connections with dual EHWIC-VA-DSL-A?

Hello.

What are the services provider sells you with the links?

Is it just simple Internet access?

Have I understood you correctly, that:

  • you have different set of credentials per link;
  • each link has different IP-address assigned;
  • the service (links) are provided by some provider;
  • you are using the links for Internet access.

If so, then to utilize both links you need to ask your provider to bundle the links together, into single L3 interface.

PS: your diagram has no port names, so I don't understand what is the role for E0/1/0 and E0/0/0.

PS2: why do you use dialer-pool 1 and 2 on both ATM0/0/0 and ATM0/1/0? Why do you use dialer-pool on Ethernet interfaces?

PS3: if you are not sure about configuration, then for implementation it worth to have anybody on site with 3G modem to allow you remote access.

New Member

Re: Bond two VDSL connections with dual EHWIC-VA-DSL-A?

Actually you helped more than you know right now...yes, set of creds per link and different IP's....what i really needed to know was WHO was supposed to bond them.  This was sold to our customer completely incorrectly and I'm just trying to triage the situation.  But I have very very limited experience with DSL......

I have more than i need configured simply because I had the router in my posession.  It has now been shipped to the site.  I will have a non-IT person that will plug it in, hook up the console cable to a laptop, and use a 3rd internet connection that I'll be able to remote in and configure, change, troubleshoot, and debug this setup.

So, to PS2 above, I'm going to be using ATM, ethernet was done only becaue the config allowed me to

But I was a little confused, admittedly, on the dialer pools as I thought each dialer had to be in it's own pool.  That will be the first change I make on the config.

So thank you, very much appreciated.  We'll see next week how it goes when it gets all hooked up.

607
Views
0
Helpful
4
Replies