Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Borderless campus Qos and IP phones

Hi,

After reading the borderless campus qos recommendation for this document, I'm a bit confused by the settings on
on the classification of voip RTP traffic.

http://www.cisco.com/en/US/docs/solutions/Enterprise/Campus/Borderless_Campus_Network_1.0/BN_Campus_QoS.html


cr22-4507-LB(config)#ip access-list extended MULTIMEDIA-CONFERENCING

cr22-4507-LB(config-ext-nacl)# remark RTP

cr22-4507-LB(config-ext-nacl)# permit udp any any range 16384 32767


cr22-4507-LB(config-ext-nacl)#ip access-list extended SIGNALING

cr22-4507-LB(config-ext-nacl)# remark SCCP

cr22-4507-LB(config-ext-nacl)# permit tcp any any range 2000 2002

cr22-4507-LB(config-ext-nacl)# remark SIP

cr22-4507-LB(config-ext-nacl)# permit tcp any any range 5060 5061

cr22-4507-LB(config-ext-nacl)# permit udp any any range 5060 5061


....... 

Class-map
 
cr22-4507-LB(config)#class-map match-all VVLAN-SIGNALING
cr22-4507-LB(config-cmap)# match ip dscp cs3


cr22-4507-LB(config-cmap)#class-map match-all VVLAN-VOIP
cr22-4507-LB(config-cmap)# match ip dscp ef 


cr22-4507-LB(config-cmap)#class-map match-all MULTIMEDIA-CONFERENCING
cr22-4507-LB(config-cmap)# match access-group name MULTIMEDIA-CONFERENCING


cr22-4507-LB(config-cmap)#class-map match-all SIGNALING
cr22-4507-LB(config-cmap)# match access-group name SIGNALING


.....

policing
cr24-3750-LB(config)#policy-map Phone+PC-Policy
cr24-3750-LB(config-pmap)# class VVLAN-VOIP
cr24-3750-LB(config-pmap-c)#  police 128000 8000 exceed-action drop
cr24-3750-LB(config-pmap-c)# class VVLAN-SIGNALING
cr24-3750-LB(config-pmap-c)#  police 32000 8000 exceed-action drop
cr24-3750-LB(config-pmap-c)# class MULTIMEDIA-CONFERENCING
cr24-3750-LB(config-pmap-c)#  police 5000000 8000 exceed-action drop
cr24-3750-LB(config-pmap-c)# class SIGNALING
cr24-3750-LB(config-pmap-c)#  police 32000 8000 exceed-action drop
....
marking
cr22-3750-LB(config)#policy-map Phone+PC-Policy
cr22-3750-LB(config-pmap)# class VVLAN-VOIP
cr22-3750-LB(config-pmap-c)#  set dscp ef
cr22-3750-LB(config-pmap-c)# class VVLAN-SIGNALING
cr22-3750-LB(config-pmap-c)#  set dscp cs3
cr22-3750-LB(config-pmap-c)# class MULTIMEDIA-CONFERENCING
cr22-3750-LB(config-pmap-c)#  set dscp af41
cr22-3750-LB(config-pmap-c)# class SIGNALING
cr22-3750-LB(config-pmap-c)#  set dscp cs3
cr22-3750-LB(config-pmap-c)# class TRANSACTIONAL-DATA
cr22-3750-LB(config-pmap-c)#  set dscp af21
cr22-3750-LB(config-pmap-c)# class BULK-DATA
cr22-3750-LB(config-pmap-c)#  set dscp af11
cr22-3750-LB(config-pmap-c)# class SCAVENGER
cr22-3750-LB(config-pmap-c)#  set dscp cs1
cr22-3750-LB(config-pmap-c)# class DEFAULT
cr22-3750-LB(config-pmap-c)#  set dscp default



My questions are

1. Will this setting put the RTP traffic from a softphone behind the Cisco IP phone into the

MULTIMEDIA-CONFERENCING class, which was set to the DSCP af41 instead of EF eventually?

2. What if the IP phone  on this switchport is a non-cisco IP phone. (e.g. Avaya IP Phone.)

if the port is still configured as a conditional-trust port, will the same thing happen that the Avaya ip phone's

voip traffic will be set to default dscp value at the ingress first before it was classified by class

MULTIMEDIA-CONFERENCING and set to DSCP af41 instead of ef?

Is there any limitation of this settings?

Kevin

 


2 REPLIES
Green

Borderless campus Qos and IP phones


1) This policy would be applied to your switch port as an inbound policy on ingress.
The data will arrive serially at the port and each IP packet will inspected and
treated as per the policy.
The switchport has not control over the order of packet arrival. Therfore the ingress
packets will be treated in a first come first served fashion no matter whether they
are from the actual phone or any device behind it.

2) The AVAYA phone will not be sending rtp packet with udp port range 16384-32767 as these
are Cisco IPT values but can be matched as DHCP EF (46). For signalling it is best to ask
the AVAYA switch person to change thesignalling DSCP to CS3 (24) for traversing Cisco network kit.
This allows you to either just trust the DSCP
on a port or use the policy map.

!
interface fas 0/21
desc *** AVAYA PHONE & PC ***
mls qos trust dscp
queue-set 1
srr-queue bandwidth share 1 30 35 5
priority-queue out
!

The bandwidths should be similar between Cisco & Avaya phones.

HTH
Alex

Regards, Alex. Please rate useful posts.
New Member

Borderless campus Qos and IP phones

Thank you acampbell for your answers.

Actually my question is more on the marking part.

let's  say a PC behind a 3750 switch port, so switchport can't trust the DSCP setting from the PC.

Then CIPC rtp stream DSCP will be set to default.

Am I correct that once the CIPC RTP traffic hit the ingress, it will be caught by MULTIMEDIA-CONFERENCING class instead of

VVLAN-VOIP class and the DSCP will be set to AF41 while DSCP EF is preferred setting for RTP?

342
Views
0
Helpful
2
Replies
CreatePlease to create content