Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Bricked router... Whoops!

I tried to upgrade the IOS on my 2801 from 12.4(24)T1 to 12.4(24)T3 to get around a particular bug we were hitting. I FTP'd the IOS over and rebooted... I didn't verify the image before rebooting and I guess the image didnt fully transfer. The router now boots in ROMMON.

I'm fairly familiar with ROMMON and did the necessary configuration to get tftpdnld set up. The router was able to connect to my TFTP server and start to transfer the file, but after a while, it would just start to timeout. Both the TFTP server and the Router were saying that the remote side stopped responding. TFTP server and router are on the same VLAN.

My next idea was to set the speed on the console port higher than 9600 and then xmodem the image over. I've done that before and it's fairly straight forward. I followed the directions here to increase the speed of the console port to 115200bps :

I reset the router and established a new session via Hyperterminal. All I'm seeing now is Jibberish (that's an official term ). I've played with the settings in Hypterterminal and tried every port speed from 9600 up to 115200, still just junk. I've also played with the Parity, stop bits, and flow control. No luck. I tried the same with Putty as well and power cycled the router a few times just for good measure.

Any ideas how I can unbrick my router?


Re: Bricked router... Whoops!

So you did this:

Once in ROMmon, change the console baud rate from 9600 bps to 115200 bps to speed up the download time. Use the confreg command and complete the instructions presented on the screen.

rommon 1 >

Configuration Summary 
enabled are: 
break/abort has effect 
console baud: 9600 
boot: the ROM Monitor

do you wish to change the configuration? y/n [n]: y
enable "diagnostic mode"? y/n [n]:
enable "use net in IP bcast address"? y/n [n]:
enable "load rom after netboot fails"? y/n [n]:
enable "use all zero broadcast"? y/n [n]:
disable "break/abort has effect"? y/n [n]:
enable "ignore system config info"? y/n [n]:
change console baud rate? y/n [n]: y
enter rate: 0 = 9600, 1 = 4800, 2 = 1200, 3 = 2400
4 = 19200, 5 = 38400, 6 = 57600, 7 = 115200 [0]: 7
change the boot characteristics? y/n [n]:
Configuration Summary
enabled are:
break/abort has effect
console baud: 115200
boot: the ROM Monitor

do you wish to change the configuration? y/n [n]:
You must reset or power cycle for new config to take effect.

rommon 2 >

And now it just spits out "Jibberish", sounds like the baud rate isn't correct on the hyper-terminal session. I would go through the listed baud rates from the doc. Leave the rest of the settings default for a Cisco console connection and only change the baud rate.

I have in the past though I hit the correct baud rate and in the end found out I didn't and it was something else. This is pretty straight forward to change.


Re: Bricked router... Whoops!

I got it figured out. The console cable was too long for 115200. I had the router in my lab and the console cable was patched via a couple patch panel hops. Moved it to my desk and it's working fine now.

CreatePlease to create content