Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Bridging 2 different networks with a RV042?

I searched for this question and didn't find a complete answer so here's my issue.  (Any help greatly appreciated!)

I have 2 networks.

NETWORK 1:

EOC connection fro ISP going into a router (not the RV042) with a static WAN address from ISP.  This router is hooked up to a switch that all the computers are connected to.  All the computers on this network are using 192.168.1.x addresses.  Most of these addresses are static, but the router is running DHCP in case we hook up temporary computers like laptops or client machines to this network.

NETWORK 2:

DSL connection going into a router (not the RV042) with a static block of IPs from ISP.  (8 IPs, 5 usable for the WAN interface, 1 static IP is being used for WAN interface).  This router has a VPN connection set up for remote access to the linux machines on this network.  This router is running DHCP on the LAN interface for this network with addresses 172.16.1.x.  All the computers on this network are tied together with another switch, completely seperate from the 192.168.1.x network switch.

PROBLEM:

We needed computers on the 192 network to be able to access computers on the 172 network.  Someone decided to just run a cat 5 cable from the 192 switch to the 172 switch (not the routers, the switches).  This "worked" - badly.  Appearently there is a DHCP conflict (or something else going on) that was causing the router on the 172 network to try and assign addresses to the 192 network computers, and it was also "resetting" a connection about once an hour.  This crashed our server on the 192 network.  I disconnected that cat 5 cable between the two siwtches, and now each of the two networks are working properly, but they are now completely isolated from one another.

I need to create a bridge between the 2 networks so that machines on the 192 network can access machines on the 172 network while filtering out DHCP broadcasts from either network router to the other network.  (I may need to filter out other protocols as well, but don't know yet.)

So, I see 3 potential ways of doing this but don't know if they will work:

1) Can I just set up multiple subnets on the LAN interface of the RV042 and just run 2 cat5 cables from each switch on the two networks to the LAN ports of the RV042?

1a) If I do set up multiple subnets on the LAN interface of the RV042, do I need to assign the two ports to different VLANs?  (I don't see any way to set each port to a specific IP address.)

2) Can I set up the 2 WAN ports on the RV042, one static for each network, and will the RV042 route traffic from 1 WAN port to the second WAN port?

3) Is there some other way I should consider setting this up?

Finally, someone mentioned that once I get the RV042 set up correctly as a bridge, I will need to route 172 addresses on the 192 network to the 192 interface of the RV042 via the DHCP router on the 192 network, and conversely, I will need to route 192 addresses on the 172 network from the DHCP router to the 172 IP interface of the RV042.  I think this will be easy enough to set up in each of the DHCP routers...

I know this is complicated, but I'm sure the solution is probably easy once I know wHat ports to plug the 2 cat5 cables into (on the RV 042), and what settings to put into each router.

Thanks again!

PS: there seem to be a LOT of people with a similar issue, so any solution will help out a lot of people beside me.

3 REPLIES
Green

Re: Bridging 2 different networks with a RV042?

Hello Louis, here is a working scenario;

Using the RV042, you will have the same issue as when connecting to your switch, the DHCP will bleed over to both networks.

On my scenario here, the router on the left is 172.16.1.0 network. The router on the right is 192.168.1.0 network. To handle the way you want things to work here is the scenario;

  • Obtain a SF300 switch
  • Configure the following commands on the switch

set system mode router

reload

y

config t

vlan database

vlan 2

interface vlan 1

ip address 192.168.1.254 / 24

interface vlan 2

ip address 172.16.1.254 /24

interface fa01

switchport mode trunk

switchport trunk native vlan 1

interface fa02

switchport mode trunk

switchport native vlan 2

exit

exit

copy run start

  • This will set up your network to communicate between the subnet
  • The DHCP should be feeding the connecting computers the default gateway of the router it is connecting to
  • The DHCP will be respective so you may configure a port to be only on VLAN 2 and receive the VLAN 2 DHCP and the same applies for a port configure in VLAN 1
  • Each router will require a static route. The left router will need a route 192.168.1.0 255.255.255.0 172.16.1.254. The right router will need a route 172.16.1.0 255.255.255.0 192.168.1.254
  • The wiring will be simple, as you connect the left router, 172.16.1.0 in to the vlan 2 port (fa2) and the right router, 192.168.1.0 in to the vlan 1 port (fa1)

-Tom

Message was edited by: Thomas Watts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

Bridging 2 different networks with a RV042?

Will this one do the trick?

Cisco SF 300-08 (SRW208-K9-NA) 8-Port 10/100 Managed Switch

http://www.amazon.com/Cisco-SF-300-24-SRW224G4-K9-NA-24-Port/dp/B0041ORNFG

(I'm on a budget)

The diagram above is exactly the setup I want.  Neither network needs to access the Internet through the SF 300. 

Only LAN traffic will be going between the two networks via the SF 300.

However, if the VLAN interface(s) of the SF-300 are also the gateway of each network (either the 192 or the 172 respectively), and the SF300 has no direct connection to the Internet itself, won't that kill our Internet connection(s) on the two networks?

I still want to run Internet connections through the two routers (either side of the SF 300), as shown in the diagram above.  We don't need "cross" access to the Internet across the SF-300. 

Thanks again for the help!

- Louis

Green

Re: Bridging 2 different networks with a RV042?

Hi Louis,

I  made a mistake in my original post. The ip default gateway of the computers connecting will be the router LAN IP addresses. The part I did not include, you will need 2 static routes on the routers.

"Left" router 192.168.1.0 network will need a static route looking like;

172.16.1.0

255.255.255.0

192.168.1.254 <- the vlan interface IP address

"Right" router 172.16.1. network will also need a route

192.168.1.0

255.255.255.0

172.16.1.254 <- the vlan interface IP address

So the answer in short, yes, both internet will work through their correct gateway

-Tom

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
4132
Views
0
Helpful
3
Replies
CreatePlease login to create content