Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Bridging Issue

Hey Guys,

 

First time I am setting up bridging on my 887. I have done some research and looked at some solutions online although I have not had any luck sorting this one out. I have plugged my wireless router (which is assigning via dhcp) into fe0 assigned to vlan 100. clients on vlan 2 assigned to fe1/3. Not having any luck seeing the internet off vlan 2.

 

any help would be appreciated!

 

ip source-route
ip cef
!
ip dhcp excluded-address 192.168.120.1 192.168.120.20
ip dhcp excluded-address 192.168.254.1 192.168.254.20
!
ip dhcp pool vlan2-pool
 network 192.168.120.0 255.255.255.0
 dns-server 192.168.120.1 192.168.200.50 192.168.200.51
 default-router 192.168.120.1
 domain-name drh.local
!
ip dhcp pool vlan100-pool
 network 192.168.254.0 255.255.255.0
 dns-server 8.8.8.8 8.8.4.4
 default-router 192.168.254.1
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
no ipv6 cef
!
controller VDSL 0
!
bridge irb
!
interface ATM0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 no atm ilmi-keepalive
 bridge-group 100
 pvc 8/35
  encapsulation aal5snap
 !
!
interface Ethernet0
 no ip address
 shutdown
!
interface FastEthernet0
 switchport access vlan 100
 no ip address
!
interface FastEthernet1
 switchport access vlan 2
 no ip address
!
interface FastEthernet2
 switchport access vlan 2
 no ip address
!
interface FastEthernet3
 switchport access vlan 2
 no ip address
!
interface Wlan-GigabitEthernet0
 description Internal switch interface connecting to the embedded AP
 switchport mode trunk
 no ip address
!
interface wlan-ap0
 description Service module interface to manage the embedded AP
 ip address 192.168.121.1 255.255.255.0
!
interface Vlan2
 description Macquarie LAN
 ip address 192.168.120.1 255.255.255.0
 ip access-group vlan-control in
 ip helper-address 192.168.200.57
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan100
 description bridging interface
 ip address 192.168.254.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 ip tcp adjust-mss 1452
 bridge-group 100
!
interface BVI100
 no ip address
!
ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip dns server
ip nat inside source list internal-nat-list interface Vlan100 overload
ip route 0.0.0.0 0.0.0.0 Vlan100
!
ip access-list extended internal-nat-list
 permit ip 192.168.0.0 0.0.255.255 any
ip access-list extended terminal-acl
 permit tcp any any eq 22 log
ip access-list extended vlan-control
 permit ip any any
!
logging trap debugging
access-list 10 permit 192.168.0.0 0.0.0.255
!
bridge 100 protocol ieee
bridge 100 route ip
!

 

Cheers..

3 REPLIES
New Member

Some help would be great... :

Some help would be great... :)

You shouldn't assign IP to 

You shouldn't assign IP to  VLAN100 interface. The address is allocated to BVI interface.

New output

" interface Vlan100
 description bridging interface
 no ip address
 ip nat outside
 ip virtual-reassembly in
 ip tcp adjust-mss 1452
 bridge-group 100

 

interface BVI100
ip address 192.168.254.1 255.255.255.0

"

 

 

http://networkingcontrol.wordpress.com/ #CCNP CSCO11962956
New Member

Hi quatreduros, Thanks for

Hi quatreduros,

 

Thanks for the feedback. Unfortunately I still cannot see the internet router from the cisco vlan 2.

 

EDIT: Do I need to set the BVI's subnet to the subnet that of the other wireless router?

 

Say my wireless router is 192.168.111.1 and has DHCP running on it, do I set the BVI to 192.168.111.x? Or do I allow the BVI to grab an address from DHCP?

 

I have used dhcp on the bvi interface. I can now see the internet from the Cisco, but I might have a NAT problem? Still no internet on vlan 2.

 

Thanks mate!

50
Views
0
Helpful
3
Replies